summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-16 18:43:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-16 18:43:43 +0000
commit53bf9f1c49f7183bc2e45db574558d76aa17dd4a (patch)
tree9a2a5e88f7785eae0411e04cd19661db690ecdff /dev-libs/libgamin
parentMasking rb_libtorrent-0.15.0 (diff)
downloadgentoo-2-53bf9f1c49f7183bc2e45db574558d76aa17dd4a.tar.gz
gentoo-2-53bf9f1c49f7183bc2e45db574558d76aa17dd4a.tar.bz2
gentoo-2-53bf9f1c49f7183bc2e45db574558d76aa17dd4a.zip
Set SUPPORT_PYTHON_ABIS, don't build static version of Python module (bug #312187).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libgamin')
-rw-r--r--dev-libs/libgamin/ChangeLog9
-rw-r--r--dev-libs/libgamin/files/libgamin-0.1.10-disable_python_static_library.patch13
-rw-r--r--dev-libs/libgamin/libgamin-0.1.10-r2.ebuild58
3 files changed, 71 insertions, 9 deletions
diff --git a/dev-libs/libgamin/ChangeLog b/dev-libs/libgamin/ChangeLog
index f8c3ed0007df..ca1f9dfc7642 100644
--- a/dev-libs/libgamin/ChangeLog
+++ b/dev-libs/libgamin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgamin
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/ChangeLog,v 1.24 2009/09/25 10:51:18 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/ChangeLog,v 1.25 2010/06/16 18:43:43 arfrever Exp $
+
+ 16 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ libgamin-0.1.10-r2.ebuild,
+ +files/libgamin-0.1.10-disable_python_static_library.patch:
+ Set SUPPORT_PYTHON_ABIS, don't build static version of Python module (bug #312187).
25 Sep 2009; Diego E. Pettenò <flameeyes@gentoo.org>
-files/gamin-0.1.9-freebsd.patch, libgamin-0.1.10-r1.ebuild,
diff --git a/dev-libs/libgamin/files/libgamin-0.1.10-disable_python_static_library.patch b/dev-libs/libgamin/files/libgamin-0.1.10-disable_python_static_library.patch
new file mode 100644
index 000000000000..562fc071eac7
--- /dev/null
+++ b/dev-libs/libgamin/files/libgamin-0.1.10-disable_python_static_library.patch
@@ -0,0 +1,13 @@
+--- python/Makefile.am
++++ python/Makefile.am
+@@ -10,8 +10,9 @@
+ python_LTLIBRARIES = _gamin.la
+
+ _gamin_la_SOURCES = gamin.c
++_gamin_la_CFLAGS = -shared
+ _gamin_la_LIBADD = $(top_builddir)/libgamin/libgamin-1.la
+-_gamin_la_LDFLAGS = -module -avoid-version
++_gamin_la_LDFLAGS = -module -avoid-version -shared
+
+ python_PYTHON = gamin.py
+
diff --git a/dev-libs/libgamin/libgamin-0.1.10-r2.ebuild b/dev-libs/libgamin/libgamin-0.1.10-r2.ebuild
index 8236e81d0a2f..20222730681f 100644
--- a/dev-libs/libgamin/libgamin-0.1.10-r2.ebuild
+++ b/dev-libs/libgamin/libgamin-0.1.10-r2.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/libgamin-0.1.10-r2.ebuild,v 1.11 2009/09/25 10:51:18 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/libgamin-0.1.10-r2.ebuild,v 1.12 2010/06/16 18:43:43 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit autotools eutils flag-o-matic libtool python
@@ -21,8 +24,7 @@ IUSE="debug kernel_linux python"
RESTRICT="test" # need gam-server
-RDEPEND="python? ( virtual/python )
- !app-admin/fam
+RDEPEND="!app-admin/fam
!<app-admin/gamin-0.1.10"
DEPEND="${RDEPEND}
@@ -30,6 +32,12 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
src_prepare() {
# Fix QA warnings, bug #257281, upstream #466791
epatch "${FILESDIR}/${P}-compilewarnings.patch"
@@ -40,6 +48,12 @@ src_prepare() {
# Fix collision problem due to intermediate library, upstream bug #530635
epatch "${FILESDIR}/${P}-noinst-lib.patch"
+ # Build only shared version of Python module.
+ epatch "${FILESDIR}/${P}-disable_python_static_library.patch"
+
+ # Python bindings are built/installed manually.
+ sed -e "/SUBDIRS += python/d" -i Makefile.am
+
# autoconf is required as the user-cflags patch modifies configure.in
# however, elibtoolize is also required, so when the above patch is
# removed, replace the following call with a call to elibtoolize
@@ -58,20 +72,50 @@ src_configure() {
$(use_with python)
}
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources python
+
+ building() {
+ emake \
+ PYTHON_INCLUDES="$(python_get_includedir)" \
+ PYTHON_SITE_PACKAGES="$(python_get_sitedir)" \
+ PYTHON_VERSION="$(python_get_version)"
+ }
+ python_execute_function -s --source-dir python building
+ fi
+}
+
src_install() {
emake DESTDIR="${D}" install || die "installation failed"
+ if use python; then
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ PYTHON_SITE_PACKAGES="$(python_get_sitedir)" \
+ PYTHON_VERSION="$(python_get_version)" \
+ install
+ }
+ python_execute_function -s --source-dir python installation
+
+ python_clean_installation_image
+ fi
+
dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt || die "dodoc failed"
dohtml doc/* || die "dohtml failed"
}
pkg_postinst() {
if use python; then
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+ python_mod_optimize gamin.py
fi
}
pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages
+ if use python; then
+ python_mod_cleanup gamin.py
+ fi
}