summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-07-11 04:16:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-07-11 04:16:29 +0000
commit317ffd5c1e9c63635ec3a4da8d6123b8453c9232 (patch)
tree66a2554fe67feb72bbe79619f76e58ae36291d38 /dev-libs/libgamin/libgamin-0.1.10-r2.ebuild
parentVersion bump #374523 by Andrew Savchenko. (diff)
downloadgentoo-2-317ffd5c1e9c63635ec3a4da8d6123b8453c9232.tar.gz
gentoo-2-317ffd5c1e9c63635ec3a4da8d6123b8453c9232.tar.bz2
gentoo-2-317ffd5c1e9c63635ec3a4da8d6123b8453c9232.zip
Stop depending on dev-util/pkgconfig wrt #374775 by dragos240. USE=static-libs and drop .la files, ebuild cleanup etc
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libgamin/libgamin-0.1.10-r2.ebuild')
-rw-r--r--dev-libs/libgamin/libgamin-0.1.10-r2.ebuild46
1 files changed, 26 insertions, 20 deletions
diff --git a/dev-libs/libgamin/libgamin-0.1.10-r2.ebuild b/dev-libs/libgamin/libgamin-0.1.10-r2.ebuild
index 20222730681f..87b51c12b488 100644
--- a/dev-libs/libgamin/libgamin-0.1.10-r2.ebuild
+++ b/dev-libs/libgamin/libgamin-0.1.10-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/libgamin-0.1.10-r2.ebuild,v 1.12 2010/06/16 18:43:43 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/libgamin-0.1.10-r2.ebuild,v 1.13 2011/07/11 04:16:29 ssuominen Exp $
+
+EAPI=2
-EAPI="2"
PYTHON_DEPEND="python? 2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
@@ -15,22 +16,21 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="Library providing the FAM File Alteration Monitor API"
HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
SRC_URI="http://www.gnome.org/~veillard/${MY_PN}/sources/${MY_P}.tar.gz
- mirror://gentoo/${MY_PN}-0.1.9-freebsd.patch.bz2"
+ mirror://gentoo/${MY_PN}-0.1.9-freebsd.patch.bz2
+ http://pkgconfig.freedesktop.org/releases/pkg-config-0.26.tar.gz" # pkg.m4 for eautoreconf
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug kernel_linux python"
+IUSE="debug kernel_linux python static-libs"
RESTRICT="test" # need gam-server
RDEPEND="!app-admin/fam
!<app-admin/gamin-0.1.10"
+DEPEND="${RDEPEND}"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
pkg_setup() {
if use python; then
@@ -39,17 +39,19 @@ pkg_setup() {
}
src_prepare() {
+ mv -vf "${WORKDIR}"/pkg-config-*/pkg.m4 "${WORKDIR}"/ || die
+
# Fix QA warnings, bug #257281, upstream #466791
- epatch "${FILESDIR}/${P}-compilewarnings.patch"
+ epatch "${FILESDIR}"/${P}-compilewarnings.patch
# Fix compile warnings; bug #188923
- epatch "${DISTDIR}/${MY_PN}-0.1.9-freebsd.patch.bz2"
+ epatch "${DISTDIR}"/${MY_PN}-0.1.9-freebsd.patch.bz2
# Fix collision problem due to intermediate library, upstream bug #530635
- epatch "${FILESDIR}/${P}-noinst-lib.patch"
+ epatch "${FILESDIR}"/${P}-noinst-lib.patch
# Build only shared version of Python module.
- epatch "${FILESDIR}/${P}-disable_python_static_library.patch"
+ epatch "${FILESDIR}"/${P}-disable_python_static_library.patch
# Python bindings are built/installed manually.
sed -e "/SUBDIRS += python/d" -i Makefile.am
@@ -57,15 +59,17 @@ src_prepare() {
# autoconf is required as the user-cflags patch modifies configure.in
# however, elibtoolize is also required, so when the above patch is
# removed, replace the following call with a call to elibtoolize
- eautoreconf
+ AT_M4DIR="${WORKDIR}" eautoreconf
# disable pyc compiling
- mv "${S}"/py-compile "${S}"/py-compile.orig
- ln -s $(type -P true) "${S}"/py-compile
+ rm -f py-compile
+ ln -s $(type -P true) py-compile
}
src_configure() {
- econf --disable-debug \
+ econf \
+ $(use_enable static-libs static) \
+ --disable-debug \
--disable-server \
$(use_enable kernel_linux inotify) \
$(use_enable debug debug-api) \
@@ -89,7 +93,7 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die "installation failed"
+ emake DESTDIR="${D}" install || die
if use python; then
installation() {
@@ -104,8 +108,10 @@ src_install() {
python_clean_installation_image
fi
- dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt || die "dodoc failed"
- dohtml doc/* || die "dohtml failed"
+ dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt || die
+ dohtml doc/* || die
+
+ find "${D}" -name '*.la' -exec rm -f {} +
}
pkg_postinst() {