summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-09-25 07:26:28 +0000
committerMike Frysinger <vapier@gentoo.org>2004-09-25 07:26:28 +0000
commit6f715a81ece62a7f25fbbd7d65b0f389b4333754 (patch)
tree88dcde9a08374d373c0e61b73cf77b0e5e909b5d /dev-libs/libedit/files
parentold (Manifest recommit) (diff)
downloadgentoo-2-6f715a81ece62a7f25fbbd7d65b0f389b4333754.tar.gz
gentoo-2-6f715a81ece62a7f25fbbd7d65b0f389b4333754.tar.bz2
gentoo-2-6f715a81ece62a7f25fbbd7d65b0f389b4333754.zip
ugly fix for shared building (PIC lib) but it works ... also add in hppa support while here
Diffstat (limited to 'dev-libs/libedit/files')
-rw-r--r--dev-libs/libedit/files/20031222-debian-to-gentoo.patch10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-libs/libedit/files/20031222-debian-to-gentoo.patch b/dev-libs/libedit/files/20031222-debian-to-gentoo.patch
index e2351f9b3dcc..4822f2aadf4d 100644
--- a/dev-libs/libedit/files/20031222-debian-to-gentoo.patch
+++ b/dev-libs/libedit/files/20031222-debian-to-gentoo.patch
@@ -30,7 +30,7 @@ diff -ur netbsd-cvs/Makefile libedit-20031222/Makefile
AHDR=vi.h emacs.h common.h
ASRC=${LIBEDITDIR}/vi.c ${LIBEDITDIR}/emacs.c ${LIBEDITDIR}/common.c
-@@ -46,46 +49,54 @@
+@@ -46,46 +49,56 @@
CLEANFILES+= ${AHDR} fcns.h help.h fcns.c help.c
SUBDIR= readline
@@ -98,12 +98,14 @@ diff -ur netbsd-cvs/Makefile libedit-20031222/Makefile
-.include <bsd.lib.mk>
-.include <bsd.subdir.mk>
+.depend: vi.h emacs.h common.h fcns.h help.h help.c
++ -mkdir .a .so
+.c.o:
-+ ${CC} ${CFLAGS} -c $<
++ ${CC} ${CFLAGS} -c $< -o .a/$*
++ ${CC} ${CFLAGS} -fPIC -c $< -o .so/$*
+libedit.a: ${OOBJS}
-+ ar -r $@ ${OOBJS}
++ ar -r $@ .a/*
+libedit.so: ${OOBJS}
-+ ${CC} --shared -o $@ ${OOBJS} ${LIBS}
++ ${CC} --shared -o $@ .so/* ${LIBS}
diff -ur netbsd-cvs/el.c libedit-20031222/el.c
--- netbsd-cvs/el.c 2003-12-22 13:44:25.474909848 -0500
+++ libedit-20031222/el.c 2003-12-22 15:00:15.545194024 -0500