summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-04-10 15:49:03 +0000
committerMichał Górny <mgorny@gentoo.org>2012-04-10 15:49:03 +0000
commit2f90954120a12fcf8dced220fa3c3136df490b77 (patch)
treeed197f775dc711b0bbc88d66c540bb2584d85452 /dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
parentUnmask chromium-19.x, v8-3.9.x (and also nodejs-0.7). Mask chromium-20.x, v8-... (diff)
downloadgentoo-2-2f90954120a12fcf8dced220fa3c3136df490b77.tar.gz
gentoo-2-2f90954120a12fcf8dced220fa3c3136df490b77.tar.bz2
gentoo-2-2f90954120a12fcf8dced220fa3c3136df490b77.zip
Initial commit for libdivsufsort, a new dependency of zpaq.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild')
-rw-r--r--dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild b/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
new file mode 100644
index 000000000000..ea253abc369a
--- /dev/null
+++ b/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild,v 1.1 2012/04/10 15:49:03 mgorny Exp $
+
+EAPI=4
+inherit cmake-utils multilib
+
+DESCRIPTION="Suffix-sorting library (for BWT)"
+HOMEPAGE="http://code.google.com/p/libdivsufsort/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ # will appreciate saner approach, if there is any
+ sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
+ */CMakeLists.txt || die
+}