summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-28 17:31:41 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-28 17:31:41 +0000
commitf1bea83580e4c68c50a0642bd1f7f75f3bbc32b5 (patch)
tree0cb124a64538c2c41c2ce243d882ffc6d94770fc /dev-libs/libRocket
parentDrop old versions (diff)
downloadgentoo-2-f1bea83580e4c68c50a0642bd1f7f75f3bbc32b5.tar.gz
gentoo-2-f1bea83580e4c68c50a0642bd1f7f75f3bbc32b5.tar.bz2
gentoo-2-f1bea83580e4c68c50a0642bd1f7f75f3bbc32b5.zip
Replace multilib_build_binaries with multilib_is_native_abi. The two are equivalent now, and the team has decided to use the old name as being less confusing.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-libs/libRocket')
-rw-r--r--dev-libs/libRocket/ChangeLog8
-rw-r--r--dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild10
-rw-r--r--dev-libs/libRocket/libRocket-9999.ebuild10
3 files changed, 17 insertions, 11 deletions
diff --git a/dev-libs/libRocket/ChangeLog b/dev-libs/libRocket/ChangeLog
index 792b8d0e455b..8c39af5cbca4 100644
--- a/dev-libs/libRocket/ChangeLog
+++ b/dev-libs/libRocket/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libRocket
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/ChangeLog,v 1.9 2014/01/04 22:56:02 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/ChangeLog,v 1.10 2014/04/28 17:31:41 mgorny Exp $
+
+ 28 Apr 2014; Michał Górny <mgorny@gentoo.org>
+ libRocket-1.2.1_p20130110-r1.ebuild, libRocket-9999.ebuild:
+ Replace multilib_build_binaries with multilib_is_native_abi. The two are
+ equivalent now, and the team has decided to use the old name as being less
+ confusing.
04 Jan 2014; Michał Górny <mgorny@gentoo.org>
libRocket-1.2.1_p20130110-r1.ebuild, libRocket-9999.ebuild:
diff --git a/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild b/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
index 20f4049dab56..8d0bc846ccdf 100644
--- a/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
+++ b/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild,v 1.4 2014/01/04 22:56:02 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild,v 1.5 2014/04/28 17:31:40 mgorny Exp $
EAPI=5
@@ -41,7 +41,7 @@ multilib_src_configure() {
-DSAMPLES_DIR=/usr/share/${PN}/samples
)
- if multilib_build_binaries ; then
+ if multilib_is_native_abi ; then
mycmakeargs+=( $(cmake-utils_use_build samples SAMPLES) )
else
mycmakeargs+=( -DBUILD_SAMPLES=OFF )
@@ -49,7 +49,7 @@ multilib_src_configure() {
cmake-utils_src_configure
- if multilib_build_binaries ; then
+ if multilib_is_native_abi ; then
if use python ; then
cfgpybind() {
local mycmakeargs=(
@@ -67,7 +67,7 @@ multilib_src_configure() {
multilib_src_compile() {
cmake-utils_src_compile
- if multilib_build_binaries ; then
+ if multilib_is_native_abi ; then
if use python ; then
buildpybind() {
cp "${S}-${ABI}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
@@ -82,7 +82,7 @@ multilib_src_compile() {
multilib_src_install() {
cmake-utils_src_install
- if multilib_build_binaries ; then
+ if multilib_is_native_abi ; then
if use python ; then
instpybind() {
python_domodule "${S}"/bin/rocket.py
diff --git a/dev-libs/libRocket/libRocket-9999.ebuild b/dev-libs/libRocket/libRocket-9999.ebuild
index 235483a824d4..2dce85a5d53b 100644
--- a/dev-libs/libRocket/libRocket-9999.ebuild
+++ b/dev-libs/libRocket/libRocket-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/libRocket-9999.ebuild,v 1.6 2014/01/04 22:56:02 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libRocket/libRocket-9999.ebuild,v 1.7 2014/04/28 17:31:40 mgorny Exp $
EAPI=5
@@ -42,7 +42,7 @@ multilib_src_configure() {
-DSAMPLES_DIR=/usr/share/${PN}/samples
)
- if multilib_build_binaries ; then
+ if multilib_is_native_abi ; then
mycmakeargs+=( $(cmake-utils_use_build samples SAMPLES) )
else
mycmakeargs+=( -DBUILD_SAMPLES=OFF )
@@ -50,7 +50,7 @@ multilib_src_configure() {
cmake-utils_src_configure
- if multilib_build_binaries ; then
+ if multilib_is_native_abi ; then
if use python ; then
cfgpybind() {
local mycmakeargs=(
@@ -68,7 +68,7 @@ multilib_src_configure() {
multilib_src_compile() {
cmake-utils_src_compile
- if multilib_build_binaries ; then
+ if multilib_is_native_abi ; then
if use python ; then
buildpybind() {
cp "${S}-${ABI}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
@@ -83,7 +83,7 @@ multilib_src_compile() {
multilib_src_install() {
cmake-utils_src_install
- if multilib_build_binaries ; then
+ if multilib_is_native_abi ; then
if use python ; then
instpybind() {
python_domodule "${S}"/bin/rocket.py