summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-07-30 03:53:31 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-07-30 03:53:31 +0000
commitcdd9234bcd72ffd53a8d014c210a973a3dff9ca0 (patch)
tree555b27399f4f61553e4da897027a69a3fbf17e47 /dev-libs/lam-mpi
parentAdded ppc to KEYWORDS. Added RDEPEND. (diff)
downloadgentoo-2-cdd9234bcd72ffd53a8d014c210a973a3dff9ca0.tar.gz
gentoo-2-cdd9234bcd72ffd53a8d014c210a973a3dff9ca0.tar.bz2
gentoo-2-cdd9234bcd72ffd53a8d014c210a973a3dff9ca0.zip
new package - lam-mpi: Local Area Multicomputer MPI implementation
Diffstat (limited to 'dev-libs/lam-mpi')
-rw-r--r--dev-libs/lam-mpi/ChangeLog20
-rw-r--r--dev-libs/lam-mpi/files/digest-lam-mpi-6.5.61
-rw-r--r--dev-libs/lam-mpi/lam-mpi-6.5.6.ebuild51
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-libs/lam-mpi/ChangeLog b/dev-libs/lam-mpi/ChangeLog
new file mode 100644
index 000000000000..5666aeb3fff2
--- /dev/null
+++ b/dev-libs/lam-mpi/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for dev-libs/lam-mpi
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/lam-mpi/ChangeLog,v 1.1 2002/07/30 03:53:31 george Exp $
+
+*lam-mpi-6.5.6.ebuild (29 Jul 2002)
+
+ 29 Jul 2002; George Shapovalov <george@gentoo.org> lam-mpi-6.5.6.ebuild :
+
+ Initial release (and rework of submitted ebuild)
+
+ form the web site:
+ LAM (Local Area Multicomputer) is an MPI programming environment and development
+ system for heterogeneous computers on a network. With LAM, a dedicated cluster
+ or an existing network computing infrastructure can act as one parallel
+ computer solving one problem.
+ LAM features extensive debugging support in the application development cycle
+ and peak performance for production applications. LAM features a full
+ implementation of the MPI communication standard.
+
+ ebuild submitted by Tibor Rudas <tibi@mdy.univie.ac.at>
diff --git a/dev-libs/lam-mpi/files/digest-lam-mpi-6.5.6 b/dev-libs/lam-mpi/files/digest-lam-mpi-6.5.6
new file mode 100644
index 000000000000..4d564991aa7a
--- /dev/null
+++ b/dev-libs/lam-mpi/files/digest-lam-mpi-6.5.6
@@ -0,0 +1 @@
+MD5 97884838b7b0299f3a095d0b2a9f9ef1 lam-6.5.6.tar.bz2 1303693
diff --git a/dev-libs/lam-mpi/lam-mpi-6.5.6.ebuild b/dev-libs/lam-mpi/lam-mpi-6.5.6.ebuild
new file mode 100644
index 000000000000..b88c8d0b261b
--- /dev/null
+++ b/dev-libs/lam-mpi/lam-mpi-6.5.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/lam-mpi/lam-mpi-6.5.6.ebuild,v 1.1 2002/07/30 03:53:31 george Exp $
+
+Name="lam"
+S=${WORKDIR}/${Name}-${PV}
+
+DESCRIPTION="the LAM MPI parallel computing environment"
+SRC_URI="http://www.lam-mpi.org/download/files/${Name}-${PV}.tar.bz2"
+HOMEPAGE="http://www.lam-mpi.org"
+
+DEPEND="virtual/glibc"
+# we need ssh if we want to use it instead of rsh
+RDEPEND="net-misc/openssh"
+
+SLOT="6"
+KEYWORDS="x86"
+LICENSE="as-is"
+
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/romio/util/
+ mv romioinstall.in romioinstall.in-orig
+ sed -e "s|docdir=\"\$datadir/lam/doc\"|docdir=\"${D}/usr/share/doc/${PF}\"|" romioinstall.in-orig >romioinstall.in
+
+}
+
+src_compile() {
+ ./configure \
+ --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr \
+ --host="${CHOST}" --with-cflags="${CFLAGS}" \
+ --sysconfdir=/etc/lam-mpi \
+ --with-cxxflags="${CXXFLAGS}" --with-rsh="ssh -x" || die
+
+ # sometimes emake doesn't finish since it gets ahead of itself :)
+
+ make || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc/lam-mpi install || die
+
+ dodoc README HISTORY LICENSE RELEASE_NOTES VERSION
+}
+