summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-03-19 14:15:08 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-03-19 14:15:08 +0000
commitd31451ff123e144cfcb25477703314aaf902e013 (patch)
treef4fb77cb1caad29479826c34b81f9ee6deebf65b /dev-libs/gobject-introspection
parentNow that the audacious flag has been removed, do not actually build the plugin. (diff)
downloadgentoo-2-d31451ff123e144cfcb25477703314aaf902e013.tar.gz
gentoo-2-d31451ff123e144cfcb25477703314aaf902e013.tar.bz2
gentoo-2-d31451ff123e144cfcb25477703314aaf902e013.zip
Bump to 0.6.9; minimal changes
(Portage version: 2.1.8.1/cvs/Linux i686)
Diffstat (limited to 'dev-libs/gobject-introspection')
-rw-r--r--dev-libs/gobject-introspection/ChangeLog8
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-0.6.9.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-libs/gobject-introspection/ChangeLog b/dev-libs/gobject-introspection/ChangeLog
index b796a045d085..390b5c49e935 100644
--- a/dev-libs/gobject-introspection/ChangeLog
+++ b/dev-libs/gobject-introspection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gobject-introspection
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.2 2010/03/18 15:22:23 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.3 2010/03/19 14:15:08 nirbheek Exp $
+
+*gobject-introspection-0.6.9 (19 Mar 2010)
+
+ 19 Mar 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +gobject-introspection-0.6.9.ebuild:
+ Bump to 0.6.9; minimal changes
*gobject-introspection-0.6.8 (18 Mar 2010)
diff --git a/dev-libs/gobject-introspection/gobject-introspection-0.6.9.ebuild b/dev-libs/gobject-introspection/gobject-introspection-0.6.9.ebuild
new file mode 100644
index 000000000000..3f0f9245135d
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-0.6.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-0.6.9.ebuild,v 1.1 2010/03/19 14:15:08 nirbheek Exp $
+
+EAPI="2"
+
+inherit python gnome2
+
+DESCRIPTION="Introspection infrastructure for gobject library bindings"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.19.0
+ >=dev-lang/python-2.5
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.12 )
+ dev-util/pkgconfig
+ sys-devel/flex"
+
+src_prepare() {
+ G2CONF="${G2CONF} --disable-static"
+
+ # FIXME: Parallel compilation failure with USE=doc
+ use doc && MAKEOPTS="-j1"
+
+ # Don't pre-compile .py
+ ln -sf $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}/giscanner
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/lib*/${PN}/giscanner
+}