summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-10-30 08:08:40 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-10-30 08:08:40 +0000
commit42bf6fd9af2f8b261f1b5d9e5fae96002273cb71 (patch)
tree34d838f6f9e20bcdb2fbc20a900c4bcfe4c972bf /dev-libs/gobject-introspection
parentRemove old snapshot version. (diff)
downloadgentoo-2-42bf6fd9af2f8b261f1b5d9e5fae96002273cb71.tar.gz
gentoo-2-42bf6fd9af2f8b261f1b5d9e5fae96002273cb71.tar.bz2
gentoo-2-42bf6fd9af2f8b261f1b5d9e5fae96002273cb71.zip
Version bump. Drop useless USE=doc, it served no useful purpose.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'dev-libs/gobject-introspection')
-rw-r--r--dev-libs/gobject-introspection/ChangeLog8
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-1.34.1.1.ebuild97
2 files changed, 104 insertions, 1 deletions
diff --git a/dev-libs/gobject-introspection/ChangeLog b/dev-libs/gobject-introspection/ChangeLog
index d057cb0cf6f9..31d107597a27 100644
--- a/dev-libs/gobject-introspection/ChangeLog
+++ b/dev-libs/gobject-introspection/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gobject-introspection
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.81 2012/10/28 15:42:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/ChangeLog,v 1.82 2012/10/30 08:08:40 eva Exp $
+
+*gobject-introspection-1.34.1.1 (30 Oct 2012)
+
+ 30 Oct 2012; Gilles Dartiguelongue <eva@gentoo.org>
+ +gobject-introspection-1.34.1.1.ebuild:
+ Version bump. Drop useless USE=doc, it served no useful purpose.
28 Oct 2012; Raúl Porcel <armin76@gentoo.org>
gobject-introspection-1.32.1.ebuild:
diff --git a/dev-libs/gobject-introspection/gobject-introspection-1.34.1.1.ebuild b/dev-libs/gobject-introspection/gobject-introspection-1.34.1.1.ebuild
new file mode 100644
index 000000000000..c82a56de82b1
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-1.34.1.1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gobject-introspection/gobject-introspection-1.34.1.1.ebuild,v 1.1 2012/10/30 08:08:40 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="2:2.7"
+PYTHON_USE_WITH="xml"
+
+inherit gnome2 python toolchain-funcs
+
+DESCRIPTION="Introspection infrastructure for generating gobject library bindings for various languages"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="doctool test"
+
+RDEPEND="
+ >=dev-libs/gobject-introspection-common-${PV}
+ >=dev-libs/glib-2.34.1:2
+ doctool? ( dev-python/mako )
+ virtual/libffi
+"
+# Wants real bison, not virtual/yacc
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.15
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+# PDEPEND to avoid circular dependencies, bug #391213
+PDEPEND="x11-libs/cairo[glib]"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # To prevent crosscompiling problems, bug #414105
+ CC=$(tc-getCC)
+
+ DOCS="AUTHORS CONTRIBUTORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-static
+ YACC=$(type -p yacc)
+ $(use_enable doctool)
+ $(use_enable test tests)"
+
+ gnome2_src_prepare
+ python_clean_py-compile_files
+
+ # avoid GNU-isms
+ sed -i -e 's/\(if test .* \)==/\1=/' configure || die
+
+ gi_skip_tests=
+ if ! has_version "x11-libs/cairo[glib]"; then
+ # Bug #391213: enable cairo-gobject support even if it's not installed
+ # We only PDEPEND on cairo to avoid circular dependencies
+ export CAIRO_LIBS="-lcairo -lcairo-gobject"
+ export CAIRO_CFLAGS="-I${EPREFIX}/usr/include/cairo"
+ if use test; then
+ G2CONF="${G2CONF} --disable-tests"
+ gi_skip_tests=yes
+ ewarn "Tests will be skipped because x11-libs/cairo[glib] is not present"
+ ewarn "on your system. Consider installing it to get tests to run."
+ fi
+ fi
+}
+
+src_test() {
+ [[ -z ${gi_skip_tests} ]] && default
+}
+
+src_install() {
+ gnome2_src_install
+ python_convert_shebangs 2 "${ED}"usr/bin/g-ir-{annotation-tool,scanner}
+ use doctool && python_convert_shebangs 2 "${ED}"usr/bin/g-ir-doc-tool
+
+ # Prevent collision with gobject-introspection-common
+ rm -v "${ED}"usr/share/aclocal/introspection.m4 \
+ "${ED}"usr/share/gobject-introspection-1.0/Makefile.introspection || die
+ rmdir "${ED}"usr/share/aclocal || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}/giscanner
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}/giscanner
+}