summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-03-07 06:08:44 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-03-07 06:08:44 +0000
commit703f1abe70e13ac3d27af798149b38cd5c560205 (patch)
treef3e534fba97d65ac5249552c204c80455ae5740e /dev-libs/elfutils
parentMask old e2fsprogs libs packages so people get the hint. (diff)
downloadgentoo-2-703f1abe70e13ac3d27af798149b38cd5c560205.tar.gz
gentoo-2-703f1abe70e13ac3d27af798149b38cd5c560205.tar.bz2
gentoo-2-703f1abe70e13ac3d27af798149b38cd5c560205.zip
Version bump.
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/ChangeLog7
-rw-r--r--dev-libs/elfutils/elfutils-0.145.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-libs/elfutils/ChangeLog b/dev-libs/elfutils/ChangeLog
index 5c0bc129c9b3..1c5db6103fca 100644
--- a/dev-libs/elfutils/ChangeLog
+++ b/dev-libs/elfutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/elfutils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.129 2010/02/20 20:12:20 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/ChangeLog,v 1.130 2010/03/07 06:08:44 dirtyepic Exp $
+
+*elfutils-0.145 (07 Mar 2010)
+
+ 07 Mar 2010; Ryan Hill <dirtyepic@gentoo.org> +elfutils-0.145.ebuild:
+ Version bump.
20 Feb 2010; Jonathan Callen <abcd@gentoo.org> elfutils-0.144.ebuild:
Transfer prefix keywords, remove dep on glibc on prefix
diff --git a/dev-libs/elfutils/elfutils-0.145.ebuild b/dev-libs/elfutils/elfutils-0.145.ebuild
new file mode 100644
index 000000000000..b5b649a9b385
--- /dev/null
+++ b/dev-libs/elfutils/elfutils-0.145.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/elfutils/elfutils-0.145.ebuild,v 1.1 2010/03/07 06:08:44 dirtyepic Exp $
+
+inherit eutils
+
+DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)"
+HOMEPAGE="http://people.redhat.com/drepper/"
+#SRC_URI="ftp://sources.redhat.com/pub/systemtap/${PN}/${P}.tar.gz"
+#SRC_URI="mirror://debian/pool/main/e/elfutils/elfutils_${PV}.orig.tar.gz"
+SRC_URI="https://fedorahosted.org/releases/e/l/elfutils/${P}.tar.bz2"
+
+LICENSE="GPL-2-with-exceptions"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 lzma nls test zlib"
+
+# This pkg does not actually seem to compile currently in a uClibc
+# environment (xrealloc errs), but we need to ensure that glibc never
+# gets pulled in as a dep since this package does not respect virtual/libc
+RDEPEND="zlib? ( >=sys-libs/zlib-1.2.2.3 )
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}
+ elibc_glibc? ( !prefix? ( >=sys-libs/glibc-2.7 ) )
+ nls? ( sys-devel/gettext )
+ >=sys-devel/flex-2.5.4a
+ sys-devel/m4
+ >=sys-devel/binutils-2.15.90.0.1
+ >=sys-devel/gcc-4.1.2
+ !dev-libs/libelf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.118-PaX-support.patch
+ epatch "${FILESDIR}"/${PN}-0.143-configure.patch #287130
+ find . -name Makefile.in -print0 | xargs -0 sed -i -e 's:-W\(error\|extra\)::g'
+ use test || sed -i -e 's: tests::' Makefile.in #226349
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --program-prefix="eu-" \
+ $(use_with zlib) \
+ $(use_with bzip2 bzlib) \
+ $(use_with lzma)
+
+ emake || die
+}
+
+src_test() {
+ env LD_LIBRARY_PATH="${S}/libelf:${S}/libebl:${S}/libdw:${S}/libasm" \
+ emake -j1 check || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS NOTES README THANKS TODO
+}