summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-06-21 13:57:30 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-06-21 13:57:30 +0000
commit807fbb70b6cf8d72eb1e921592ac835c71b4882b (patch)
tree4c24cb53d20bfb1549d99ae69231531ebb52bfc8 /dev-libs/eb
parentStable on ppc wrt bug 228609 (diff)
downloadgentoo-2-807fbb70b6cf8d72eb1e921592ac835c71b4882b.tar.gz
gentoo-2-807fbb70b6cf8d72eb1e921592ac835c71b4882b.tar.bz2
gentoo-2-807fbb70b6cf8d72eb1e921592ac835c71b4882b.zip
Fix building with --as-needed and clean up ebuild.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r5 x86_64)
Diffstat (limited to 'dev-libs/eb')
-rw-r--r--dev-libs/eb/ChangeLog8
-rw-r--r--dev-libs/eb/eb-4.2.2.ebuild24
-rw-r--r--dev-libs/eb/files/eb-4.2.2-as-needed.patch12
3 files changed, 32 insertions, 12 deletions
diff --git a/dev-libs/eb/ChangeLog b/dev-libs/eb/ChangeLog
index 7f158995e73d..ff55f1119608 100644
--- a/dev-libs/eb/ChangeLog
+++ b/dev-libs/eb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/eb
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/eb/ChangeLog,v 1.36 2007/12/25 17:06:38 phreak Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eb/ChangeLog,v 1.37 2008/06/21 13:57:30 dirtyepic Exp $
+
+ 21 Jun 2008; Ryan Hill <dirtyepic@gentoo.org>
+ +files/eb-4.2.2-as-needed.patch, eb-4.2.2.ebuild:
+ Fix building with --as-needed and clean up ebuild.
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing usata from metadata.xml as per #22931. Assigning to maintainer-needed.
diff --git a/dev-libs/eb/eb-4.2.2.ebuild b/dev-libs/eb/eb-4.2.2.ebuild
index 671af09a29cd..0ac62d1bd40b 100644
--- a/dev-libs/eb/eb-4.2.2.ebuild
+++ b/dev-libs/eb/eb-4.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/eb/eb-4.2.2.ebuild,v 1.13 2007/08/25 17:13:37 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/eb/eb-4.2.2.ebuild,v 1.14 2008/06/21 13:57:30 dirtyepic Exp $
inherit eutils
@@ -14,21 +14,25 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
-DEPEND="virtual/libc
- sys-libs/zlib
- nls? ( sys-devel/gettext )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
src_compile () {
econf \
--with-pkgdocdir=/usr/share/doc/${PF}/html \
- `use_enable nls` \
- `use_enable threads pthread` \
- `use_enable ipv6` || die
- emake || die
+ $(use_enable nls) \
+ $(use_enable threads pthread) \
+ $(use_enable ipv6) || die "Failed configure."
+ emake || die "Failed make."
}
src_install () {
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die "Failed install."
dodoc AUTHORS INSTALL* NEWS README*
}
diff --git a/dev-libs/eb/files/eb-4.2.2-as-needed.patch b/dev-libs/eb/files/eb-4.2.2-as-needed.patch
new file mode 100644
index 000000000000..19ec6c1ab582
--- /dev/null
+++ b/dev-libs/eb/files/eb-4.2.2-as-needed.patch
@@ -0,0 +1,12 @@
+diff -Naurp eb-4.2.2-orig/eb/Makefile.in eb-4.2.2/eb/Makefile.in
+--- eb-4.2.2-orig/eb/Makefile.in 2005-11-25 21:02:13.000000000 -0600
++++ eb-4.2.2/eb/Makefile.in 2008-06-21 07:37:51.000000000 -0600
+@@ -318,7 +318,7 @@ clean-libLTLIBRARIES:
+ rm -f "$${dir}/so_locations"; \
+ done
+ libeb.la: $(libeb_la_OBJECTS) $(libeb_la_DEPENDENCIES)
+- $(LINK) -rpath $(libdir) $(libeb_la_LDFLAGS) $(libeb_la_OBJECTS) $(libeb_la_LIBADD) $(LIBS)
++ $(LINK) -rpath $(libdir) $(libeb_la_LDFLAGS) $(libeb_la_OBJECTS) $(libeb_la_LIBADD) $(LIBS) $(ZLIBLIBS)
+
+ mostlyclean-compile:
+ -rm -f *.$(OBJEXT)