summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2011-05-29 16:18:01 +0000
committerThomas Sachau <tommy@gentoo.org>2011-05-29 16:18:01 +0000
commit5207eb29901886656f086838e6d8d833258584b2 (patch)
tree1996ce80e5811471cfd68d8cba0e98cbeacf1333 /dev-libs/e_dbus
parentDrop sparc keywords (diff)
downloadgentoo-2-5207eb29901886656f086838e6d8d833258584b2.tar.gz
gentoo-2-5207eb29901886656f086838e6d8d833258584b2.tar.bz2
gentoo-2-5207eb29901886656f086838e6d8d833258584b2.zip
Version bump
(Portage version: 2.2.0_alpha37-r1/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/e_dbus')
-rw-r--r--dev-libs/e_dbus/ChangeLog8
-rw-r--r--dev-libs/e_dbus/e_dbus-1.0.1.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/e_dbus/ChangeLog b/dev-libs/e_dbus/ChangeLog
index c4b30c0fb238..74567e32317f 100644
--- a/dev-libs/e_dbus/ChangeLog
+++ b/dev-libs/e_dbus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/e_dbus
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/ChangeLog,v 1.4 2011/03/27 16:07:03 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/ChangeLog,v 1.5 2011/05/29 16:18:01 tommy Exp $
+
+*e_dbus-1.0.1 (29 May 2011)
+
+ 29 May 2011; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +e_dbus-1.0.1.ebuild:
+ Version bump
27 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> e_dbus-1.0.0.ebuild:
Remove support for sys-apps/hal wrt #313389.
diff --git a/dev-libs/e_dbus/e_dbus-1.0.1.ebuild b/dev-libs/e_dbus/e_dbus-1.0.1.ebuild
new file mode 100644
index 000000000000..e89f43af9c4b
--- /dev/null
+++ b/dev-libs/e_dbus/e_dbus-1.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/e_dbus/e_dbus-1.0.1.ebuild,v 1.1 2011/05/29 16:18:01 tommy Exp $
+
+EAPI="2"
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment's (Ecore) integration to DBus"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth +connman +libnotify ofono static-libs test-binaries +udev"
+
+RDEPEND=">=dev-libs/eina-1.0.0_beta
+ >=dev-libs/ecore-1.0.0_beta
+ sys-apps/dbus
+ libnotify? ( >=media-libs/evas-1.0.0_beta )
+ udev? ( sys-power/upower sys-fs/udisks )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ MY_ECONF="
+ $(use_enable bluetooth ebluez)
+ $(use_enable connman econnman)
+ $(use_enable doc)
+ --disable-ehal
+ $(use_enable libnotify enotify)
+ $(use_enable ofono eofono)
+ $(use_enable test-binaries edbus-test)
+ $(use_enable test-binaries edbus-test-client)
+ $(use_enable udev eukit)"
+ if use test-binaries ; then
+ MY_ECONF+="
+ $(use_enable bluetooth edbus-bluez-test)
+ $(use_enable connman edbus-connman-test)
+ $(use_enable libnotify edbus-notification-daemon-test)
+ $(use_enable libnotify edbus-notify-test)
+ $(use_enable ofono edbus-ofono-test)
+ $(use_enable udev edbus-ukit-test)"
+ else
+ MY_ECONF+="
+ --disable-edbus-bluez-test
+ --disable-edbus-connman-test
+ --disable-edbus-notification-daemon-test
+ --disable-edbus-notify-test
+ --disable-edbus-ofono-test
+ --disable-edbus-ukit-test"
+ fi
+ enlightenment_src_configure
+}