summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2003-03-13 23:18:57 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2003-03-13 23:18:57 +0000
commitc3769c679d7dc6e5a4e4080083b439e001a46973 (patch)
treee4519c736bbf587ce840ffad6a1d34ee5b495fea /dev-libs/dvthread
parentfix EXTRAHEADERS problems with arm-sources (diff)
downloadgentoo-2-c3769c679d7dc6e5a4e4080083b439e001a46973.tar.gz
gentoo-2-c3769c679d7dc6e5a4e4080083b439e001a46973.tar.bz2
gentoo-2-c3769c679d7dc6e5a4e4080083b439e001a46973.zip
gcc3 patch
Diffstat (limited to 'dev-libs/dvthread')
-rw-r--r--dev-libs/dvthread/dvthread-0.4.4.ebuild11
-rw-r--r--dev-libs/dvthread/files/gentoo-0.4.4.patch12
2 files changed, 21 insertions, 2 deletions
diff --git a/dev-libs/dvthread/dvthread-0.4.4.ebuild b/dev-libs/dvthread/dvthread-0.4.4.ebuild
index 19ef5f5e6e19..e8863169a4b0 100644
--- a/dev-libs/dvthread/dvthread-0.4.4.ebuild
+++ b/dev-libs/dvthread/dvthread-0.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvthread/dvthread-0.4.4.ebuild,v 1.2 2003/03/13 10:03:22 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvthread/dvthread-0.4.4.ebuild,v 1.3 2003/03/13 23:18:51 pvdabeel Exp $
A=dvthread-${PV}.tar.gz
S=${WORKDIR}/dvthread-${PV}
@@ -8,13 +8,20 @@ DESCRIPTION="dvthread provides classes for threads and monitors, wrapped around
SRC_URI="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvthread/download/${A}"
HOMEPAGE="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvthread/html/"
KEYWORDS="x86 ppc"
-LICENSE="GPL2"
+LICENSE="GPL-2"
SLOT="0"
+inherit eutils
+
IUSE=""
DEPEND="virtual/glibc"
RDEPEND=${DEPEND}
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/gentoo-0.4.4.patch
+}
+
src_install() {
make prefix=${D}/usr install
}
diff --git a/dev-libs/dvthread/files/gentoo-0.4.4.patch b/dev-libs/dvthread/files/gentoo-0.4.4.patch
new file mode 100644
index 000000000000..880b8fa66e8c
--- /dev/null
+++ b/dev-libs/dvthread/files/gentoo-0.4.4.patch
@@ -0,0 +1,12 @@
+diff -urN ori/dvthread/monitor.h dvthread-0.4.4/dvthread/monitor.h
+--- ori/dvthread/monitor.h 2003-03-14 00:16:27.000000000 +0100
++++ dvthread-0.4.4/dvthread/monitor.h 2003-03-14 00:16:44.000000000 +0100
+@@ -2,6 +2,8 @@
+ #define DV_THREAD_MONITOR_H
+ // $Id: monitor.h,v 1.9 2002/12/22 09:20:08 dvermeir Exp $
+
++using namespace std;
++
+ #include <string>
+ #include <iostream>
+ #include <stdexcept>