summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-11-14 09:47:42 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-11-14 09:47:42 +0000
commit34caef8d34dbcb20ca1617ea811eec6a3cee0b0d (patch)
tree258d70fc164ee228acd07d45cb77d3c2315c3040 /dev-libs/boost
parentInitial commit. Snap: A Haskell Web Framework (core interfaces and types). (diff)
downloadgentoo-2-34caef8d34dbcb20ca1617ea811eec6a3cee0b0d.tar.gz
gentoo-2-34caef8d34dbcb20ca1617ea811eec6a3cee0b0d.tar.bz2
gentoo-2-34caef8d34dbcb20ca1617ea811eec6a3cee0b0d.zip
Add compatibility with glibc 2.18, wrt bug #482372
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog6
-rw-r--r--dev-libs/boost/boost-1.53.0.ebuild9
-rw-r--r--dev-libs/boost/boost-1.54.0.ebuild9
-rw-r--r--dev-libs/boost/files/boost-1.53.0-glibc-2.18-compat.patch18
4 files changed, 33 insertions, 9 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 3662583b3823..c53044a99525 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.304 2013/09/26 17:28:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.305 2013/11/14 09:47:42 pinkbyte Exp $
+
+ 14 Nov 2013; Sergey Popov <pinkbyte@gentoo.org> boost-1.53.0.ebuild,
+ +files/boost-1.53.0-glibc-2.18-compat.patch, boost-1.54.0.ebuild:
+ Add compatibility with glibc 2.18, wrt bug #482372
26 Sep 2013; Agostino Sarubbo <ago@gentoo.org> boost-1.52.0-r6.ebuild:
Stable for arm, wrt bug #455464
diff --git a/dev-libs/boost/boost-1.53.0.ebuild b/dev-libs/boost/boost-1.53.0.ebuild
index b56a3ae73352..4101e5ac7fd3 100644
--- a/dev-libs/boost/boost-1.53.0.ebuild
+++ b/dev-libs/boost/boost-1.53.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.53.0.ebuild,v 1.7 2013/09/05 18:29:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.53.0.ebuild,v 1.8 2013/11/14 09:47:42 pinkbyte Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}
=dev-util/boost-build-${MAJOR_V}*"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
create_user-config.jam() {
local compiler compiler_version compiler_executable
@@ -69,8 +69,9 @@ src_prepare() {
"${FILESDIR}/${PN}-1.48.0-no_strict_aliasing_python2.patch" \
"${FILESDIR}/${PN}-1.48.0-disable_libboost_python3.patch" \
"${FILESDIR}/${PN}-1.48.0-python_linking.patch" \
- "${FILESDIR}/${PN}-1.48.0-disable_icu_rpath.patch" \
- "${FILESDIR}/${PN}-1.53.0-library_status.patch" # bug 459112
+ "${FILESDIR}/${PN}-1.48.0-disable_icu_rpath.patch"
+ epatch "${FILESDIR}/${PN}-1.53.0-library_status.patch" # bug 459112
+ epatch "${FILESDIR}/${PN}-1.53.0-glibc-2.18-compat.patch" # bug 482372
# Avoid a patch for now
for file in libs/context/src/asm/*.S; do
diff --git a/dev-libs/boost/boost-1.54.0.ebuild b/dev-libs/boost/boost-1.54.0.ebuild
index 8a695313ce7e..446112bac6ad 100644
--- a/dev-libs/boost/boost-1.54.0.ebuild
+++ b/dev-libs/boost/boost-1.54.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.54.0.ebuild,v 1.3 2013/09/05 18:29:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.54.0.ebuild,v 1.4 2013/11/14 09:47:42 pinkbyte Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}
=dev-util/boost-build-${MAJOR_V}*"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
create_user-config.jam() {
local compiler compiler_version compiler_executable
@@ -69,8 +69,9 @@ src_prepare() {
"${FILESDIR}/${PN}-1.48.0-no_strict_aliasing_python2.patch" \
"${FILESDIR}/${PN}-1.48.0-disable_libboost_python3.patch" \
"${FILESDIR}/${PN}-1.48.0-python_linking.patch" \
- "${FILESDIR}/${PN}-1.48.0-disable_icu_rpath.patch" \
- "${FILESDIR}/${PN}-1.53.0-library_status.patch" # bug 459112
+ "${FILESDIR}/${PN}-1.48.0-disable_icu_rpath.patch"
+ epatch "${FILESDIR}/${PN}-1.53.0-library_status.patch" # bug 459112
+ epatch "${FILESDIR}/${PN}-1.53.0-glibc-2.18-compat.patch" # bug 482372
# Avoid a patch for now
for file in libs/context/src/asm/*.S; do
diff --git a/dev-libs/boost/files/boost-1.53.0-glibc-2.18-compat.patch b/dev-libs/boost/files/boost-1.53.0-glibc-2.18-compat.patch
new file mode 100644
index 000000000000..54d2e2990205
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.53.0-glibc-2.18-compat.patch
@@ -0,0 +1,18 @@
+Patch for compatibility with glibc 2.18
+Gentoo bugreport: https://bugs.gentoo.org/show_bug.cgi?id=482372
+Upstream fix: https://svn.boost.org/trac/boost/changeset/84950
+
+--- boost_1_53_0/boost/cstdint.hpp 2012-12-11 22:42:26.000000000 +0800
++++ boost_1_53_0.fix/boost/cstdint.hpp 2013-08-25 20:48:53.683000000 +0800
+@@ -41,7 +41,10 @@
+ // so we disable use of stdint.h when GLIBC does not define __GLIBC_HAVE_LONG_LONG.
+ // See https://svn.boost.org/trac/boost/ticket/3548 and http://sources.redhat.com/bugzilla/show_bug.cgi?id=10990
+ //
+-#if defined(BOOST_HAS_STDINT_H) && (!defined(__GLIBC__) || defined(__GLIBC_HAVE_LONG_LONG))
++#if defined(BOOST_HAS_STDINT_H) \
++ && (!defined(__GLIBC__) \
++ || defined(__GLIBC_HAVE_LONG_LONG) \
++ || (defined(__GLIBC__) && ((__GLIBC__ > 2) || ((__GLIBC__ == 2) && (__GLIBC_MINOR__ >= 17)))))
+
+ // The following #include is an implementation artifact; not part of interface.
+ # ifdef __hpux