summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2013-12-22 11:46:41 +0000
committerRalph Sennhauser <sera@gentoo.org>2013-12-22 11:46:41 +0000
commit405f610c4104c764731e339aae476c1311256a38 (patch)
tree8b0b5ffa96f30c5e21b84ff1756b1a57a3bfacde /dev-libs/boehm-gc
parentFix fperms invocation (#494886 by Zhang Hongjiu), drop old. (diff)
downloadgentoo-2-405f610c4104c764731e339aae476c1311256a38.tar.gz
gentoo-2-405f610c4104c764731e339aae476c1311256a38.tar.bz2
gentoo-2-405f610c4104c764731e339aae476c1311256a38.zip
Version bump.
No longer install private headers for #44251. (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 3C5CF75A)
Diffstat (limited to 'dev-libs/boehm-gc')
-rw-r--r--dev-libs/boehm-gc/ChangeLog8
-rw-r--r--dev-libs/boehm-gc/boehm-gc-7.4.0.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/boehm-gc/ChangeLog b/dev-libs/boehm-gc/ChangeLog
index 8b5985d98ab4..6efb8cfe18c5 100644
--- a/dev-libs/boehm-gc/ChangeLog
+++ b/dev-libs/boehm-gc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/boehm-gc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/ChangeLog,v 1.105 2013/11/18 18:12:48 sera Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/ChangeLog,v 1.106 2013/12/22 11:46:41 sera Exp $
+
+*boehm-gc-7.4.0 (22 Dec 2013)
+
+ 22 Dec 2013; Ralph Sennhauser <sera@gentoo.org> +boehm-gc-7.4.0.ebuild:
+ Version bump.
+ No longer install private headers for #44251.
*boehm-gc-7.2e (18 Nov 2013)
diff --git a/dev-libs/boehm-gc/boehm-gc-7.4.0.ebuild b/dev-libs/boehm-gc/boehm-gc-7.4.0.ebuild
new file mode 100644
index 000000000000..733601787236
--- /dev/null
+++ b/dev-libs/boehm-gc/boehm-gc-7.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boehm-gc/boehm-gc-7.4.0.ebuild,v 1.1 2013/12/22 11:46:41 sera Exp $
+
+EAPI=5
+
+inherit eutils
+
+MY_P="gc-${PV}"
+
+DESCRIPTION="The Boehm-Demers-Weiser conservative garbage collector"
+HOMEPAGE="http://www.hpl.hp.com/personal/Hans_Boehm/gc/"
+SRC_URI="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/${MY_P}.tar.gz"
+
+LICENSE="boehm-gc"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="cxx static-libs threads"
+
+DEPEND=">=dev-libs/libatomic_ops-7.4
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local config=(
+ --with-libatomic-ops
+ $(use_enable cxx cplusplus)
+ $(use_enable static-libs static)
+ $(use threads || echo --disable-threads)
+ )
+ econf "${config[@]}"
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+
+ rm -r "${ED}"/usr/share/gc || die
+ dodoc README.QUICK doc/README{.environment,.linux,.macros} \
+ doc/barrett_diagram
+ dohtml doc/*.html
+ newman doc/gc.man GC_malloc.1
+}