summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-04-20 19:30:22 +0000
committerPacho Ramos <pacho@gentoo.org>2012-04-20 19:30:22 +0000
commitc2e9a5d04d3b80e94a7121e052036c3ffc154fb1 (patch)
tree3bf10b3deb250b9e675f2ac770b036ebcc8f8df1 /dev-libs/ace
parentPrevent goffice from accidentally linking to pcre and causing undefined (diff)
downloadgentoo-2-c2e9a5d04d3b80e94a7121e052036c3ffc154fb1.tar.gz
gentoo-2-c2e9a5d04d3b80e94a7121e052036c3ffc154fb1.tar.bz2
gentoo-2-c2e9a5d04d3b80e94a7121e052036c3ffc154fb1.zip
Drop -O3 flag per bug #322941, letting it be the only version still compiling for me in the tree.
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/ace')
-rw-r--r--dev-libs/ace/ChangeLog10
-rw-r--r--dev-libs/ace/ace-5.6.1.ebuild76
-rw-r--r--dev-libs/ace/ace-5.6.5-r1.ebuild80
-rw-r--r--dev-libs/ace/ace-5.6.5-r2.ebuild81
-rw-r--r--dev-libs/ace/ace-5.6.5.ebuild76
-rw-r--r--dev-libs/ace/ace-5.7.2.ebuild6
6 files changed, 12 insertions, 317 deletions
diff --git a/dev-libs/ace/ChangeLog b/dev-libs/ace/ChangeLog
index c685559dadc0..cd0558bc8894 100644
--- a/dev-libs/ace/ChangeLog
+++ b/dev-libs/ace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/ace
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.61 2011/07/20 13:56:04 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.62 2012/04/20 19:30:22 pacho Exp $
+
+ 20 Apr 2012; Pacho Ramos <pacho@gentoo.org> -ace-5.6.1.ebuild,
+ -ace-5.6.5-r1.ebuild, -ace-5.6.5-r2.ebuild, -ace-5.6.5.ebuild,
+ ace-5.7.2.ebuild:
+ Drop -O3 flag per bug #322941, letting it be the only version still compiling
+ for me in the tree.
20 Jul 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #34534
diff --git a/dev-libs/ace/ace-5.6.1.ebuild b/dev-libs/ace/ace-5.6.1.ebuild
deleted file mode 100644
index 33f1baa8d222..000000000000
--- a/dev-libs/ace/ace-5.6.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.6.1.ebuild,v 1.2 2007/10/08 09:06:40 dragonheart Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="The Adaptive Communications Environment"
-HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
-SRC_URI="!tao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2 )
- tao? (
- !ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO-${PV}.tar.bz2 )
- ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO+CIAO-${PV}.tar.bz2 )
- )"
-LICENSE="BSD as-is"
-SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
-IUSE="X ipv6 tao ciao"
-
-COMMON_DEPEND="dev-libs/openssl"
-# TODO probably more
-RDEPEND="${COMMON_DEPEND}
- X? ( x11-libs/libXt x11-libs/libXaw )"
-
-DEPEND="${COMMON_DEPEND}
- X? ( x11-proto/xproto )"
-
-S="${WORKDIR}/ACE_wrappers"
-
-src_compile() {
- export ACE_ROOT="${S}"
- mkdir build
- cd build
-
- # This disables a silly test which fills the memory
- # waiting for a bad_alloc exception and happily
- # leaking memory (bug #169647)
- export ace_cv_new_throws_bad_alloc_exception="yes"
-
- ECONF_SOURCE="${S}"
- econf \
- --enable-lib-all \
- $(use_with X) \
- $(use_enable ipv6) \
- || die "econf died"
- # --with-qos needs ACE_HAS_RAPI
- emake static_libs=1 || die "emake failed"
-}
-
-src_install() {
- cd build
- emake ACE_ROOT="${S}" DESTDIR="${D}" install || die "failed to install"
- insinto /usr/include/ace
- doins "${S}/ace/OS.inl"
- doins "${S}/ace/Select_Reactor.h"
- # punt gperf stuff
- rm -rf "${D}/usr/bin" "${D}/usr/share"
-}
-
-src_test() {
- cd "${S}/build"
- emake ACE_ROOT="${S}" check || die "self test failed"
- sed -i -e "^#define PACKAGE_.*//g" /usr/include/ace/config.h
-}
-
-pkg_postinst() {
-
- local CC_MACHINE=$($(tc-getCC) -dumpmachine)
- if [ -d "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" ]; then
- ewarn "moving /usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace to"
- ewarn "ace.old"
- ewarn "This is required, as anything trying to compile against ACE will"
- ewarn "have problems with conflicting OS.h files if this is not done."
- mv "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" \
- "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace.old"
- fi
-}
diff --git a/dev-libs/ace/ace-5.6.5-r1.ebuild b/dev-libs/ace/ace-5.6.5-r1.ebuild
deleted file mode 100644
index 3f39b838e5a3..000000000000
--- a/dev-libs/ace/ace-5.6.5-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.6.5-r1.ebuild,v 1.2 2008/11/04 13:36:07 dragonheart Exp $
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="The Adaptive Communications Environment"
-HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
-SRC_URI="!tao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2 )
- tao? (
- !ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO-${PV}.tar.bz2 )
- ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO+CIAO-${PV}.tar.bz2 )
- )"
-LICENSE="BSD as-is"
-SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
-IUSE="X ipv6 tao ciao"
-
-COMMON_DEPEND="dev-libs/openssl"
-# TODO probably more
-RDEPEND="${COMMON_DEPEND}
- X? ( x11-libs/libXt x11-libs/libXaw )"
-
-DEPEND="${COMMON_DEPEND}
- X? ( x11-proto/xproto )"
-
-S="${WORKDIR}/ACE_wrappers"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/ace-missing-refcountable-header.patch
-}
-
-src_compile() {
- export ACE_ROOT="${S}"
- mkdir build
- cd build
-
- ECONF_SOURCE="${S}"
- econf \
- --enable-lib-all \
- $(use_with X) \
- $(use_enable ipv6) \
- || die "econf died"
- # --with-qos needs ACE_HAS_RAPI
- emake static_libs=1 || die "emake failed"
-}
-
-src_install() {
- cd build
- emake ACE_ROOT="${S}" DESTDIR="${D}" install || die "failed to install"
- insinto /usr/include/ace
- doins \
- "${S}/ace/Svc_Conf_Token_Table.h" \
- "${S}/ace/Unbounded_Set_Ex.inl" \
- "${S}/ace/Unbounded_Set_Ex.h" \
- "${S}/ace/Unbounded_Set_Ex.cpp"
- # punt gperf stuff
- rm -rf "${D}/usr/bin" "${D}/usr/share"
-}
-
-src_test() {
- cd "${S}/build"
- emake ACE_ROOT="${S}" check || die "self test failed"
- sed -i -e "^#define PACKAGE_.*//g" /usr/include/ace/config.h
-}
-
-pkg_postinst() {
-
- local CC_MACHINE=$($(tc-getCC) -dumpmachine)
- if [ -d "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" ]; then
- ewarn "moving /usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace to"
- ewarn "ace.old"
- ewarn "This is required, as anything trying to compile against ACE will"
- ewarn "have problems with conflicting OS.h files if this is not done."
- mv "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" \
- "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace.old"
- fi
-}
diff --git a/dev-libs/ace/ace-5.6.5-r2.ebuild b/dev-libs/ace/ace-5.6.5-r2.ebuild
deleted file mode 100644
index 7b3f580f7e28..000000000000
--- a/dev-libs/ace/ace-5.6.5-r2.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.6.5-r2.ebuild,v 1.1 2008/12/14 11:56:46 mrness Exp $
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="The Adaptive Communications Environment"
-HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
-SRC_URI="!tao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2 )
- tao? (
- !ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO-${PV}.tar.bz2 )
- ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO+CIAO-${PV}.tar.bz2 )
- )"
-LICENSE="BSD as-is"
-SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
-IUSE="X ipv6 tao ciao"
-
-COMMON_DEPEND="dev-libs/openssl"
-# TODO probably more
-RDEPEND="${COMMON_DEPEND}
- X? ( x11-libs/libXt x11-libs/libXaw )"
-
-DEPEND="${COMMON_DEPEND}
- X? ( x11-proto/xproto )"
-
-S="${WORKDIR}/ACE_wrappers"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/ace-missing-refcountable-header.patch
-}
-
-src_compile() {
- export ACE_ROOT="${S}"
- mkdir build
- cd build
-
- ECONF_SOURCE="${S}"
- econf \
- --enable-lib-all \
- $(use_with X) \
- $(use_enable ipv6) \
- || die "econf died"
- # --with-qos needs ACE_HAS_RAPI
- emake static_libs=1 || die "emake failed"
-}
-
-src_install() {
- cd build
- emake ACE_ROOT="${S}" DESTDIR="${D}" install || die "failed to install"
- insinto /usr/include/ace
- doins \
- "${S}/ace/Svc_Conf_Token_Table.h" \
- "${S}/ace/Unbounded_Set_Ex.inl" \
- "${S}/ace/Unbounded_Set_Ex.h" \
- "${S}/ace/Unbounded_Set_Ex.cpp"
- # punt gperf stuff
- rm -rf "${D}/usr/bin" "${D}/usr/share"
- # remove PACKAGE_* definitions from installed config.h (#192676)
- sed -i -e "s:^[ \t]*#define[ \t]\+PACKAGE_.*$:/\* & \*/:g" "${D}/usr/include/ace/config.h"
-}
-
-src_test() {
- cd "${S}/build"
- emake ACE_ROOT="${S}" check || die "self test failed"
-}
-
-pkg_postinst() {
-
- local CC_MACHINE=$($(tc-getCC) -dumpmachine)
- if [ -d "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" ]; then
- ewarn "moving /usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace to"
- ewarn "ace.old"
- ewarn "This is required, as anything trying to compile against ACE will"
- ewarn "have problems with conflicting OS.h files if this is not done."
- mv "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" \
- "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace.old"
- fi
-}
diff --git a/dev-libs/ace/ace-5.6.5.ebuild b/dev-libs/ace/ace-5.6.5.ebuild
deleted file mode 100644
index 900b54ea60c5..000000000000
--- a/dev-libs/ace/ace-5.6.5.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.6.5.ebuild,v 1.1 2008/06/20 14:21:27 dragonheart Exp $
-
-inherit toolchain-funcs
-
-DESCRIPTION="The Adaptive Communications Environment"
-HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
-SRC_URI="!tao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2 )
- tao? (
- !ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO-${PV}.tar.bz2 )
- ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO+CIAO-${PV}.tar.bz2 )
- )"
-LICENSE="BSD as-is"
-SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
-IUSE="X ipv6 tao ciao"
-
-COMMON_DEPEND="dev-libs/openssl"
-# TODO probably more
-RDEPEND="${COMMON_DEPEND}
- X? ( x11-libs/libXt x11-libs/libXaw )"
-
-DEPEND="${COMMON_DEPEND}
- X? ( x11-proto/xproto )"
-
-S="${WORKDIR}/ACE_wrappers"
-
-src_compile() {
- export ACE_ROOT="${S}"
- mkdir build
- cd build
-
- # This disables a silly test which fills the memory
- # waiting for a bad_alloc exception and happily
- # leaking memory (bug #169647)
- #export ace_cv_new_throws_bad_alloc_exception="yes"
-
- ECONF_SOURCE="${S}"
- econf \
- --enable-lib-all \
- $(use_with X) \
- $(use_enable ipv6) \
- || die "econf died"
- # --with-qos needs ACE_HAS_RAPI
- emake static_libs=1 || die "emake failed"
-}
-
-src_install() {
- cd build
- emake ACE_ROOT="${S}" DESTDIR="${D}" install || die "failed to install"
- insinto /usr/include/ace
- doins "${S}/ace/OS.inl"
- doins "${S}/ace/Select_Reactor.h"
- # punt gperf stuff
- rm -rf "${D}/usr/bin" "${D}/usr/share"
-}
-
-src_test() {
- cd "${S}/build"
- emake ACE_ROOT="${S}" check || die "self test failed"
- sed -i -e "^#define PACKAGE_.*//g" /usr/include/ace/config.h
-}
-
-pkg_postinst() {
-
- local CC_MACHINE=$($(tc-getCC) -dumpmachine)
- if [ -d "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" ]; then
- ewarn "moving /usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace to"
- ewarn "ace.old"
- ewarn "This is required, as anything trying to compile against ACE will"
- ewarn "have problems with conflicting OS.h files if this is not done."
- mv "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" \
- "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace.old"
- fi
-}
diff --git a/dev-libs/ace/ace-5.7.2.ebuild b/dev-libs/ace/ace-5.7.2.ebuild
index ce6791cee583..f9929af902f3 100644
--- a/dev-libs/ace/ace-5.7.2.ebuild
+++ b/dev-libs/ace/ace-5.7.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.7.2.ebuild,v 1.2 2010/07/13 00:19:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.7.2.ebuild,v 1.3 2012/04/20 19:30:22 pacho Exp $
inherit toolchain-funcs eutils
@@ -33,6 +33,8 @@ src_unpack() {
if has_version ">=dev-libs/openssl-1.0.0"; then
sed -i -e 's:SSL_METHOD:const SSL_METHOD:' configure || die
fi
+
+ sed -i -e 's/-O3//' configure || die
}
src_compile() {