summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-07-12 22:00:32 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-07-12 22:00:32 +0000
commit5c27684d9169a2645513d3e9353f02b04bb87edd (patch)
tree5e4111f3bb772fe6afa3c0e61055601c15d4b8a8 /dev-libs/ace
parentVerbump fixes #171884 and #180510 (diff)
downloadgentoo-2-5c27684d9169a2645513d3e9353f02b04bb87edd.tar.gz
gentoo-2-5c27684d9169a2645513d3e9353f02b04bb87edd.tar.bz2
gentoo-2-5c27684d9169a2645513d3e9353f02b04bb87edd.zip
Cosmetic cleanup, fixed bug #169647
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'dev-libs/ace')
-rw-r--r--dev-libs/ace/ChangeLog5
-rw-r--r--dev-libs/ace/ace-5.5.8.ebuild66
2 files changed, 40 insertions, 31 deletions
diff --git a/dev-libs/ace/ChangeLog b/dev-libs/ace/ChangeLog
index ab0c0371b5af..74ab32c453df 100644
--- a/dev-libs/ace/ChangeLog
+++ b/dev-libs/ace/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/ace
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.47 2007/06/22 22:24:51 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.48 2007/07/12 22:00:32 dev-zero Exp $
+
+ 12 Jul 2007; Tiziano Müller <dev-zero@gentoo.org> ace-5.5.8.ebuild:
+ Cosmetic cleanup, fixed bug #169647
*ace-5.5.8 (22 Jun 2007)
diff --git a/dev-libs/ace/ace-5.5.8.ebuild b/dev-libs/ace/ace-5.5.8.ebuild
index c4b36137f688..5124a6d43599 100644
--- a/dev-libs/ace/ace-5.5.8.ebuild
+++ b/dev-libs/ace/ace-5.5.8.ebuild
@@ -1,22 +1,18 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.5.8.ebuild,v 1.3 2007/07/12 02:25:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.5.8.ebuild,v 1.4 2007/07/12 22:00:32 dev-zero Exp $
-S="${WORKDIR}/ACE_wrappers"
-DESCRIPTION="The Adaptive Communications Environment"
-SRC_URI="!tao? (
- http://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2 )
- tao? ( !ciao? (
- http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO-${PV}.tar.bz2 )
- ciao? (
- http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO+CIAO-${PV}.tar.bz2
- )
- )"
+inherit toolchain-funcs
+DESCRIPTION="The Adaptive Communications Environment"
HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
-
-SLOT="0"
+SRC_URI="!tao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE-${PV}.tar.bz2 )
+ tao? (
+ !ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO-${PV}.tar.bz2 )
+ ciao? ( http://download.dre.vanderbilt.edu/previous_versions/ACE+TAO+CIAO-${PV}.tar.bz2 )
+ )"
LICENSE="BSD as-is"
+SLOT="0"
KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
IUSE="X ipv6 tao ciao"
@@ -35,40 +31,50 @@ DEPEND="${COMMON_DEPEND}
virtual/x11 )
)"
+S="${WORKDIR}/ACE_wrappers"
+
src_compile() {
export ACE_ROOT="${S}"
mkdir build
cd build
+
+ # This disables a silly test which fills the memory
+ # waiting for a bad_alloc exception and happily
+ # leaking memory (bug #169647)
+ export ace_cv_new_throws_bad_alloc_exception="yes"
+
ECONF_SOURCE="${S}"
- econf --enable-lib-all $(use_with X) $(use_enable ipv6) || \
- die "econf died"
+ econf \
+ --enable-lib-all \
+ $(use_with X) \
+ $(use_enable ipv6) \
+ || die "econf died"
# --with-qos needs ACE_HAS_RAPI
- emake static_libs=1 || die
-}
-
-src_test() {
- cd "${S}"/build
- make ACE_ROOT=${S} check || die "self test failed"
+ emake static_libs=1 || die "emake failed"
}
src_install() {
cd build
- make ACE_ROOT="${S}" DESTDIR="${D}" install || die "failed to install"
+ emake ACE_ROOT="${S}" DESTDIR="${D}" install || die "failed to install"
insinto /usr/include/ace
- doins "${S}"/ace/OS.inl
- doins "${S}"/ace/Select_Reactor.h
+ doins "${S}/ace/OS.inl"
+ doins "${S}/ace/Select_Reactor.h"
# punt gperf stuff
- rm -rf "${D}"/usr/bin "${D}"/usr/share
+ rm -rf "${D}/usr/bin" "${D}/usr/share"
+}
+
+src_test() {
+ cd "${S}/build"
+ emake ACE_ROOT="${S}" check || die "self test failed"
}
pkg_postinst() {
# This is required, as anything trying to compile against ACE will have
# problems with conflicting OS.h files if this is not done.
- local CC_MACHINE=`gcc -dumpmachine`
- local CC_VERSION=`gcc -dumpversion`
- if [ -d "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" ]; then
- mv "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" \
- "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace.old"
+ local CC_MACHINE=$($(tc-getCC) -dumpmachine)
+ if [ -d "/usr/lib/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" ]; then
+ mv "/usr/lib/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace" \
+ "/usr/lib/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace.old"
fi
}