summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-15 09:58:58 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-15 09:58:58 +0000
commitdc7ac00a8f61aa218a9232b5737e6410e486e7b0 (patch)
tree22a396249d18e5627002cbe69f23c8821b547f48 /dev-lang
parentRemove dependency on opencl useflag since it was dropped in ati-drivers. Fixe... (diff)
downloadgentoo-2-dc7ac00a8f61aa218a9232b5737e6410e486e7b0.tar.gz
gentoo-2-dc7ac00a8f61aa218a9232b5737e6410e486e7b0.tar.bz2
gentoo-2-dc7ac00a8f61aa218a9232b5737e6410e486e7b0.zip
Version bump. Update to EAPI 4.
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/orc/ChangeLog9
-rw-r--r--dev-lang/orc/orc-0.4.16.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-lang/orc/ChangeLog b/dev-lang/orc/ChangeLog
index efcdb9f2803e..a43da41cd8c2 100644
--- a/dev-lang/orc/ChangeLog
+++ b/dev-lang/orc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/orc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/ChangeLog,v 1.22 2011/11/24 22:42:57 naota Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/ChangeLog,v 1.23 2012/02/15 09:58:58 radhermit Exp $
+
+*orc-0.4.16 (15 Feb 2012)
+
+ 15 Feb 2012; Tim Harder <radhermit@gentoo.org> +orc-0.4.16.ebuild:
+ Version bump. Update to EAPI 4.
24 Nov 2011; Naohiro Aota <naota@gentoo.org> orc-0.4.14.ebuild:
Add ~x86-fbsd
diff --git a/dev-lang/orc/orc-0.4.16.ebuild b/dev-lang/orc/orc-0.4.16.ebuild
new file mode 100644
index 000000000000..43c7220ff414
--- /dev/null
+++ b/dev-lang/orc/orc-0.4.16.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/orc/orc-0.4.16.ebuild,v 1.1 2012/02/15 09:58:58 radhermit Exp $
+
+EAPI=4
+inherit autotools flag-o-matic
+
+DESCRIPTION="The Oil Runtime Compiler"
+HOMEPAGE="http://code.entropywave.com/projects/orc/"
+SRC_URI="http://code.entropywave.com/download/orc/${P}.tar.gz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs examples"
+
+src_prepare() {
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' Makefile.am || die
+ AT_M4DIR="m4" eautoreconf
+ fi
+}
+
+src_configure() {
+ # any optimisation on PPC/Darwin yields in a complaint from the assembler
+ # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
+ # the same for Intel/Darwin, although the error message there is different
+ # but along the same lines
+ [[ ${CHOST} == *-darwin* ]] && filter-flags -O*
+ econf \
+ $(use_enable static-libs static) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete
+}