summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 16:21:25 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 16:21:25 +0000
commitc8b463b31ba0ca8f69f70b855ef7d3ebe575dac4 (patch)
treedec07ee11a4203a6eb8813defcd625d2145b8257 /dev-lang
parentneed eutils for epatch (diff)
downloadgentoo-2-c8b463b31ba0ca8f69f70b855ef7d3ebe575dac4.tar.gz
gentoo-2-c8b463b31ba0ca8f69f70b855ef7d3ebe575dac4.tar.bz2
gentoo-2-c8b463b31ba0ca8f69f70b855ef7d3ebe575dac4.zip
need eutils for epatch
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/erlang/erlang-9c-r1.ebuild4
-rw-r--r--dev-lang/nhc98/nhc98-1.12.ebuild21
-rw-r--r--dev-lang/nhc98/nhc98-1.16-r1.ebuild25
-rw-r--r--dev-lang/nhc98/nhc98-1.16.ebuild25
-rw-r--r--dev-lang/ocaml/ocaml-3.06-r1.ebuild27
-rw-r--r--dev-lang/ocaml/ocaml-3.06.ebuild25
-rw-r--r--dev-lang/python/python-2.2.3-r1.ebuild4
-rw-r--r--dev-lang/ruby/ruby-1.6.8-r1.ebuild19
-rw-r--r--dev-lang/ruby/ruby-1.6.8.ebuild18
-rw-r--r--dev-lang/ruby/ruby-1.8.0_pre2-r1.ebuild15
-rw-r--r--dev-lang/ruby/ruby-1.8.0_pre2-r2.ebuild15
-rw-r--r--dev-lang/ruby/ruby-1.8.0_pre2-r3.ebuild15
-rw-r--r--dev-lang/ruby/ruby-1.8.0_pre2.ebuild17
-rw-r--r--dev-lang/ruby/ruby-1.8.0_pre3.ebuild12
-rw-r--r--dev-lang/ruby/ruby-1.8.0_pre4.ebuild12
-rw-r--r--dev-lang/ruby/ruby-1.8.0_pre5.ebuild12
-rw-r--r--dev-lang/ruby/ruby-1.8.0_pre6.ebuild12
-rw-r--r--dev-lang/sather/sather-1.3.ebuild14
18 files changed, 137 insertions, 155 deletions
diff --git a/dev-lang/erlang/erlang-9c-r1.ebuild b/dev-lang/erlang/erlang-9c-r1.ebuild
index 064975061476..668773fdfe73 100644
--- a/dev-lang/erlang/erlang-9c-r1.ebuild
+++ b/dev-lang/erlang/erlang-9c-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-9c-r1.ebuild,v 1.3 2003/07/28 13:34:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-9c-r1.ebuild,v 1.4 2003/08/05 16:21:25 vapier Exp $
+
+inherit eutils
MY_P=otp_src_R9B-1
DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
diff --git a/dev-lang/nhc98/nhc98-1.12.ebuild b/dev-lang/nhc98/nhc98-1.12.ebuild
index bf65482ebcc6..b5d68da8fbbf 100644
--- a/dev-lang/nhc98/nhc98-1.12.ebuild
+++ b/dev-lang/nhc98/nhc98-1.12.ebuild
@@ -1,31 +1,28 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.12.ebuild,v 1.8 2003/06/12 20:31:38 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.12.ebuild,v 1.9 2003/08/05 16:21:25 vapier Exp $
-IUSE="readline"
-
-TARBALL=nhc98src-${PV}.tar.gz
+inherit eutils
DESCRIPTION="Haskell 98 compiler"
-SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/${TARBALL}"
HOMEPAGE="http://www.cs.york.ac.uk/fp/nhc98/"
+SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/nhc98src-${PV}.tar.gz"
-SLOT="0"
LICENSE="nhc98"
-KEYWORDS="x86 sparc "
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE="readline"
DEPEND="readline? ( >=readline-4.1 )"
src_unpack() {
- # unpack the source
- unpack "${TARBALL}"
+ unpack ${A}
# patch to fix the getenv bug when tracing
cd ${P}
- patch -p0 < ${FILESDIR}/nhc98-1.12-getenv.patch
+ epatch ${FILESDIR}/nhc98-1.12-getenv.patch
}
src_compile() {
-
./configure --buildwith=gcc \
--prefix=/usr --installdir=/usr \
-man -docs \
@@ -35,7 +32,7 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
# The install location is taken care of by the
# configure script.
make DESTDIR=${D} install || die
diff --git a/dev-lang/nhc98/nhc98-1.16-r1.ebuild b/dev-lang/nhc98/nhc98-1.16-r1.ebuild
index 1ff6082d057b..6cd2d9b056bb 100644
--- a/dev-lang/nhc98/nhc98-1.16-r1.ebuild
+++ b/dev-lang/nhc98/nhc98-1.16-r1.ebuild
@@ -1,35 +1,30 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16-r1.ebuild,v 1.2 2003/07/11 22:14:07 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16-r1.ebuild,v 1.3 2003/08/05 16:21:25 vapier Exp $
-IUSE="readline"
-
-TARBALL="nhc98src-${PV}.tar.gz"
+inherit eutils
DESCRIPTION="Haskell 98 compiler"
-SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/${TARBALL}
- ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/patch-1.16-typesyn"
HOMEPAGE="http://www.cs.york.ac.uk/fp/nhc98/"
+SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/nhc98src-${PV}.tar.gz
+ ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/patch-1.16-typesyn"
-SLOT="0"
LICENSE="nhc98"
-KEYWORDS="x86 ~sparc "
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+IUSE="readline"
DEPEND="virtual/glibc
readline? ( >=readline-4.1 )"
src_unpack() {
- # unpack the source
- unpack "${TARBALL}"
+ unpack nhc98src-${PV}.tar.gz
# type synoym patch
cd ${S}
epatch ${DISTDIR}/patch-1.16-typesyn
-# cd ${P}
-# patch -p0 < ${FILESDIR}/patch-1.16-typesyn
}
src_compile() {
-
./configure --buildwith=gcc \
--prefix=/usr --installdir=/usr \
-man -docs \
@@ -39,7 +34,7 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
# The install location is taken care of by the
# configure script.
make DESTDIR=${D} install || die
@@ -63,7 +58,7 @@ src_install () {
rm ${D}/usr/share/man/man1/hmake*
}
-pkg_postinst () {
+pkg_postinst() {
# info about new package structure
einfo "NOTICE: hmake is no longer a part of this package,"
einfo "but separately available as dev-haskell/hmake."
diff --git a/dev-lang/nhc98/nhc98-1.16.ebuild b/dev-lang/nhc98/nhc98-1.16.ebuild
index b90c57a431a0..b1fb5573dc76 100644
--- a/dev-lang/nhc98/nhc98-1.16.ebuild
+++ b/dev-lang/nhc98/nhc98-1.16.ebuild
@@ -1,35 +1,30 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16.ebuild,v 1.4 2003/07/11 22:14:07 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16.ebuild,v 1.5 2003/08/05 16:21:25 vapier Exp $
-IUSE="readline"
-
-TARBALL="nhc98src-${PV}.tar.gz"
+inherit eutils
DESCRIPTION="Haskell 98 compiler"
-SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/${TARBALL}
- ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/patch-1.16-typesyn"
HOMEPAGE="http://www.cs.york.ac.uk/fp/nhc98/"
+SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/nhc98src-${PV}.tar.gz
+ ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/patch-1.16-typesyn"
-SLOT="0"
LICENSE="nhc98"
-KEYWORDS="x86 ~sparc "
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+IUSE="readline"
DEPEND="virtual/glibc
readline? ( >=readline-4.1 )"
src_unpack() {
- # unpack the source
- unpack "${TARBALL}"
+ unpack nhc98src-${PV}.tar.gz
# type synoym patch
cd ${S}
epatch ${DISTDIR}/patch-1.16-typesyn
-# cd ${P}
-# patch -p0 < ${FILESDIR}/patch-1.16-typesyn
}
src_compile() {
-
./configure --buildwith=gcc \
--prefix=/usr --installdir=/usr \
-man -docs \
@@ -39,7 +34,7 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
# The install location is taken care of by the
# configure script.
make DESTDIR=${D} install || die
@@ -54,7 +49,7 @@ src_install () {
dodoc bugs/README
}
-pkg_postinst () {
+pkg_postinst() {
#nhc's build system does not update hmakerc when using DESTDIR;
#therefore, we do it manually here
diff --git a/dev-lang/ocaml/ocaml-3.06-r1.ebuild b/dev-lang/ocaml/ocaml-3.06-r1.ebuild
index 3edeea5b0b45..d760475e22e0 100644
--- a/dev-lang/ocaml/ocaml-3.06-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.06-r1.ebuild
@@ -1,27 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r1.ebuild,v 1.1 2003/05/02 08:34:40 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r1.ebuild,v 1.2 2003/08/05 16:21:25 vapier Exp $
-IUSE="tcltk"
-
-inherit flag-o-matic
+inherit flag-o-matic eutils
filter-flags "-fstack-protector"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Objective Caml is a fast modern type-inferring functional programming language descended from the ML (Meta Language) family."
-SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz"
+DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
+SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz"
-DEPEND="virtual/glibc
- tcltk? ( >=dev-lang/tk-3.3.3 )"
-
-SLOT="0"
LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
KEYWORDS="~x86 ~sparc ~ppc"
+IUSE="tcltk"
+
+DEPEND="virtual/glibc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
-src_compile()
-{
+src_compile() {
local myconf
use tcltk || myconf="-no-tk"
@@ -38,8 +34,7 @@ src_compile()
make opt.opt || die
}
-src_install ()
-{
+src_install() {
make BINDIR=${D}/usr/bin \
LIBDIR=${D}/usr/lib/ocaml \
MANDIR=${D}/usr/share/man \
diff --git a/dev-lang/ocaml/ocaml-3.06.ebuild b/dev-lang/ocaml/ocaml-3.06.ebuild
index fad5976c98eb..ab35ff84fb00 100644
--- a/dev-lang/ocaml/ocaml-3.06.ebuild
+++ b/dev-lang/ocaml/ocaml-3.06.ebuild
@@ -1,27 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06.ebuild,v 1.8 2003/04/11 18:32:16 method Exp $
-
-IUSE="tcltk"
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06.ebuild,v 1.9 2003/08/05 16:21:25 vapier Exp $
inherit flag-o-matic
filter-flags "-fstack-protector"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Objective Caml is a fast modern type-inferring functional programming language descended from the ML (Meta Language) family."
-SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz"
+DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
+SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz"
-DEPEND="virtual/glibc
- tcltk? ( >=dev-lang/tk-3.3.3 )"
-
-SLOT="0"
LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
KEYWORDS="x86 sparc ~ppc"
+IUSE="tcltk"
+
+DEPEND="virtual/glibc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
-src_compile()
-{
+src_compile() {
local myconf
use tcltk || myconf="-no-tk"
@@ -36,8 +32,7 @@ src_compile()
make opt.opt || die
}
-src_install ()
-{
+src_install() {
make BINDIR=${D}/usr/bin \
LIBDIR=${D}/usr/lib/ocaml \
MANDIR=${D}/usr/share/man \
diff --git a/dev-lang/python/python-2.2.3-r1.ebuild b/dev-lang/python/python-2.2.3-r1.ebuild
index 6299b197f2e6..54eb3fee82ad 100644
--- a/dev-lang/python/python-2.2.3-r1.ebuild
+++ b/dev-lang/python/python-2.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r1.ebuild,v 1.4 2003/07/23 12:22:33 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r1.ebuild,v 1.5 2003/08/05 16:21:25 vapier Exp $
IUSE="readline tcltk berkdb bootstrap build doc"
@@ -37,7 +37,7 @@ PROVIDE="virtual/python"
SLOT="2.2"
-inherit flag-o-matic
+inherit flag-o-matic eutils
src_unpack() {
unpack ${A}
diff --git a/dev-lang/ruby/ruby-1.6.8-r1.ebuild b/dev-lang/ruby/ruby-1.6.8-r1.ebuild
index 26415960cd33..7c4ad3696829 100644
--- a/dev-lang/ruby/ruby-1.6.8-r1.ebuild
+++ b/dev-lang/ruby/ruby-1.6.8-r1.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.6.8-r1.ebuild,v 1.3 2003/08/01 03:23:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.6.8-r1.ebuild,v 1.4 2003/08/05 16:21:25 vapier Exp $
+
+inherit flag-o-matic eutils
+filter-flags -fomit-frame-pointer
-S=${WORKDIR}/${P}
DESCRIPTION="An object-oriented scripting language"
-SRC_URI="mirror://ruby/${PV%.*}/${P/_pre/-preview}.tar.gz"
HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${PV%.*}/${P/_pre/-preview}.tar.gz"
+
LICENSE="Ruby"
-KEYWORDS="x86 alpha ppc sparc hppa amd64"
SLOT="0"
-
-inherit flag-o-matic
-filter-flags -fomit-frame-pointer
+KEYWORDS="x86 alpha ppc sparc hppa amd64"
DEPEND=">=sys-libs/glibc-2.1.3
>=sys-libs/gdbm-1.8.0
@@ -20,17 +20,16 @@ DEPEND=">=sys-libs/glibc-2.1.3
src_unpack() {
unpack ${A}
-
cd ${S}
use amd64 && epatch ${FILESDIR}/ruby-1.6.8-fix-x86_64.patch
}
src_compile() {
- econf --enable-shared
+ econf --enable-shared || die
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc COPYING* ChangeLog MANIFEST README* ToDo
}
diff --git a/dev-lang/ruby/ruby-1.6.8.ebuild b/dev-lang/ruby/ruby-1.6.8.ebuild
index c4d3ef4ccbb0..25d5a729ff15 100644
--- a/dev-lang/ruby/ruby-1.6.8.ebuild
+++ b/dev-lang/ruby/ruby-1.6.8.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.6.8.ebuild,v 1.11 2003/08/01 03:23:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.6.8.ebuild,v 1.12 2003/08/05 16:21:25 vapier Exp $
+
+inherit flag-o-matic eutils
+filter-flags -fomit-frame-pointer
-S=${WORKDIR}/${P}
DESCRIPTION="An object-oriented scripting language"
-SRC_URI="mirror://ruby/${PV%.*}/${P/_pre/-preview}.tar.gz"
HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${PV%.*}/${P/_pre/-preview}.tar.gz"
+
LICENSE="Ruby"
-KEYWORDS="x86 alpha ppc sparc hppa"
SLOT="0"
-
-inherit flag-o-matic
-filter-flags -fomit-frame-pointer
+KEYWORDS="x86 alpha ppc sparc hppa"
DEPEND=">=sys-libs/glibc-2.1.3
>=sys-libs/gdbm-1.8.0
@@ -19,11 +19,11 @@ DEPEND=">=sys-libs/glibc-2.1.3
>=sys-libs/ncurses-5.2"
src_compile() {
- econf
+ econf || die
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc COPYING* ChangeLog MANIFEST README* ToDo
}
diff --git a/dev-lang/ruby/ruby-1.8.0_pre2-r1.ebuild b/dev-lang/ruby/ruby-1.8.0_pre2-r1.ebuild
index d8a28484e995..4f6aa9b711c3 100644
--- a/dev-lang/ruby/ruby-1.8.0_pre2-r1.ebuild
+++ b/dev-lang/ruby/ruby-1.8.0_pre2-r1.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre2-r1.ebuild,v 1.2 2003/08/01 03:23:26 agriffis Exp $
-
-IUSE="socks5 tcltk"
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre2-r1.ebuild,v 1.3 2003/08/05 16:21:25 vapier Exp $
inherit flag-o-matic eutils
-S=${WORKDIR}/${P%_pre*}
DESCRIPTION="An object-oriented scripting language"
-SRC_URI="mirror://ruby/${P/_pre/-preview}.tar.gz"
HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${P/_pre/-preview}.tar.gz"
+
LICENSE="Ruby"
-KEYWORDS="~x86 ~alpha"
SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE="socks5 tcltk"
DEPEND=">=sys-libs/glibc-2.1.3
>=sys-libs/gdbm-1.8.0
@@ -21,6 +20,8 @@ DEPEND=">=sys-libs/glibc-2.1.3
socks5? ( >=net-misc/dante-1.1.13 )
tcltk? ( dev-lang/tk )"
+S=${WORKDIR}/${P%_pre*}
+
src_unpack() {
unpack ${A}
cd ${WORKDIR}
@@ -49,7 +50,7 @@ src_compile() {
emake || die "emake failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc COPYING* ChangeLog MANIFEST README* ToDo
}
diff --git a/dev-lang/ruby/ruby-1.8.0_pre2-r2.ebuild b/dev-lang/ruby/ruby-1.8.0_pre2-r2.ebuild
index 2a8198d3b5f3..95bb82339fde 100644
--- a/dev-lang/ruby/ruby-1.8.0_pre2-r2.ebuild
+++ b/dev-lang/ruby/ruby-1.8.0_pre2-r2.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre2-r2.ebuild,v 1.3 2003/08/01 03:23:26 agriffis Exp $
-
-IUSE="socks5 tcltk"
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre2-r2.ebuild,v 1.4 2003/08/05 16:21:25 vapier Exp $
inherit flag-o-matic eutils
-S=${WORKDIR}/${P%_pre*}
DESCRIPTION="An object-oriented scripting language"
-SRC_URI="mirror://ruby/${P/_pre/-preview}.tar.gz"
HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${P/_pre/-preview}.tar.gz"
+
LICENSE="Ruby"
-KEYWORDS="~x86 ~alpha"
SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE="socks5 tcltk"
DEPEND=">=sys-libs/glibc-2.1.3
>=sys-libs/gdbm-1.8.0
@@ -21,6 +20,8 @@ DEPEND=">=sys-libs/glibc-2.1.3
socks5? ( >=net-misc/dante-1.1.13 )
tcltk? ( dev-lang/tk )"
+S=${WORKDIR}/${P%_pre*}
+
src_unpack() {
unpack ${A}
cd ${WORKDIR}
@@ -49,7 +50,7 @@ src_compile() {
emake || die "emake failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc COPYING* ChangeLog MANIFEST README* ToDo
}
diff --git a/dev-lang/ruby/ruby-1.8.0_pre2-r3.ebuild b/dev-lang/ruby/ruby-1.8.0_pre2-r3.ebuild
index 284ba973e61f..4a902892fe41 100644
--- a/dev-lang/ruby/ruby-1.8.0_pre2-r3.ebuild
+++ b/dev-lang/ruby/ruby-1.8.0_pre2-r3.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre2-r3.ebuild,v 1.2 2003/08/01 03:23:26 agriffis Exp $
-
-IUSE="socks5 tcltk"
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre2-r3.ebuild,v 1.3 2003/08/05 16:21:25 vapier Exp $
inherit flag-o-matic eutils
-S=${WORKDIR}/${P%_pre*}
DESCRIPTION="An object-oriented scripting language"
-SRC_URI="mirror://ruby/${P/_pre/-preview}.tar.gz"
HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${P/_pre/-preview}.tar.gz"
+
LICENSE="Ruby"
-KEYWORDS="~x86 ~alpha"
SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE="socks5 tcltk"
DEPEND=">=sys-libs/glibc-2.1.3
>=sys-libs/gdbm-1.8.0
@@ -22,6 +21,8 @@ DEPEND=">=sys-libs/glibc-2.1.3
tcltk? ( dev-lang/tk )
sys-apps/findutils"
+S=${WORKDIR}/${P%_pre*}
+
src_unpack() {
unpack ${A}
cd ${WORKDIR}
@@ -50,7 +51,7 @@ src_compile() {
emake || die "emake failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc COPYING* ChangeLog MANIFEST README* ToDo
# Fix perms on directories (bug # 22446)
diff --git a/dev-lang/ruby/ruby-1.8.0_pre2.ebuild b/dev-lang/ruby/ruby-1.8.0_pre2.ebuild
index 65b20ef2c354..5d31b62924fc 100644
--- a/dev-lang/ruby/ruby-1.8.0_pre2.ebuild
+++ b/dev-lang/ruby/ruby-1.8.0_pre2.ebuild
@@ -1,29 +1,30 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre2.ebuild,v 1.4 2003/08/01 03:23:26 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre2.ebuild,v 1.5 2003/08/05 16:21:25 vapier Exp $
+
+inherit flag-o-matic
+filter-flags -fomit-frame-pointer
S=${WORKDIR}/${PN}-`echo ${PV} | sed 's/_pre[0-9]*//'`
DESCRIPTION="An object-oriented scripting language"
-SRC_URI="mirror://ruby/${PN}-`echo ${PV} | sed 's/_pre/-preview/'`.tar.gz"
HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${PN}-`echo ${PV} | sed 's/_pre/-preview/'`.tar.gz"
+
LICENSE="Ruby"
-KEYWORDS="~x86"
SLOT="0"
+KEYWORDS="~x86"
DEPEND=">=sys-libs/glibc-2.1.3
>=sys-libs/gdbm-1.8.0
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2"
-inherit flag-o-matic
-filter-flags -fomit-frame-pointer
-
src_compile() {
- econf
+ econf || die
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc COPYING* ChangeLog MANIFEST README* ToDo
}
diff --git a/dev-lang/ruby/ruby-1.8.0_pre3.ebuild b/dev-lang/ruby/ruby-1.8.0_pre3.ebuild
index 76cf03e3270a..4b5f0223af6a 100644
--- a/dev-lang/ruby/ruby-1.8.0_pre3.ebuild
+++ b/dev-lang/ruby/ruby-1.8.0_pre3.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre3.ebuild,v 1.3 2003/08/01 03:23:26 agriffis Exp $
-
-IUSE="socks5 tcltk"
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre3.ebuild,v 1.4 2003/08/05 16:21:25 vapier Exp $
inherit flag-o-matic eutils gnuconfig
S=${WORKDIR}/${P%_pre*}
DESCRIPTION="An object-oriented scripting language"
-SRC_URI="mirror://ruby/${P/_pre/-preview}.tar.gz"
HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${P/_pre/-preview}.tar.gz"
+
LICENSE="Ruby"
-KEYWORDS="~x86 ~alpha"
SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE="socks5 tcltk"
DEPEND=">=sys-libs/glibc-2.1.3
>=sys-libs/gdbm-1.8.0
@@ -55,7 +55,7 @@ src_compile() {
emake || die "emake failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc COPYING* ChangeLog MANIFEST README* ToDo
# Fix perms on directories (bug # 22446)
diff --git a/dev-lang/ruby/ruby-1.8.0_pre4.ebuild b/dev-lang/ruby/ruby-1.8.0_pre4.ebuild
index 1a8cdef0b5bb..4edc4475fd3a 100644
--- a/dev-lang/ruby/ruby-1.8.0_pre4.ebuild
+++ b/dev-lang/ruby/ruby-1.8.0_pre4.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre4.ebuild,v 1.2 2003/08/01 03:23:26 agriffis Exp $
-
-IUSE="socks5 tcltk"
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre4.ebuild,v 1.3 2003/08/05 16:21:25 vapier Exp $
inherit flag-o-matic eutils gnuconfig
S=${WORKDIR}/${P%_pre*}
DESCRIPTION="An object-oriented scripting language"
-SRC_URI="mirror://ruby/${P/_pre/-preview}.tar.gz"
HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${P/_pre/-preview}.tar.gz"
+
LICENSE="Ruby"
-KEYWORDS="~x86 ~alpha"
SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE="socks5 tcltk"
DEPEND=">=sys-libs/glibc-2.1.3
>=sys-libs/gdbm-1.8.0
@@ -55,7 +55,7 @@ src_compile() {
emake || die "emake failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc COPYING* ChangeLog MANIFEST README* ToDo
# Fix perms on directories (bug # 22446)
diff --git a/dev-lang/ruby/ruby-1.8.0_pre5.ebuild b/dev-lang/ruby/ruby-1.8.0_pre5.ebuild
index 395c7c32d32d..23d578b51a2f 100644
--- a/dev-lang/ruby/ruby-1.8.0_pre5.ebuild
+++ b/dev-lang/ruby/ruby-1.8.0_pre5.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre5.ebuild,v 1.3 2003/08/01 03:23:26 agriffis Exp $
-
-IUSE="socks5 tcltk"
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre5.ebuild,v 1.4 2003/08/05 16:21:25 vapier Exp $
inherit flag-o-matic eutils gnuconfig
S=${WORKDIR}/${P%_pre*}
DESCRIPTION="An object-oriented scripting language"
-SRC_URI="mirror://ruby/${P/_pre/-preview}.tar.gz"
HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${P/_pre/-preview}.tar.gz"
+
LICENSE="Ruby"
-KEYWORDS="~x86 ~alpha"
SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE="socks5 tcltk"
DEPEND=">=sys-libs/glibc-2.1.3
>=sys-libs/gdbm-1.8.0
@@ -55,7 +55,7 @@ src_compile() {
emake || die "emake failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc COPYING* ChangeLog MANIFEST README* ToDo
# Fix perms on directories (bug # 22446)
diff --git a/dev-lang/ruby/ruby-1.8.0_pre6.ebuild b/dev-lang/ruby/ruby-1.8.0_pre6.ebuild
index 05f3c5ca7c8d..313c235dcc3b 100644
--- a/dev-lang/ruby/ruby-1.8.0_pre6.ebuild
+++ b/dev-lang/ruby/ruby-1.8.0_pre6.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre6.ebuild,v 1.1 2003/08/01 03:23:26 agriffis Exp $
-
-IUSE="socks5 tcltk"
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0_pre6.ebuild,v 1.2 2003/08/05 16:21:25 vapier Exp $
inherit flag-o-matic eutils gnuconfig
S=${WORKDIR}/${P%_pre*}
DESCRIPTION="An object-oriented scripting language"
-SRC_URI="mirror://ruby/${PV%.*}/${P/_pre/-preview}.tar.gz"
HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${PV%.*}/${P/_pre/-preview}.tar.gz"
+
LICENSE="Ruby"
-KEYWORDS="~x86 ~alpha"
SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE="socks5 tcltk"
DEPEND=">=sys-libs/glibc-2.1.3
>=sys-libs/gdbm-1.8.0
@@ -52,7 +52,7 @@ src_compile() {
emake || die "emake failed"
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die "make install failed"
dodoc COPYING* ChangeLog MANIFEST README* ToDo
# Fix perms on directories (bug # 22446)
diff --git a/dev-lang/sather/sather-1.3.ebuild b/dev-lang/sather/sather-1.3.ebuild
index 739c81198de7..d43c293182f7 100644
--- a/dev-lang/sather/sather-1.3.ebuild
+++ b/dev-lang/sather/sather-1.3.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/sather/sather-1.3.ebuild,v 1.11 2003/06/14 03:23:19 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/sather/sather-1.3.ebuild,v 1.12 2003/08/05 16:21:25 vapier Exp $
-IUSE=""
+inherit eutils
MY_P="Sather-${PV}"
-DESCRIPTION="Sather is an object oriented language designed to be simple, efficient, safe, flexible and non-proprietary."
+DESCRIPTION="object oriented language designed to be simple, efficient, safe, flexible and non-proprietary"
+HOMEPAGE="http://www.cs.waikato.ac.nz/sather/ http://www.icsi.berkeley.edu/~sather/"
SRC_URI="http://www.cs.waikato.ac.nz/${PN}/release/downloads/${MY_P}.tar.gz
ftp://ftp.gnu.org/gnu/${PN}/Doc/${PN}-tutorial-000328.ps.gz
ftp://ftp.gnu.org/gnu/${PN}/Doc/${PN}-tutorial-000328.html.tar.gz
@@ -13,11 +14,10 @@ SRC_URI="http://www.cs.waikato.ac.nz/${PN}/release/downloads/${MY_P}.tar.gz
ftp://ftp.gnu.org/gnu/${PN}/Doc/${PN}-specification-000328.ps.gz
http://www.icsi.berkeley.edu/~${PN}/Publications/satish-thatte.ps.gz
http://www.icsi.berkeley.edu/~${PN}/Documentation/LanguageDescription/Descript.ps.gz"
-HOMEPAGE="http://www.cs.waikato.ac.nz/sather/ http://www.icsi.berkeley.edu/~sather/"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 sparc "
+SLOT="0"
+KEYWORDS="x86 sparc"
DEPEND=">=sys-devel/gcc-2.95.3-r5
>=dev-libs/boehm-gc-6.0"
@@ -51,7 +51,7 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
dodir /usr
cp -a ${WORKDIR}/${MY_P} ${D}/usr/sather
rm -rf ${D}/usr/${PN}/bin/sacomp.code