summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Rothe <corsair@gentoo.org>2005-05-09 16:00:09 +0000
committerMarkus Rothe <corsair@gentoo.org>2005-05-09 16:00:09 +0000
commitc546ec041da37e9f002285b23ba845750d19fec0 (patch)
tree3a28bd4bc77d0e84ec72023184e99676a6822e1b /dev-lang
parentversion bump. Fixes #91992 and #74579 (diff)
downloadgentoo-2-c546ec041da37e9f002285b23ba845750d19fec0.tar.gz
gentoo-2-c546ec041da37e9f002285b23ba845750d19fec0.tar.bz2
gentoo-2-c546ec041da37e9f002285b23ba845750d19fec0.zip
added patch and ~ppc64
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ChangeLog6
-rw-r--r--dev-lang/ghc/files/ghc-6.4-powerpc.patch26
-rw-r--r--dev-lang/ghc/ghc-6.4.ebuild12
3 files changed, 39 insertions, 5 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index e258af43322c..08279fd15362 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.57 2005/04/09 20:49:50 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.58 2005/05/09 16:00:09 corsair Exp $
+
+ 09 May 2005; Markus Rothe <corsair@gentoo.org>
+ +files/ghc-6.4-powerpc.patch, ghc-6.4.ebuild:
+ Added patch for ppc64 and added ~ppc64 to KEYWORDS
09 Apr 2005; Michael Hanselmann <hansmi@gentoo.org> ghc-6.2.2.ebuild:
Stable on ppc.
diff --git a/dev-lang/ghc/files/ghc-6.4-powerpc.patch b/dev-lang/ghc/files/ghc-6.4-powerpc.patch
new file mode 100644
index 000000000000..7fc7ccd5b1fb
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-6.4-powerpc.patch
@@ -0,0 +1,26 @@
+diff -ur ghc-6.4/distrib/configure-bin.ac ghc-6.4/distrib/configure-bin.ac
+--- ghc-6.4/distrib/configure-bin.ac 2005-03-10 09:10:09.000000000 -0500
++++ ghc-6.4/distrib/configure-bin.ac 2005-03-14 21:37:20.356380744 -0500
+@@ -78,6 +78,10 @@
+ TargetPlatform=rs6000-ibm-aix;;
+ powerpc-apple-darwin*)
+ TargetPlatform=powerpc-apple-darwin;;
++powerpc-*-linux*)
++ TargetPlatform=powerpc-unknown-linux;;
++powerpc64-*-linux*)
++ TargetPlatform=powerpc64-unknown-linux;;
+ sparc-sun-sunos4*)
+ TargetPlatform=sparc-sun-sunos4;;
+ sparc-sun-solaris2*)
+diff -ur ghc-6.4/ghc/includes/MachRegs.h ghc-6.4/ghc/includes/MachRegs.h
+--- ghc-6.4/ghc/includes/MachRegs.h 2005-01-28 07:55:51.000000000 -0500
++++ ghc-6.4/ghc/includes/MachRegs.h 2005-03-14 21:37:31.825368128 -0500
+@@ -457,7 +457,7 @@
+ #define REG_R7 r20
+ #define REG_R8 r21
+
+-#ifdef darwin_REGS
++#if darwin_REGS
+
+ #define REG_F1 f14
+ #define REG_F2 f15
diff --git a/dev-lang/ghc/ghc-6.4.ebuild b/dev-lang/ghc/ghc-6.4.ebuild
index 2073c081fcb1..041e85950fec 100644
--- a/dev-lang/ghc/ghc-6.4.ebuild
+++ b/dev-lang/ghc/ghc-6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.ebuild,v 1.4 2005/03/25 17:53:04 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.ebuild,v 1.5 2005/05/09 16:00:09 corsair Exp $
# Brief explanation of the bootstrap logic:
#
@@ -32,7 +32,7 @@ SRC_URI="http://www.haskell.org/ghc/dist/${EXTRA_SRC_URI}/${MY_P}-src.tar.bz2"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~x86 ~ppc -alpha ~amd64 -sparc"
+KEYWORDS="-alpha ~amd64 ~ppc ~ppc64 -sparc ~x86"
S="${WORKDIR}/${MY_P}"
@@ -94,6 +94,10 @@ pkg_setup() {
src_unpack() {
base_src_unpack
+ if use ppc64; then
+ epatch ${FILESDIR}/ghc-6.4-powerpc.patch
+ fi
+
# hardened-gcc needs to be disabled, because the
# mangler doesn't accept its output; yes, the 6.2 version
# should do ...
@@ -153,8 +157,8 @@ src_compile() {
echo "ArSupportsInput:=" >> mk/build.mk
# Required for some architectures, because they don't support ghc fully ...
- use ppc || use amd64 && echo "SplitObjs=NO" >> mk/build.mk
- use amd64 && echo "GhcWithInterpreter=NO" >> mk/build.mk
+ use ppc || use ppc64 || use amd64 && echo "SplitObjs=NO" >> mk/build.mk
+ use amd64 || use ppc64 && echo "GhcWithInterpreter=NO" >> mk/build.mk
# (--enable-threaded-rts is no longer needed)
econf ${myconf} || die "econf failed"