summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-11-08 22:43:08 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-11-08 22:43:08 +0000
commitbdcecb5d701fd7f8629481cdebbbf0ba9cab36fa (patch)
tree2e4f02d8d782185130f6e8caaf84e5337314f3c9 /dev-lang
parentadd ebuild for oslo-utils (diff)
downloadgentoo-2-bdcecb5d701fd7f8629481cdebbbf0ba9cab36fa.tar.gz
gentoo-2-bdcecb5d701fd7f8629481cdebbbf0ba9cab36fa.tar.bz2
gentoo-2-bdcecb5d701fd7f8629481cdebbbf0ba9cab36fa.zip
Remove unused eblits
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog7
-rw-r--r--dev-lang/perl/files/eblits/src_configure-v50160001.eblit152
-rw-r--r--dev-lang/perl/files/eblits/src_prepare-v50180002.eblit70
3 files changed, 6 insertions, 223 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index 6c38e8ff7d71..43dba18d4b6a 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/perl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.455 2014/11/08 14:42:52 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.456 2014/11/08 22:43:08 dilfridge Exp $
+
+ 08 Nov 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ -files/eblits/src_configure-v50160001.eblit,
+ -files/eblits/src_prepare-v50180002.eblit:
+ Remove unused eblits
08 Nov 2014; Andreas K. Huettel <dilfridge@gentoo.org>
-perl-5.20.0-r2.ebuild:
diff --git a/dev-lang/perl/files/eblits/src_configure-v50160001.eblit b/dev-lang/perl/files/eblits/src_configure-v50160001.eblit
deleted file mode 100644
index 1b506d3ab24f..000000000000
--- a/dev-lang/perl/files/eblits/src_configure-v50160001.eblit
+++ /dev/null
@@ -1,152 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/src_configure-v50160001.eblit,v 1.8 2014/03/30 10:14:33 zlogene Exp $
-
-myconf() {
- # the myconf array is declared in src_configure
- myconf=( "${myconf[@]}" "$@" )
-}
-
-eblit-perl-src_configure() {
- declare -a myconf
-
- export LC_ALL="C"
- [[ ${COLUMNS:-1} -ge 1 ]] || unset COLUMNS # bug #394091
-
- # some arches and -O do not mix :)
- use ppc && replace-flags -O? -O1
- # Perl has problems compiling with -Os in your flags with glibc
- use elibc_uclibc || replace-flags "-Os" "-O2"
- # This flag makes compiling crash in interesting ways
- filter-flags "-malign-double"
- # Fixes bug #97645
- use ppc && filter-flags "-mpowerpc-gpopt"
- # Fixes bug #143895 on gcc-4.1.1
- filter-flags "-fsched2-use-superblocks"
-
- use sparc && myconf -Ud_longdbl
-
- export BUILD_BZIP2=0
- export BZIP2_INCLUDE=${EPREFIX}/usr/include
- export BZIP2_LIB=${EPREFIX}/usr/$(get_libdir)
-
- export BUILD_ZLIB=False
- export ZLIB_INCLUDE=${EPREFIX}/usr/include
- export ZLIB_LIB=${EPREFIX}/usr/$(get_libdir)
-
- # allow either gdbm to provide ndbm (in <gdbm/ndbm.h>) or db1
-
- myndbm='U'
- mygdbm='U'
- mydb='U'
-
- if use gdbm ; then
- mygdbm='D'
- myndbm='D'
- fi
- if use berkdb ; then
- mydb='D'
- has_version '=sys-libs/db-1*' && myndbm='D'
- fi
-
- myconf "-${myndbm}i_ndbm" "-${mygdbm}i_gdbm" "-${mydb}i_db"
-
- if use alpha && [[ "$(tc-getCC)" = "ccc" ]] ; then
- ewarn "Perl will not be built with berkdb support, use gcc if you needed it..."
- myconf -Ui_db -Ui_ndbm
- fi
-
- use ithreads && myconf -Dusethreads
-
- if use debug ; then
- append-cflags "-g"
- myconf -DDEBUGGING
- elif [[ ${CFLAGS} == *-g* ]] ; then
- myconf -DDEBUGGING=-g
- else
- myconf -DDEBUGGING=none
- fi
-
- if [[ -n ${PERL_OLDVERSEN} ]] ; then
- local inclist=$(for v in ${PERL_OLDVERSEN}; do echo -n "${v}/${myarch}${mythreading} ${v} "; done )
- myconf -Dinc_version_list="${inclist}"
- fi
-
- [[ ${ELIBC} == "FreeBSD" ]] && myconf "-Dlibc=/usr/$(get_libdir)/libc.a"
-
- # Prefix: the host system needs not to follow Gentoo multilib stuff, and in
- # Prefix itself we don't do multilib either, so make sure perl can find
- # something compatible.
- if use prefix ; then
- local ldir
- local paths=""
- local scantool=""
- case ${CHOST} in
- *-aix*) paths="/lib /usr/lib" ;;
- *-darwin*) scantool=scanmacho ;;
- *) scantool=scanelf ;;
- esac
- if [[ -n ${scantool} ]]; then
- echo "int main() {}" > "${T}"/t.c
- # need to ensure dirs contain compatible libs,
- # bugs #358875, #400839, use scanelf for #425538
- $(tc-getCC) -o "${T}"/t "${T}"/t.c > /dev/null || die
- local mtype=$(${scantool} -BF "%M%D#f" "${T}"/t)
- einfo "searching libdirs for ${mtype}"
- for ldir in /lib/*-linux-gnu /usr/lib/*-linux-gnu /lib64 /lib/64 /usr/lib64 /usr/lib/64 /lib32 /usr/lib32 /lib /usr/lib ; do
- [[ -e ${ldir} ]] || continue
- if ${scantool} -BF "%M%D#f" ${ldir}/ | grep -q ${mtype} ; then
- paths="${paths} ${ldir}"
- einfo "found ${ldir}"
- fi
- done
- fi
- myconf "-Dlibpth=${EPREFIX}/$(get_libdir) ${EPREFIX}/usr/$(get_libdir) ${paths}"
- elif [[ $(get_libdir) != "lib" ]] ; then
- # We need to use " and not ', as the written config.sh use ' ...
- myconf "-Dlibpth=/usr/local/$(get_libdir) /$(get_libdir) /usr/$(get_libdir)"
- fi
-
- # don't try building ODBM, bug #354453
- myconf -Dnoextensions=ODBM_File
-
- sh Configure \
- -des \
- -Duseshrplib \
- -Darchname="${myarch}" \
- -Dcc="$(tc-getCC)" \
- -Doptimize="${CFLAGS}" \
- -Dldflags="${LDFLAGS}" \
- -Dprefix="${EPREFIX}"'/usr' \
- -Dinstallprefix="${EPREFIX}"'/usr' \
- -Dsiteprefix="${EPREFIX}"'/usr/local' \
- -Dvendorprefix="${EPREFIX}"'/usr' \
- -Dscriptdir="${EPREFIX}"'/usr/bin' \
- -Dprivlib="${EPREFIX}${PRIV_LIB}" \
- -Darchlib="${EPREFIX}${ARCH_LIB}" \
- -Dsitelib="${EPREFIX}${SITE_LIB}" \
- -Dsitearch="${EPREFIX}${SITE_ARCH}" \
- -Dvendorlib="${EPREFIX}${VENDOR_LIB}" \
- -Dvendorarch="${EPREFIX}${VENDOR_ARCH}" \
- -Dman1dir="${EPREFIX}"/usr/share/man/man1 \
- -Dman3dir="${EPREFIX}"/usr/share/man/man3 \
- -Dsiteman1dir="${EPREFIX}"/usr/local/man/man1 \
- -Dsiteman3dir="${EPREFIX}"/usr/local/man/man3 \
- -Dvendorman1dir="${EPREFIX}"/usr/share/man/man1 \
- -Dvendorman3dir="${EPREFIX}"/usr/share/man/man3 \
- -Dman1ext='1' \
- -Dman3ext='3pm' \
- -Dlibperl="${LIBPERL}" \
- -Dlocincpth="${EPREFIX}"'/usr/include ' \
- -Dglibpth="${EPREFIX}/$(get_libdir) ${EPREFIX}/usr/$(get_libdir)"' ' \
- -Duselargefiles \
- -Dd_semctl_semun \
- -Dcf_by='Gentoo' \
- -Dmyhostname='localhost' \
- -Dperladmin='root@localhost' \
- -Dinstallusrbinperl='n' \
- -Ud_csh \
- -Uusenm \
- -Dsh="${EPREFIX}"/bin/sh \
- "${myconf[@]}" || die "Unable to configure"
-}
diff --git a/dev-lang/perl/files/eblits/src_prepare-v50180002.eblit b/dev-lang/perl/files/eblits/src_prepare-v50180002.eblit
deleted file mode 100644
index 9f83cc563b2f..000000000000
--- a/dev-lang/perl/files/eblits/src_prepare-v50180002.eblit
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/src_prepare-v50180002.eblit,v 1.1 2014/04/30 14:47:53 civil Exp $
-
-src_prepare_update_patchlevel_h() {
- # Copied and modified from debian:
- # Copyright 2011 Niko Tyni
- # This program is free software; you can redistribute it and/or modify
- # it under the same terms as Perl itself.
- local patchdir="${WORKDIR}/patches"
- local prefix
-
- [[ -f ${patchdir}/series ]] || return 0
-
-while read patch
-do
- patchname=$(echo $patch | sed 's/\.diff$//')
- < $patchdir/$patch sed -e '/^Subject:/ { N; s/\n / / }' | sed -n -e '
-
- # massage the patch headers
- s|^Bug: .*https\?://rt\.perl\.org/.*id=\(.*\).*|[perl #\1]|; tprepend;
- s|^Bug: .*https\?://rt\.cpan\.org/.*id=\(.*\).*|[rt.cpan.org #\1]|; tprepend;
- s|^Bug-Gentoo: ||; tprepend;
- s/^\(Subject\|Description\): //; tappend;
- s|^Origin: .*http://perl5\.git\.perl\.org/perl\.git/commit\(diff\)\?/\(.......\).*|[\2]|; tprepend;
-
- # post-process at the end of input
- $ { x;
- # include the version number in the patchlevel.h description (if available)
- s/List packaged patches/&'" for ${PF}(#${PATCH_VER})"'/;
-
- # escape any backslashes and double quotes
- s|\\|\\\\|g; s|"|\\"|g;
-
- # add a prefix
- s|^|\t,"'"$prefix$patchname"' - |;
- # newlines away
- s/\n/ /g; s/ */ /g;
- # add a suffix
- s/ *$/"/; p
- };
- # stop all processing
- d;
- # label: append to the hold space
- :append H; d;
- # label: prepend to the hold space
- :prepend x; H; d;
- '
-done < "${WORKDIR}"/patches/series > "${S}"/patchlevel-gentoo.h
-}
-
-eblit-perl-src_prepare() {
- local patch
- EPATCH_OPTS+=" -p1"
- einfo "Applying patches from ${MY_P}-patches-${PATCH_VER} ..."
- while read patch ; do
- EPATCH_SINGLE_MSG=" ${patch} ..."
- epatch "${WORKDIR}"/patches/${patch}
- done < "${WORKDIR}"/patches/series
-
- src_prepare_update_patchlevel_h
-
- # pod/perltoc.pod fails
- # lib/ExtUtils/t/Embed.t fails
- if ! tc-is-static-only ; then
- ln -s ${LIBPERL} libperl$(get_libname ${SHORT_PV}) || die
- ln -s ${LIBPERL} libperl$(get_libname ) || die
- fi
-}
-