summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-13 22:21:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-13 22:21:33 +0000
commitbd29393476ed763cf43fc73ebc30ac8915894369 (patch)
tree76cb6792c120ae0499e9d97b5c59447614c3b1c2 /dev-lang
parentsasl fixes, closes bug 4958 (diff)
downloadgentoo-2-bd29393476ed763cf43fc73ebc30ac8915894369.tar.gz
gentoo-2-bd29393476ed763cf43fc73ebc30ac8915894369.tar.bz2
gentoo-2-bd29393476ed763cf43fc73ebc30ac8915894369.zip
symlink fix and repoman
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tk/ChangeLog12
-rw-r--r--dev-lang/tk/files/digest-tk-8.3.3-r11
-rw-r--r--dev-lang/tk/tk-8.3.3-r1.ebuild72
-rw-r--r--dev-lang/tk/tk-8.3.3.ebuild5
4 files changed, 87 insertions, 3 deletions
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index 823d0001abce..a0df2906e99a 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-lang/tk
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.2 2002/04/26 03:46:18 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.3 2002/07/13 22:21:33 seemant Exp $
+
+*tk-8.3.3-r1 (13 Jul 2002)
+
+ 13 Jul 2002; Seemant Kulleen <seemant@gentoo.org> tk-8.3.3-r1.ebuild
+ files/digest-tk-8.3.3-r1 :
+
+ Symlink for the .so was not being created. Thanks to
+ j_r_fonseca@yahoo.co.uk (Jose' Fonseca) in bug #4946 for the catch and
+ fix.
+
25 Apr 2002; Seemant Kulleen <seemant@gentoo.org> tk-8.3.3.ebuild :
diff --git a/dev-lang/tk/files/digest-tk-8.3.3-r1 b/dev-lang/tk/files/digest-tk-8.3.3-r1
new file mode 100644
index 000000000000..068113942ff6
--- /dev/null
+++ b/dev-lang/tk/files/digest-tk-8.3.3-r1
@@ -0,0 +1 @@
+MD5 72eb2d4a84f32fc1608e2333f92a2661 tk8.3.3.tar.gz 2537686
diff --git a/dev-lang/tk/tk-8.3.3-r1.ebuild b/dev-lang/tk/tk-8.3.3-r1.ebuild
new file mode 100644
index 000000000000..53cd0e7a489a
--- /dev/null
+++ b/dev-lang/tk/tk-8.3.3-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.3-r1.ebuild,v 1.1 2002/07/13 22:21:33 seemant Exp $
+
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_4/${PN}${PV}.tar.gz"
+
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+
+DESCRIPTION="Tk Widget Set"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ =dev-lang/tcl-${PV}*"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86"
+
+# hyper-optimizations untested...
+#
+src_compile() {
+
+ cd ${S}/unix
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-tcl=/usr/lib \
+ --enable-threads || die
+
+ emake CFLAGS="${CFLAGS}" || die
+
+}
+
+src_install() {
+
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tkConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TK_BUILD_LIB_SPEC='-L${S2}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TK_SRC_DIR='${S2}',TCL_SRC_DIR='/usr/lib/tk${V2}/include'," \
+ -e "s,^TK_BUILD_STUB_LIB_SPEC='-L${S2}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TK_BUILD_STUB_LIB_PATH='${S2}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ ${D}/usr/lib/tkConfig.sh > ${D}/usr/lib/tkConfig.sh.new
+ mv ${D}/usr/lib/tkConfig.sh.new ${D}/usr/lib/tkConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tk${V2}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tk${v1}/include/unix
+ dodir /usr/lib/tk${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tk${v1}/include/generic
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tk.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkDecls.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkPlatDecls.h
+
+ # install symlink for libraries
+ #dosym /usr/lib/libtk${v1}.a /usr/lib/libtk.a
+ dosym /usr/lib/libtk${v1}.so /usr/lib/libtk.so
+ dosym /usr/lib/libtkstub${v1}.a /usr/lib/libtkstub.a
+
+ ln -sf wish${v1} ${D}/usr/bin/wish
+
+ cd ${S}
+ dodoc README changes license.terms
+
+}
diff --git a/dev-lang/tk/tk-8.3.3.ebuild b/dev-lang/tk/tk-8.3.3.ebuild
index c84c9d3faf80..fc2e25fb84ae 100644
--- a/dev-lang/tk/tk-8.3.3.ebuild
+++ b/dev-lang/tk/tk-8.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.3.ebuild,v 1.4 2002/06/27 12:50:05 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.3.ebuild,v 1.5 2002/07/13 22:21:33 seemant Exp $
S=${WORKDIR}/${PN}${PV}
@@ -14,8 +14,9 @@ DEPEND="virtual/glibc
virtual/x11
=dev-lang/tcl-${PV}*"
-SLOT=""
+SLOT="0"
LICENSE="BSD"
+KEYWORDS="x86"
# hyper-optimizations untested...
#