summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-02-01 18:28:47 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-02-01 18:28:47 +0000
commitbd0e6c0356f63c423d48756a49b0976430bad0ee (patch)
treeb1895cec6c25045d797efd1a4e155ad307289bf4 /dev-lang
parent Add local libotf USE flag for app-editors/emacs-cvs. (diff)
downloadgentoo-2-bd0e6c0356f63c423d48756a49b0976430bad0ee.tar.gz
gentoo-2-bd0e6c0356f63c423d48756a49b0976430bad0ee.tar.bz2
gentoo-2-bd0e6c0356f63c423d48756a49b0976430bad0ee.zip
Version bump
(Portage version: 2.1.4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ifc/ChangeLog8
-rw-r--r--dev-lang/ifc/ifc-10.1.012.ebuild96
-rw-r--r--dev-lang/ifc/metadata.xml20
3 files changed, 113 insertions, 11 deletions
diff --git a/dev-lang/ifc/ChangeLog b/dev-lang/ifc/ChangeLog
index be8ad2248e96..81970b410e94 100644
--- a/dev-lang/ifc/ChangeLog
+++ b/dev-lang/ifc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ifc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.42 2008/01/08 15:37:49 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.43 2008/02/01 18:28:47 bicatali Exp $
+
+*ifc-10.1.012 (01 Feb 2008)
+
+ 01 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ +ifc-10.1.012.ebuild:
+ Version bump
08 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org>
ifc-10.0.026-r1.ebuild:
diff --git a/dev-lang/ifc/ifc-10.1.012.ebuild b/dev-lang/ifc/ifc-10.1.012.ebuild
new file mode 100644
index 000000000000..f6ca31168624
--- /dev/null
+++ b/dev-lang/ifc/ifc-10.1.012.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ifc-10.1.012.ebuild,v 1.1 2008/02/01 18:28:47 bicatali Exp $
+
+inherit rpm eutils
+
+PID=955
+PB=fc
+PEXEC="ifort"
+DESCRIPTION="Intel FORTRAN 77/95 optimized compiler for Linux"
+HOMEPAGE="http://www.intel.com/software/products/compilers/flin/"
+
+###
+# everything below common to ifc and icc
+# no eclass: very likely to change for next versions
+###
+PACKID="l_${PB}_p_${PV}"
+KEYWORDS="~amd64 ~ia64 ~x86"
+SRC_COM="http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKID}"
+SRC_URI="amd64? ( ${SRC_COM}_intel64.tar.gz )
+ ia64? ( ${SRC_COM}_ia64.tar.gz )
+ x86? ( ${SRC_COM}_ia32.tar.gz )"
+
+LICENSE="Intel-SDP"
+SLOT="0"
+
+RESTRICT="test strip mirror"
+IUSE=""
+DEPEND=""
+RDEPEND="virtual/libstdc++
+ amd64? ( app-emulation/emul-linux-x86-compat )"
+
+src_unpack() {
+ unpack ${A}
+ mv "${WORKDIR}"/l_* "${S}"
+ cd "${S}"
+
+ local ext=
+ use amd64 && ext=e
+ INSTALL_DIR=/opt/intel/${PB}${ext}/${PV}
+
+ # debugger installed with dev-lang/idb
+ rm -f data/intel*idb*.rpm
+
+ for x in data/intel*.rpm; do
+ einfo "Extracting $(basename ${x})..."
+ rpm_unpack "${S}/${x}" || die "rpm_unpack ${x} failed"
+ done
+
+ einfo "Fixing paths and tagging"
+ cd "${S}"/${INSTALL_DIR}/bin
+ sed -e "s|<INSTALLDIR>|${INSTALL_DIR}|g" \
+ -e 's|export -n IA32ROOT;||g' \
+ -i ${PEXEC} *sh \
+ || die "sed fixing shells and paths failed"
+
+ cd "${S}"/${INSTALL_DIR}/doc
+ sed -e "s|\<installpackageid\>|${PACKID}|g" \
+ -e "s|\<INSTALLTIMECOMBOPACKAGEID\>|${PACKID}|g" \
+ -i *support \
+ || die "sed support file failed"
+ chmod 644 *support
+}
+
+src_install() {
+ einfo "Copying files"
+ dodir ${INSTALL_DIR}
+ cp -pPR \
+ "${S}"/${INSTALL_DIR}/* \
+ "${D}"/${INSTALL_DIR}/ \
+ || die "Copying ${PN} failed"
+
+ local env_file=05${PN}
+ cat > ${env_file} <<-EOF
+ PATH=${INSTALL_DIR}/bin
+ ROOTPATH=${INSTALL_DIR}/bin
+ LDPATH=${INSTALL_DIR}/lib
+ MANPATH=${INSTALL_DIR}/man
+ EOF
+ doenvd ${env_file} || die "doenvd ${env_file} failed"
+}
+
+pkg_postinst () {
+ # remove left over from unpacking
+ rm -f "${ROOT}"/opt/intel/{intel_sdp_products.db,.*.log} \
+ || die "remove logs failed"
+
+ elog "Make sure you have recieved the a license for ${PN},"
+ elog "you cannot run ${PN} without a license file."
+ elog "To receive a non-commercial license, you need to register."
+ elog "Read the website for more information on this license:"
+ elog "${HOMEPAGE}"
+ elog "Then put the license file into ${ROOT}/opt/intel/licenses."
+ elog "\nTo use ${PN} issue first \n\tsource /etc/profile"
+ elog "Debugger is installed with dev-lang/idb"
+}
diff --git a/dev-lang/ifc/metadata.xml b/dev-lang/ifc/metadata.xml
index 6059ed65191f..1217c4f5b653 100644
--- a/dev-lang/ifc/metadata.xml
+++ b/dev-lang/ifc/metadata.xml
@@ -1,14 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
- The Intel® Fortran Compiler is a full featured FORTRAN 77/95 and
- substantial FORTRAN 2003 compiler for Intel based architectures. The
- compiler supports multi-threading with automatic processor dispatch,
- vectorization, auto-parallelization, OpenMP, data prefetching, loop
- unrolling. The package comes with extensive documentation.
- The product can be installed as a non-commercial as well. License,
- terms of qualifications can be found on the web site.
- </longdescription>
+<herd>sci@gentoo.org</herd>
+<longdescription lang="en">
+ The Intel® Fortran Compiler is a full featured FORTRAN 77/95 and
+ substantial FORTRAN 2003 compiler for Intel based architectures. The
+ compiler supports multi-threading with automatic processor dispatch,
+ vectorization, auto-parallelization, OpenMP, data prefetching, loop
+ unrolling. The package comes with extensive documentation.
+ The product can be installed as a non-commercial as well. License,
+ terms of qualifications can be found on the web site.
+</longdescription>
</pkgmetadata>