summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-12-24 20:08:28 +0000
committerAnant Narayanan <anant@gentoo.org>2007-12-24 20:08:28 +0000
commitbaf3eac2ac34e7943e1797ad89aaa5fb249fe7e7 (patch)
treef66853a3695c2c16d8f57aa287fb3482552f3dff /dev-lang
parentAdded ~ppc wrt bug 166789 (diff)
downloadgentoo-2-baf3eac2ac34e7943e1797ad89aaa5fb249fe7e7.tar.gz
gentoo-2-baf3eac2ac34e7943e1797ad89aaa5fb249fe7e7.tar.bz2
gentoo-2-baf3eac2ac34e7943e1797ad89aaa5fb249fe7e7.zip
Bump to version 2
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/dmd-bin/ChangeLog8
-rw-r--r--dev-lang/dmd-bin/dmd-bin-1.023.ebuild110
-rw-r--r--dev-lang/dmd-bin/dmd-bin-2.008.ebuild (renamed from dev-lang/dmd-bin/dmd-bin-1.022.ebuild)58
-rw-r--r--dev-lang/dmd-bin/files/digest-dmd-bin-1.0223
-rw-r--r--dev-lang/dmd-bin/files/digest-dmd-bin-1.0233
-rw-r--r--dev-lang/dmd-bin/files/digest-dmd-bin-2.0083
6 files changed, 37 insertions, 148 deletions
diff --git a/dev-lang/dmd-bin/ChangeLog b/dev-lang/dmd-bin/ChangeLog
index fdc0f3f5c06e..47f9121e9da7 100644
--- a/dev-lang/dmd-bin/ChangeLog
+++ b/dev-lang/dmd-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/dmd-bin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/ChangeLog,v 1.12 2007/11/03 21:48:10 anant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/ChangeLog,v 1.13 2007/12/24 20:08:28 anant Exp $
+
+*dmd-bin-2.008 (24 Dec 2007)
+
+ 24 Dec 2007; <anant@gentoo.org> -dmd-bin-1.022.ebuild,
+ -dmd-bin-1.023.ebuild, +dmd-bin-2.008.ebuild:
+ Bump to version 2, still keeping 1.016 from (yet to be stabled) 1.x series
*dmd-bin-1.023 (03 Nov 2007)
diff --git a/dev-lang/dmd-bin/dmd-bin-1.023.ebuild b/dev-lang/dmd-bin/dmd-bin-1.023.ebuild
deleted file mode 100644
index 45bd93c85651..000000000000
--- a/dev-lang/dmd-bin/dmd-bin-1.023.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/dmd-bin-1.023.ebuild,v 1.1 2007/11/03 21:48:10 anant Exp $
-
-inherit eutils
-
-MY_P=${P/-bin/}
-MY_P=${MY_P/-/.}
-
-DESCRIPTION="Digital Mars D Compiler"
-HOMEPAGE="http://www.digitalmars.com/d/"
-SRC_URI="http://ftp.digitalmars.com/${MY_P}.zip"
-
-LICENSE="DMD"
-RESTRICT="mirror strip"
-SLOT="0"
-KEYWORDS="~x86"
-
-LOC="/opt/dmd"
-S="${WORKDIR}"
-
-DEPEND="sys-apps/findutils"
-RDEPEND="amd64? ( app-emulation/emul-linux-x86-compat )
- x86? ( sys-libs/libstdc++-v3 )"
-
-src_unpack() {
- unpack "${A}"
-
- # Remove unneccessary files
- mv "${S}/dmd/lib/libphobos.a" "${S}/dmd"
- rm -r "${S}/dmd/lib"
- mkdir "${S}/dmd/lib"
- mv "${S}/dmd/libphobos.a" "${S}/dmd/lib"
-
- rm -r "${S}/dm"
- rm "${S}/dmd/bin/*.dll" "${S}/dmd/bin/*.exe" "${S}/dmd/bin/readme.txt"
- rm "${S}/dmd/bin/sc.ini" "${S}/dmd/bin/windbg.hlp"
-
- # Cleanup line endings
- cd "${S}/dmd"
- edos2unix `find . -name '*.c' -type f`
- edos2unix `find . -name '*.d' -type f`
- edos2unix `find . -name '*.ddoc' -type f`
- edos2unix `find . -name '*.h' -type f`
- edos2unix `find . -name '*.mak' -type f`
- edos2unix `find . -name '*.txt' -type f`
- edos2unix `find samples -name '*.html' -type f`
-
- # Fix permissions
- fperms guo=r `find . -type f`
- fperms guo=rx `find . -type d`
- fperms guo=rx bin/dmd bin/dumpobj bin/obj2asm bin/rdmd
-}
-
-src_compile() {
- cd "${S}/dmd/src/phobos"
- sed -i -e "s:DMD=.*:DMD=${S}/dmd/bin/dmd -I${S}/dmd/src/phobos -L${S}/dmd/lib/libphobos.a:" linux.mak internal/gc/linux.mak
- # Can't use emake, customized build system
- edos2unix linux.mak internal/gc/linux.mak
- make -f linux.mak
- cp libphobos.a "${S}/dmd/lib"
-
- # Clean up
- make -f linux.mak clean
- rm internal/gc/*.o
-}
-
-src_install() {
- cd "${S}/dmd"
-
- # Broken dmd.conf
- # http://d.puremagic.com/issues/show_bug.cgi?id=278
- mv bin/dmd bin/dmd.bin
- cat <<END > "bin/dmd"
-#!/bin/sh
-${LOC}/bin/dmd.bin -I${LOC}/src/phobos -L${LOC}/lib/libphobos.a \$*
-END
- fperms guo=rx bin/dmd bin/dmd.bin
-
- # Man pages
- doman man/man1/dmd.1
- doman man/man1/dumpobj.1
- doman man/man1/obj2asm.1
- rm -r man
-
- # Install
- mkdir "${D}/opt"
- mv "${S}/dmd" "${D}/opt/dmd"
-
- # Set PATH
- doenvd "${FILESDIR}/25dmd"
-}
-
-pkg_postinst () {
- ewarn "The DMD Configuration file has been disabled, "
- ewarn "and will be re-enabled when: "
- ewarn " "
- ewarn "http://d.puremagic.com/issues/show_bug.cgi?id=278"
- ewarn " "
- ewarn "has been fixed. Meanwhile, please supply all your"
- ewarn "configuration options in the /opt/dmd/bin/dmd "
- ewarn "shell script. "
- ewarn " "
- ewarn "You may need to run: "
- ewarn " "
- ewarn "env-update && source /etc/profile "
- ewarn " "
- ewarn "to be able to use the compiler immediately. "
- ewarn " "
-}
diff --git a/dev-lang/dmd-bin/dmd-bin-1.022.ebuild b/dev-lang/dmd-bin/dmd-bin-2.008.ebuild
index 6bf74d34c410..7f7651c153e8 100644
--- a/dev-lang/dmd-bin/dmd-bin-1.022.ebuild
+++ b/dev-lang/dmd-bin/dmd-bin-2.008.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/dmd-bin-1.022.ebuild,v 1.2 2007/10/08 06:01:46 anant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/dmd-bin-2.008.ebuild,v 1.1 2007/12/24 20:08:28 anant Exp $
inherit eutils
@@ -27,14 +27,9 @@ src_unpack() {
unpack "${A}"
# Remove unneccessary files
- mv "${S}/dmd/lib/libphobos.a" "${S}/dmd"
rm -r "${S}/dmd/lib"
- mkdir "${S}/dmd/lib"
- mv "${S}/dmd/libphobos.a" "${S}/dmd/lib"
-
rm -r "${S}/dm"
- rm "${S}/dmd/bin/*.dll" "${S}/dmd/bin/*.exe" "${S}/dmd/bin/readme.txt"
- rm "${S}/dmd/bin/sc.ini" "${S}/dmd/bin/windbg.hlp"
+ rm dmd/license.txt dmd/readme
# Cleanup line endings
cd "${S}/dmd"
@@ -45,37 +40,42 @@ src_unpack() {
edos2unix `find . -name '*.mak' -type f`
edos2unix `find . -name '*.txt' -type f`
edos2unix `find samples -name '*.html' -type f`
+ edos2unix src/phobos/linux.mak src/phobos/internal/gc/linux.mak
- # Fix permissions
+ # Fix permissions and clean up
fperms guo=r `find . -type f`
fperms guo=rx `find . -type d`
fperms guo=rx bin/dmd bin/dumpobj bin/obj2asm bin/rdmd
+ mv bin/{dmd,dumpobj,obj2asm,rdmd} .
+ rm -r bin/
+ mkdir bin
+ mkdir lib
+ mv ./{dmd,dumpobj,obj2asm,rdmd} bin/
}
src_compile() {
+ # Don't use teh bundled library since on gentoo we do teh compile
cd "${S}/dmd/src/phobos"
- sed -i -e "s:DMD=.*:DMD=${S}/dmd/bin/dmd -I${S}/dmd/src/phobos -L${S}/dmd/lib/libphobos.a:" linux.mak internal/gc/linux.mak
+ sed -i -e "s:DMD=.*:DMD=${S}/dmd/bin/dmd:" linux.mak internal/gc/linux.mak
# Can't use emake, customized build system
- edos2unix linux.mak internal/gc/linux.mak
make -f linux.mak
- cp libphobos.a "${S}/dmd/lib"
+ cp obj/release/libphobos2.a "${S}/dmd/lib"
# Clean up
make -f linux.mak clean
- rm internal/gc/*.o
}
src_install() {
cd "${S}/dmd"
- # Broken dmd.conf
- # http://d.puremagic.com/issues/show_bug.cgi?id=278
- mv bin/dmd bin/dmd.bin
- cat <<END > "bin/dmd"
-#!/bin/sh
-${LOC}/bin/dmd.bin -I${LOC}/src/phobos -L${LOC}/lib/libphobos.a \$*
+ # Setup dmd.conf
+ cat <<END > "bin/dmd.conf"
+[Environment]
+DFLAGS=-I/opt/dmd/src/phobos -L-L/opt/dmd/lib
END
- fperms guo=rx bin/dmd bin/dmd.bin
+ insinto /etc
+ doins bin/dmd.conf
+ rm bin/dmd.conf
# Man pages
doman man/man1/dmd.1
@@ -83,6 +83,10 @@ END
doman man/man1/obj2asm.1
rm -r man
+ # Documentation
+ dohtml html/d/* html/d/phobos/*
+ rm -r html
+
# Install
mkdir "${D}/opt"
mv "${S}/dmd" "${D}/opt/dmd"
@@ -92,19 +96,11 @@ END
}
pkg_postinst () {
- ewarn "The DMD Configuration file has been disabled, "
- ewarn "and will be re-enabled when: "
- ewarn " "
- ewarn "http://d.puremagic.com/issues/show_bug.cgi?id=278"
- ewarn " "
- ewarn "has been fixed. Meanwhile, please supply all your"
- ewarn "configuration options in the /opt/dmd/bin/dmd "
- ewarn "shell script. "
- ewarn " "
ewarn "You may need to run: "
- ewarn " "
ewarn "env-update && source /etc/profile "
- ewarn " "
ewarn "to be able to use the compiler immediately. "
- ewarn " "
+ einfo " "
+ einfo "The bundled sources and samples may be found in "
+ einfo "/opt/dmd/src and /opt/dmd/samples respectively. "
+ einfo " "
}
diff --git a/dev-lang/dmd-bin/files/digest-dmd-bin-1.022 b/dev-lang/dmd-bin/files/digest-dmd-bin-1.022
deleted file mode 100644
index 03ab329163c4..000000000000
--- a/dev-lang/dmd-bin/files/digest-dmd-bin-1.022
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 645b4527ae4137d0e1dc639d2cf70974 dmd.1.022.zip 4839507
-RMD160 7678a74b0f4485820f46c89cb4d231a2f40c81cb dmd.1.022.zip 4839507
-SHA256 711090403acaeaf96b392455808568db389c521431634cfc8ae53ae4fb31249e dmd.1.022.zip 4839507
diff --git a/dev-lang/dmd-bin/files/digest-dmd-bin-1.023 b/dev-lang/dmd-bin/files/digest-dmd-bin-1.023
deleted file mode 100644
index 6f8f8991bfda..000000000000
--- a/dev-lang/dmd-bin/files/digest-dmd-bin-1.023
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e641101a0938b993f853db7b70a6f7ca dmd.1.023.zip 4845839
-RMD160 8582088acee96596724b15a4427d452a4a49b7f1 dmd.1.023.zip 4845839
-SHA256 b6cc3900a95febaf3a2326b16ae8684c03c03a898e1a1c07d8dc07319b3f69d9 dmd.1.023.zip 4845839
diff --git a/dev-lang/dmd-bin/files/digest-dmd-bin-2.008 b/dev-lang/dmd-bin/files/digest-dmd-bin-2.008
new file mode 100644
index 000000000000..c2e63fcae482
--- /dev/null
+++ b/dev-lang/dmd-bin/files/digest-dmd-bin-2.008
@@ -0,0 +1,3 @@
+MD5 0c5fd34e7520ddbfadb71249829f2dd0 dmd.2.008.zip 5325757
+RMD160 13e6ba91db036210d02144d0fc37c6872b8aa98c dmd.2.008.zip 5325757
+SHA256 8d8a0b4399ebf1ecc7e88ee68852db5e944ec7b88607d7c02a150bfcdfaf2b64 dmd.2.008.zip 5325757