summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-02-18 21:47:23 +0000
committerMike Gilbert <floppym@gentoo.org>2013-02-18 21:47:23 +0000
commitba5d1d3ceb336f6804fe4098834d4eab13349754 (patch)
tree56729058b5047bc6fcdf473f98df4722926e99a9 /dev-lang
parentMask video_cards_* that are used by media-libs/mesa (diff)
downloadgentoo-2-ba5d1d3ceb336f6804fe4098834d4eab13349754.tar.gz
gentoo-2-ba5d1d3ceb336f6804fe4098834d4eab13349754.tar.bz2
gentoo-2-ba5d1d3ceb336f6804fe4098834d4eab13349754.zip
Also apply build changes to 3.15.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/v8/ChangeLog5
-rw-r--r--dev-lang/v8/v8-3.15.11.15.ebuild28
2 files changed, 25 insertions, 8 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index e2f41a858895..164ed399db81 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.279 2013/02/18 21:36:45 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.280 2013/02/18 21:47:23 floppym Exp $
+
+ 18 Feb 2013; Mike Gilbert <floppym@gentoo.org> v8-3.15.11.15.ebuild:
+ Also apply build changes to 3.15.
*v8-3.16.14.1 (18 Feb 2013)
diff --git a/dev-lang/v8/v8-3.15.11.15.ebuild b/dev-lang/v8/v8-3.15.11.15.ebuild
index b1da1d053c00..e154717b0052 100644
--- a/dev-lang/v8/v8-3.15.11.15.ebuild
+++ b/dev-lang/v8/v8-3.15.11.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.15.11.15.ebuild,v 1.1 2013/02/06 02:30:42 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.15.11.15.ebuild,v 1.2 2013/02/18 21:47:23 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
@@ -23,7 +23,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-vfp2-r0.patch
}
-src_compile() {
+src_configure() {
tc-export AR CC CXX RANLIB
export LINK=${CXX}
@@ -46,20 +46,34 @@ src_compile() {
esac
mytarget=${myarch}.release
- local snapshot=on
- host-is-pax && snapshot=off
-
# TODO: Add console=readline option once implemented upstream
# http://code.google.com/p/v8/issues/detail?id=1781
+ # Generate the real Makefile.
emake V=1 \
library=shared \
werror=no \
soname_version=${soname_version} \
- snapshot=${snapshot} \
+ snapshot=on \
hardfp=${hardfp} \
- ${mytarget} || die
+ out/Makefile.${myarch} || die
+}
+src_compile() {
+ local makeargs=(
+ -C out
+ -f Makefile.${myarch}
+ V=1
+ BUILDTYPE=Release
+ builddir="${S}/out/${mytarget}"
+ )
+
+ # Build mksnapshot so we can pax-mark it.
+ emake "${makeargs[@]}" mksnapshot || die
+ pax-mark m out/${mytarget}/mksnapshot
+
+ # Build everything else.
+ emake "${makeargs[@]}" || die
pax-mark m out/${mytarget}/{cctest,d8,shell} || die
}