summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-10-22 17:16:53 +0000
committerJeroen Roovers <jer@gentoo.org>2011-10-22 17:16:53 +0000
commit96ca57fd3b57045738195345c9f727786e24ed40 (patch)
tree4f187ac881611acf175f1bcac01d5666e33abaa5 /dev-lang
parentBump for #386693 (diff)
downloadgentoo-2-96ca57fd3b57045738195345c9f727786e24ed40.tar.gz
gentoo-2-96ca57fd3b57045738195345c9f727786e24ed40.tar.bz2
gentoo-2-96ca57fd3b57045738195345c9f727786e24ed40.zip
Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug #332593).
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ruby/ChangeLog6
-rw-r--r--dev-lang/ruby/ruby-1.9.3_rc1.ebuild7
2 files changed, 10 insertions, 3 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index a2cec4b803f3..c3f6ae069016 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ruby
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.513 2011/10/22 16:53:31 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.514 2011/10/22 17:16:53 jer Exp $
+
+ 22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.3_rc1.ebuild:
+ Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
+ #332593).
22 Oct 2011; Jeroen Roovers <jer@gentoo.org> ruby-1.9.2_p290.ebuild:
Add workaround for target_arch issue (bug #342819). Marked ~hppa (bug
diff --git a/dev-lang/ruby/ruby-1.9.3_rc1.ebuild b/dev-lang/ruby/ruby-1.9.3_rc1.ebuild
index 00698093017a..7bfbdc70c2ab 100644
--- a/dev-lang/ruby/ruby-1.9.3_rc1.ebuild
+++ b/dev-lang/ruby/ruby-1.9.3_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.9.3_rc1.ebuild,v 1.1 2011/10/22 10:13:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.9.3_rc1.ebuild,v 1.2 2011/10/22 17:16:53 jer Exp $
EAPI=2
@@ -35,7 +35,7 @@ SRC_URI="mirror://ruby/1.9/${MY_P}.tar.bz2
http://dev.gentoo.org/~flameeyes/ruby-team/${PN}-patches-${PATCHSET}.tar.bz2"
LICENSE="|| ( Ruby BSD-2 )"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="berkdb debug doc examples gdbm ipv6 +rdoc rubytests socks5 ssl tk xemacs ncurses +readline +yaml" #libedit
# libedit support is removed everywhere because of this upstream bug:
@@ -121,6 +121,9 @@ src_configure() {
# fi
myconf="${myconf} $(use_with readline)"
+ # Set a faux target (bug #342819)
+ use hppa && myconf="${myconf} --target=parisc"
+
econf \
--program-suffix=${MY_SUFFIX} \
--with-soname=ruby${MY_SUFFIX} \