summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2010-07-09 10:38:01 +0000
committerKeri Harris <keri@gentoo.org>2010-07-09 10:38:01 +0000
commit862a6f37495de681fc1209321054d32dbf02d393 (patch)
treec0970cb57e44283ee0e72cbd9ab9a189e7b860e5 /dev-lang
parentWhitespace a bit. (diff)
downloadgentoo-2-862a6f37495de681fc1209321054d32dbf02d393.tar.gz
gentoo-2-862a6f37495de681fc1209321054d32dbf02d393.tar.bz2
gentoo-2-862a6f37495de681fc1209321054d32dbf02d393.zip
Parallelize compile; filter install files; install examples to /usr/share/doc; use correct libdir
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/xsb/ChangeLog6
-rw-r--r--dev-lang/xsb/xsb-3.2.ebuild24
2 files changed, 23 insertions, 7 deletions
diff --git a/dev-lang/xsb/ChangeLog b/dev-lang/xsb/ChangeLog
index 41212f25b451..1c32aa4be628 100644
--- a/dev-lang/xsb/ChangeLog
+++ b/dev-lang/xsb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/xsb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/xsb/ChangeLog,v 1.20 2010/07/08 08:38:56 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/xsb/ChangeLog,v 1.21 2010/07/09 10:38:01 keri Exp $
+
+ 09 Jul 2010; <keri@gentoo.org> xsb-3.2.ebuild:
+ Parallelize compile; filter install files; install examples to
+ /usr/share/doc; use correct libdir
08 Jul 2010; <keri@gentoo.org> xsb-3.2.ebuild:
Filter temporary c -> XSB files during install
diff --git a/dev-lang/xsb/xsb-3.2.ebuild b/dev-lang/xsb/xsb-3.2.ebuild
index c1103c8c30fc..b943c12f0277 100644
--- a/dev-lang/xsb/xsb-3.2.ebuild
+++ b/dev-lang/xsb/xsb-3.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/xsb/xsb-3.2.ebuild,v 1.3 2010/07/08 08:38:56 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/xsb/xsb-3.2.ebuild,v 1.4 2010/07/09 10:38:01 keri Exp $
MY_P="XSB"
-PATCHSET_VER="1"
+PATCHSET_VER="2"
inherit eutils autotools java-pkg-opt-2
@@ -16,7 +16,7 @@ SRC_URI="http://xsb.sourceforge.net/downloads/${MY_P}.tar.gz
LICENSE="GPL-2 LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug iodbc java libwww mysql odbc perl threads xml"
+IUSE="debug examples iodbc java libwww mysql odbc perl threads xml"
RDEPEND="iodbc? ( dev-db/libiodbc )
java? ( >=virtual/jdk-1.4 )
@@ -57,7 +57,7 @@ src_compile() {
$(use_enable debug debug-verbose) \
$(use_enable debug profile) \
|| die "econf failed"
- emake -j1 || die "emake failed"
+ emake || die "emake failed"
if use libwww ; then
cd "${S}"/packages/libwww
@@ -79,6 +79,9 @@ src_compile() {
econf || die "econf xpath package failed"
fi
+ # All XSB Packages are compiled using a single Prolog engine.
+ # Consequently they must all be compiled using a single make job.
+
cd "${S}"/packages
rm -rf *.xwam
emake -j1 || die "emake packages failed"
@@ -108,10 +111,11 @@ src_install() {
cd "${S}"/build
make DESTDIR="${D}" install || die "make install failed"
- dosym /usr/lib/xsb/bin/xsb /usr/bin/xsb
+ local XSB_INSTALL_DIR=/usr/$(get_libdir)/xsb-${PV}
+ dosym ${XSB_INSTALL_DIR}/bin/xsb /usr/bin/xsb
cd "${S}"/packages
- local PACKAGES=/usr/lib/xsb/packages
+ local PACKAGES=${XSB_INSTALL_DIR}/packages
insinto ${PACKAGES}
doins *.xwam
@@ -189,6 +193,14 @@ src_install() {
doins xpath/cc/*.H
fi
+ if use examples ; then
+ cd "${S}"/build
+ make \
+ DESTDIR="${D}" \
+ install_examples="${D}"/usr/share/doc/${PF}/examples \
+ install_examples || die "make install_examples failed"
+ fi
+
cd "${S}"
dodoc FAQ README
}