summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-07-31 07:46:21 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-07-31 07:46:21 +0000
commit23f80696326110c19b4898a81c1f8e7e52f759a6 (patch)
treed349e23e74d3fc77bbed639770f5a83138d4cb56 /dev-lang
parentBlock texlive-latexextra-2010 too, they collide, bug #377019 by William Throwe (diff)
downloadgentoo-2-23f80696326110c19b4898a81c1f8e7e52f759a6.tar.gz
gentoo-2-23f80696326110c19b4898a81c1f8e7e52f759a6.tar.bz2
gentoo-2-23f80696326110c19b4898a81c1f8e7e52f759a6.zip
Make search for linker more resilient. Fixes bug 377111. Thanks to Diego Elio Pettenò <flameeyes@gentoo.org>
(Portage version: 2.2.0_alpha49/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/path64/ChangeLog7
-rw-r--r--dev-lang/path64/path64-1.0.0_pre20110729.ebuild5
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-lang/path64/ChangeLog b/dev-lang/path64/ChangeLog
index 314597559534..30b1e77d4a7e 100644
--- a/dev-lang/path64/ChangeLog
+++ b/dev-lang/path64/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/path64
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/path64/ChangeLog,v 1.1 2011/07/29 17:40:49 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/path64/ChangeLog,v 1.2 2011/07/31 07:46:21 xarthisius Exp $
+
+ 31 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org>
+ path64-1.0.0_pre20110729.ebuild:
+ Make search for linker more resilient. Fixes bug 377111. Thanks to Diego Elio
+ Pettenò <flameeyes@gentoo.org>
*path64-1.0.0_pre20110729 (29 Jul 2011)
diff --git a/dev-lang/path64/path64-1.0.0_pre20110729.ebuild b/dev-lang/path64/path64-1.0.0_pre20110729.ebuild
index 86ac6d0813c2..e2d149d889a5 100644
--- a/dev-lang/path64/path64-1.0.0_pre20110729.ebuild
+++ b/dev-lang/path64/path64-1.0.0_pre20110729.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/path64/path64-1.0.0_pre20110729.ebuild,v 1.1 2011/07/29 17:40:49 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/path64/path64-1.0.0_pre20110729.ebuild,v 1.2 2011/07/31 07:46:21 xarthisius Exp $
EAPI=4
CMAKE_VERBOSE=1
@@ -48,7 +48,8 @@ src_prepare() {
}
src_configure() {
- local linker=$($(tc-getCC) --help -v 2>&1 >/dev/null | grep '\-dynamic\-linker' | cut -f7 -d' ')
+ local linker=$($(tc-getCC) --help -v 2>&1 >/dev/null | \
+ sed -n -e '/dynamic-linker/s:.* -dynamic-linker \([^ ]\+\) .*:\1:p')
local libgcc=$($(tc-getCC) -print-libgcc-file-name)
local crt=$($(tc-getCC) -print-file-name=crt1.o)
use custom-cflags && flags=(