summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2010-01-04 04:55:54 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2010-01-04 04:55:54 +0000
commit15be44feca47fbe75fd096391eb2a793f78fac15 (patch)
tree95f5f7aa686c2e1e7989718fbef363ef055a28a5 /dev-lang
parentVersion bump, tests are shipped but fail, waiting on upstream. (diff)
downloadgentoo-2-15be44feca47fbe75fd096391eb2a793f78fac15.tar.gz
gentoo-2-15be44feca47fbe75fd096391eb2a793f78fac15.tar.bz2
gentoo-2-15be44feca47fbe75fd096391eb2a793f78fac15.zip
Version bump. Fixing bugs #252253 #251007
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gnu-smalltalk/ChangeLog9
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-3.1.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/dev-lang/gnu-smalltalk/ChangeLog b/dev-lang/gnu-smalltalk/ChangeLog
index 6a33e8dbd5d7..9d1b0d149b67 100644
--- a/dev-lang/gnu-smalltalk/ChangeLog
+++ b/dev-lang/gnu-smalltalk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/gnu-smalltalk
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.39 2009/06/01 21:34:04 araujo Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.40 2010/01/04 04:55:54 araujo Exp $
+
+*gnu-smalltalk-3.1 (04 Jan 2010)
+
+ 04 Jan 2010; Luis F. Araujo <araujo@gentoo.org> +gnu-smalltalk-3.1.ebuild:
+ Version bump. Fixing bugs #252253 , #251007
*gnu-smalltalk-3.0.5 (01 Jun 2009)
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-3.1.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.1.ebuild
new file mode 100644
index 000000000000..76b73e204f3a
--- /dev/null
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-3.1.ebuild,v 1.1 2010/01/04 04:55:54 araujo Exp $
+
+inherit elisp-common flag-o-matic eutils
+
+DESCRIPTION="GNU Smalltalk"
+HOMEPAGE="http://smalltalk.gnu.org"
+SRC_URI="http://ftp.gnu.org/gnu/smalltalk/smalltalk-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tk readline emacs gtk gmp"
+
+DEPEND="sys-libs/gdbm
+ sys-apps/debianutils
+ dev-libs/libsigsegv
+ virtual/libffi
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )
+ tk? ( dev-lang/tk )
+ gtk? ( =x11-libs/gtk+-2* )
+ gmp? ( dev-libs/gmp )"
+RDEPEND=""
+
+S="${WORKDIR}/smalltalk-${PV}"
+
+SITEFILE=50gnu-smalltalk-gentoo.el
+
+src_compile() {
+ replace-flags '-O3' '-O2'
+ ./configure --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --with-system-libsigsegv \
+ --with-system-libffi \
+ `use_with emacs emacs` \
+ `use_with readline readline` \
+ `use_with gmp gmp` \
+ `use_with tk tcl /usr/$(get_libdir)` \
+ `use_with tk tk /usr/$(get_libdir)` \
+ `use_enable gtk gtk` \
+ || die "configure failed"
+ emake || die "emake failed"
+ use emacs && elisp-compile *.el
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS COPYING* ChangeLog NEWS README THANKS TODO
+ if use emacs; then
+ elisp-install "${PN}" *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ fperms 0444 /usr/share/smalltalk/packages.xml
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}