summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2010-05-06 19:50:01 +0000
committerAlex Legler <a3li@gentoo.org>2010-05-06 19:50:01 +0000
commit045ed84da9d025c23ca55ef3357e8419d90d120f (patch)
tree02e0f6716cc0379a1a1ee6a51eaba412983e0a64 /dev-lang
parentRemove old version. Cleanup in files/ (diff)
downloadgentoo-2-045ed84da9d025c23ca55ef3357e8419d90d120f.tar.gz
gentoo-2-045ed84da9d025c23ca55ef3357e8419d90d120f.tar.bz2
gentoo-2-045ed84da9d025c23ca55ef3357e8419d90d120f.zip
Use $PVR instead of $PV in patchset names
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ruby/ChangeLog6
-rw-r--r--dev-lang/ruby/ruby-1.8.6_p388.ebuild6
-rw-r--r--dev-lang/ruby/ruby-1.8.7_p249.ebuild6
3 files changed, 11 insertions, 7 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index c3467aa7189d..7f9bec5ffaa5 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ruby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.446 2010/05/06 19:41:00 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.447 2010/05/06 19:50:01 a3li Exp $
+
+ 06 May 2010; Alex Legler <a3li@gentoo.org> ruby-1.8.6_p388.ebuild,
+ ruby-1.8.7_p249.ebuild:
+ Use $PVR instead of $PV in patchset names
06 May 2010; Alex Legler <a3li@gentoo.org>
-files/ruby-1.8.6-memory-leak.diff,
diff --git a/dev-lang/ruby/ruby-1.8.6_p388.ebuild b/dev-lang/ruby/ruby-1.8.6_p388.ebuild
index eb7b469afc3d..9015962d669a 100644
--- a/dev-lang/ruby/ruby-1.8.6_p388.ebuild
+++ b/dev-lang/ruby/ruby-1.8.6_p388.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p388.ebuild,v 1.6 2010/01/13 19:35:57 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p388.ebuild,v 1.7 2010/05/06 19:50:01 a3li Exp $
EAPI=1
inherit autotools eutils flag-o-matic multilib versionator
@@ -14,7 +14,7 @@ MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="http://www.ruby-lang.org/"
SRC_URI="mirror://ruby/${SLOT}/${MY_P}.tar.bz2
-http://dev.a3li.li/gentoo/distfiles/${PN}-patches-${PV}.tar.bz2"
+http://dev.a3li.li/gentoo/distfiles/${PN}-patches-${PVR}.tar.bz2"
LICENSE="|| ( Ruby GPL-2 )"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
@@ -59,7 +59,7 @@ src_unpack() {
cd "${S}"
EPATCH_FORCE="yes" EPATCH_SUFFIX="patch" \
- epatch "${WORKDIR}/patches-${PV}"
+ epatch "${WORKDIR}/patches-${PVR}"
# Fix a hardcoded lib path in configure script
sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
diff --git a/dev-lang/ruby/ruby-1.8.7_p249.ebuild b/dev-lang/ruby/ruby-1.8.7_p249.ebuild
index 433ed97a4d5e..4d488ae4f091 100644
--- a/dev-lang/ruby/ruby-1.8.7_p249.ebuild
+++ b/dev-lang/ruby/ruby-1.8.7_p249.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.7_p249.ebuild,v 1.6 2010/01/13 19:35:57 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.7_p249.ebuild,v 1.7 2010/05/06 19:50:01 a3li Exp $
EAPI=1
inherit autotools eutils flag-o-matic multilib versionator
@@ -14,7 +14,7 @@ MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="http://www.ruby-lang.org/"
SRC_URI="mirror://ruby/${SLOT}/${MY_P}.tar.bz2
- http://dev.a3li.li/gentoo/distfiles/${PN}-patches-${PV}.tar.bz2"
+ http://dev.a3li.li/gentoo/distfiles/${PN}-patches-${PVR}.tar.bz2"
LICENSE="|| ( Ruby GPL-2 )"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
@@ -59,7 +59,7 @@ src_unpack() {
cd "${S}"
EPATCH_FORCE="yes" EPATCH_SUFFIX="patch" \
- epatch "${WORKDIR}/patches-${PV}"
+ epatch "${WORKDIR}/patches-${PVR}"
# Fix a hardcoded lib path in configure script
sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \