summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-26 10:54:17 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-26 10:54:17 +0000
commit7cdac938541f2da8b3556977beb13649d30a877e (patch)
treed9bee8417e9d7dc7f1119906fa4afdad77b7f735 /dev-lang/v8
parentstable x86, bug 352394 (diff)
downloadgentoo-2-7cdac938541f2da8b3556977beb13649d30a877e.tar.gz
gentoo-2-7cdac938541f2da8b3556977beb13649d30a877e.tar.bz2
gentoo-2-7cdac938541f2da8b3556977beb13649d30a877e.zip
Version bump for beta channel release.
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'dev-lang/v8')
-rw-r--r--dev-lang/v8/ChangeLog7
-rw-r--r--dev-lang/v8/v8-2.5.9.11.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index dda2e9f26f2f..b039780873ff 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.30 2011/01/22 10:05:32 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.31 2011/01/26 10:54:17 phajdan.jr Exp $
+
+*v8-2.5.9.11 (26 Jan 2011)
+
+ 26 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> +v8-2.5.9.11.ebuild:
+ Version bump for beta channel release.
22 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> v8-3.0.7.ebuild,
v8-9999.ebuild:
diff --git a/dev-lang/v8/v8-2.5.9.11.ebuild b/dev-lang/v8/v8-2.5.9.11.ebuild
new file mode 100644
index 000000000000..c68355724170
--- /dev/null
+++ b/dev-lang/v8/v8-2.5.9.11.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.5.9.11.ebuild,v 1.1 2011/01/26 10:54:17 phajdan.jr Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic multilib scons-utils toolchain-funcs
+
+DESCRIPTION="Google's open source JavaScript engine"
+HOMEPAGE="http://code.google.com/p/v8"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="readline"
+
+RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
+DEPEND="${RDEPEND}"
+
+EXTRA_ESCONS="library=shared soname=on importenv=\"LINKFLAGS\""
+
+pkg_setup() {
+ tc-export AR CC CXX RANLIB
+
+ # Make the build respect LDFLAGS.
+ export LINKFLAGS="${LDFLAGS}"
+}
+
+src_prepare() {
+ # Stop -Werror from breaking the build.
+ epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
+
+ # Respect the user's CFLAGS, including the optimization level.
+ epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
+
+ # Fix a compile error (bug #349794), to be upstreamed.
+ epatch "${FILESDIR}"/${PN}-gentoo-bug-349794-r0.patch
+
+ # Backport an upstream bugfix for symbol visibility,
+ # see bug #348609.
+ epatch "${FILESDIR}"/${PN}-upstream-bug-1016-r0.patch
+
+ # Remove a test that is known to fail:
+ # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
+ rm test/mjsunit/debug-script.js || die
+
+ # Remove a test that behaves differently depending on FEATURES="userpriv",
+ # see bug #348558.
+ rm test/mjsunit/d8-os.js || die
+}
+
+src_configure() {
+ # GCC issues multiple warnings about strict-aliasing issues in v8 code.
+ append-flags -fno-strict-aliasing
+}
+
+src_compile() {
+ local myconf=""
+
+ # Use target arch detection logic from bug #296917.
+ local myarch="$ABI"
+ [[ $myarch = "" ]] && myarch="$ARCH"
+
+ if [[ $myarch = amd64 ]] ; then
+ myconf+=" arch=x64"
+ elif [[ $myarch = x86 ]] ; then
+ myconf+=" arch=ia32"
+ elif [[ $myarch = arm ]] ; then
+ myconf+=" arch=arm"
+ else
+ die "Failed to determine target arch, got '$myarch'."
+ fi
+
+ escons $(use_scons readline console readline dumb) ${myconf} . || die
+}
+
+src_install() {
+ insinto /usr
+ doins -r include || die
+
+ dobin d8 || die
+
+ dolib libv8-${PV}.so || die
+ dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
+
+ dodoc AUTHORS ChangeLog || die
+}
+
+src_test() {
+ tools/test.py --no-build -p dots --shell d8 || die
+}