summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2008-10-27 20:27:15 +0000
committerFederico Ferri <mescalinum@gentoo.org>2008-10-27 20:27:15 +0000
commit2d36e87b21aa95ea77395b75d94a16dd7a1f3c61 (patch)
tree689bbc1130eb85e4693d30e58c2290789927ef44 /dev-lang/tk
parentamd64/x86 stable, bug #244535 (diff)
downloadgentoo-2-2d36e87b21aa95ea77395b75d94a16dd7a1f3c61.tar.gz
gentoo-2-2d36e87b21aa95ea77395b75d94a16dd7a1f3c61.tar.bz2
gentoo-2-2d36e87b21aa95ea77395b75d94a16dd7a1f3c61.zip
adding patch 8.4-lastevent, fixes bug #225999
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang/tk')
-rw-r--r--dev-lang/tk/ChangeLog8
-rw-r--r--dev-lang/tk/files/tk-8.4-lastevent.patch28
-rw-r--r--dev-lang/tk/tk-8.4.18-r1.ebuild120
-rw-r--r--dev-lang/tk/tk-8.4.19.ebuild7
4 files changed, 160 insertions, 3 deletions
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index 6982152e0e58..c1c3239d6484 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/tk
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.111 2008/10/26 11:21:33 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.112 2008/10/27 20:27:07 mescalinum Exp $
+
+*tk-8.4.18-r1 (27 Oct 2008)
+
+ 27 Oct 2008; Federico Ferri <mescalinum@gentoo.org>
+ +files/tk-8.4-lastevent.patch, +tk-8.4.18-r1.ebuild, tk-8.4.19.ebuild:
+ adding patch 8.4-lastevent, fixes bug #225999
*tk-8.4.19 (26 Oct 2008)
diff --git a/dev-lang/tk/files/tk-8.4-lastevent.patch b/dev-lang/tk/files/tk-8.4-lastevent.patch
new file mode 100644
index 000000000000..f93d335bf964
--- /dev/null
+++ b/dev-lang/tk/files/tk-8.4-lastevent.patch
@@ -0,0 +1,28 @@
+Source: Jeffrey Gardner (je_fro) <jeffrey.e.gardner@comcast.net> - http://overlays.gentoo.org/dev/je_fro/browser/dev-lang/tk/files/tk-8.4-lastevent.patch
+Upstream: N/A
+Reason: Fix ABI incompatibility introduced by x11-proto/xproto-7.0.13 (bug #225999)
+--- generic/tk.h.orig 2008-02-06 16:31:40.000000000 +0100
++++ generic/tk.h 2008-07-24 08:21:46.000000000 +0200
+@@ -635,17 +635,15 @@
+ *
+ *---------------------------------------------------------------------------
+ */
+-#define VirtualEvent (LASTEvent)
+-#define ActivateNotify (LASTEvent + 1)
+-#define DeactivateNotify (LASTEvent + 2)
+-#define MouseWheelEvent (LASTEvent + 3)
+-#define TK_LASTEVENT (LASTEvent + 4)
++#define VirtualEvent (MappingNotify + 1)
++#define ActivateNotify (MappingNotify + 2)
++#define DeactivateNotify (MappingNotify + 3)
++#define MouseWheelEvent (MappingNotify + 4)
++#define TK_LASTEVENT (MappingNotify + 5)
+
+ #define MouseWheelMask (1L << 28)
+-
+ #define ActivateMask (1L << 29)
+ #define VirtualEventMask (1L << 30)
+-#define TK_LASTEVENT (LASTEvent + 4)
+
+
+ /*
diff --git a/dev-lang/tk/tk-8.4.18-r1.ebuild b/dev-lang/tk/tk-8.4.18-r1.ebuild
new file mode 100644
index 000000000000..ea40525dc2ac
--- /dev/null
+++ b/dev-lang/tk/tk-8.4.18-r1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.18-r1.ebuild,v 1.1 2008/10/27 20:27:07 mescalinum Exp $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+
+inherit autotools eutils multilib toolchain-funcs
+
+DESCRIPTION="Tk Widget Set"
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug threads"
+
+RDEPEND="x11-libs/libX11
+ ~dev-lang/tcl-${PV}"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ >=x11-proto/xproto-7.0.13"
+
+S=${WORKDIR}/${PN}${PV}
+
+pkg_setup() {
+ if use threads ; then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling ${P} with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications"
+ ewarn "that compile against tcl. You use threading at"
+ ewarn "your own discretion."
+ ewarn ""
+ epause 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/remove-control-v-8.4.9.diff
+ epatch "${FILESDIR}"/${PN}-8.4.9-man.patch
+ epatch "${FILESDIR}"/${PN}-8.4.11-multilib.patch
+
+ # Bug 125971
+ epatch "${FILESDIR}"/${PN}-8.4.15-tclm4-soname.patch
+
+ # Bug 225999
+ epatch "${FILESDIR}"/${PN}-8.4-lastevent.patch
+
+ local d
+ for d in */configure ; do
+ cd "${S}"/${d%%/*}
+ EPATCH_SINGLE_MSG="Patching nls cruft in ${d}" \
+ epatch "${FILESDIR}"/tk-configure-LANG.patch
+ done
+
+ cd "${S}"/unix
+ eautoreconf
+}
+
+src_compile() {
+ tc-export CC
+ cd "${S}"/unix
+
+ local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
+
+ econf \
+ --with-tcl=/usr/${mylibdir} \
+ $(use_enable threads) \
+ $(use_enable debug symbols) || die
+
+ emake || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd "${S}"/unix
+ make DESTDIR="${D}" install || die
+
+ # fix the tkConfig.sh to eliminate refs to the build directory
+ local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
+ sed -i \
+ -e "s,^\(TK_BUILD_LIB_SPEC='-L\)${S}/unix,\1/usr/${mylibdir}," \
+ -e "s,^\(TK_SRC_DIR='\)${S}',\1/usr/${mylibdir}/tk${v1}/include'," \
+ -e "s,^\(TK_BUILD_STUB_LIB_SPEC='-L\)${S}/unix,\1/usr/${mylibdir}," \
+ -e "s,^\(TK_BUILD_STUB_LIB_PATH='\)${S}/unix,\1/usr/${mylibdir}," \
+ -e "s,^\(TK_CC_SEARCH_FLAGS='.*\)',\1:/usr/${mylibdir}'," \
+ -e "s,^\(TK_LD_SEARCH_FLAGS='.*\)',\1:/usr/${mylibdir}'," \
+ "${D}"/usr/${mylibdir}/tkConfig.sh || die
+
+ # install private headers
+ insinto /usr/${mylibdir}/tk${v1}/include/unix
+ doins "${S}"/unix/*.h || die
+ insinto /usr/${mylibdir}/tk${v1}/include/generic
+ doins "${S}"/generic/*.h || die
+ rm -f "${D}"/usr/${mylibdir}/tk${v1}/include/generic/tk.h
+ rm -f "${D}"/usr/${mylibdir}/tk${v1}/include/generic/tkDecls.h
+ rm -f "${D}"/usr/${mylibdir}/tk${v1}/include/generic/tkPlatDecls.h
+
+ # install symlink for libraries
+ #dosym libtk${v1}.a /usr/${mylibdir}/libtk.a
+ if use debug ; then
+ dosym libtk${v1}g.so /usr/${mylibdir}/libtk${v1}.so
+ dosym libtkstub${v1}g.a /usr/${mylibdir}/libtkstub${v1}.a
+ dosym ../tk${v1}g/pkgIndex.tcl /usr/${mylibdir}/tk${v1}/pkgIndex.tcl
+ fi
+ dosym libtk${v1}.so /usr/${mylibdir}/libtk.so
+ dosym libtkstub${v1}.a /usr/${mylibdir}/libtkstub.a
+
+ dosym wish${v1} /usr/bin/wish
+
+ cd "${S}"
+ dodoc ChangeLog README changes license.terms
+}
diff --git a/dev-lang/tk/tk-8.4.19.ebuild b/dev-lang/tk/tk-8.4.19.ebuild
index d6f01c46f8b7..3f199a194dd5 100644
--- a/dev-lang/tk/tk-8.4.19.ebuild
+++ b/dev-lang/tk/tk-8.4.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.19.ebuild,v 1.1 2008/10/26 11:21:33 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.19.ebuild,v 1.2 2008/10/27 20:27:07 mescalinum Exp $
WANT_AUTOCONF=latest
WANT_AUTOMAKE=latest
@@ -20,7 +20,7 @@ RDEPEND="x11-libs/libX11
~dev-lang/tcl-${PV}"
DEPEND="${RDEPEND}
x11-libs/libXt
- x11-proto/xproto"
+ >=x11-proto/xproto-7.0.3"
S=${WORKDIR}/${PN}${PV}
@@ -47,6 +47,9 @@ src_unpack() {
# Bug 125971
epatch "${FILESDIR}"/${PN}-8.4.15-tclm4-soname.patch
+ # Bug 225999
+ epatch "${FILESDIR}"/${PN}-8.4-lastevent.patch
+
local d
for d in */configure ; do
cd "${S}"/${d%%/*}