summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-01-18 14:57:36 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-01-18 14:57:36 +0000
commitcfc7e57181489199248848086cb4d647f2924047 (patch)
tree37b2a58b5728e7a1b8d37233e15baf75f3efcfc7 /dev-lang/ruby
parentAdd patch from bug 119403. It should allow it to work on ppc64/ppc. (diff)
downloadgentoo-2-cfc7e57181489199248848086cb4d647f2924047.tar.gz
gentoo-2-cfc7e57181489199248848086cb4d647f2924047.tar.bz2
gentoo-2-cfc7e57181489199248848086cb4d647f2924047.zip
remove old versions
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ChangeLog6
-rw-r--r--dev-lang/ruby/files/digest-ruby-1.8.22
-rw-r--r--dev-lang/ruby/files/digest-ruby-1.8.2-r12
-rw-r--r--dev-lang/ruby/ruby-1.8.2-r1.ebuild134
-rw-r--r--dev-lang/ruby/ruby-1.8.2.ebuild128
5 files changed, 5 insertions, 267 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 7a8ecb9e91b2..901eda93d1b7 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ruby
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.178 2006/01/18 14:27:39 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.179 2006/01/18 14:57:36 caleb Exp $
+
+ 18 Jan 2006; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.2.ebuild,
+ -ruby-1.8.2-r1.ebuild:
+ Remove old versions
18 Jan 2006; Caleb Tennis <caleb@gentoo.org> ruby-1.8.4-r1.ebuild:
I think this is now a good candidate for x86 stable
diff --git a/dev-lang/ruby/files/digest-ruby-1.8.2 b/dev-lang/ruby/files/digest-ruby-1.8.2
deleted file mode 100644
index 8d52d012ead8..000000000000
--- a/dev-lang/ruby/files/digest-ruby-1.8.2
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 8ffc79d96f336b80f2690a17601dea9b ruby-1.8.2.tar.gz 3627349
-MD5 f64bad67181b02fbd67fac16710537f3 onigd2_4_0.tar.gz 202285
diff --git a/dev-lang/ruby/files/digest-ruby-1.8.2-r1 b/dev-lang/ruby/files/digest-ruby-1.8.2-r1
deleted file mode 100644
index 8d52d012ead8..000000000000
--- a/dev-lang/ruby/files/digest-ruby-1.8.2-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 8ffc79d96f336b80f2690a17601dea9b ruby-1.8.2.tar.gz 3627349
-MD5 f64bad67181b02fbd67fac16710537f3 onigd2_4_0.tar.gz 202285
diff --git a/dev-lang/ruby/ruby-1.8.2-r1.ebuild b/dev-lang/ruby/ruby-1.8.2-r1.ebuild
deleted file mode 100644
index 7a99672efe20..000000000000
--- a/dev-lang/ruby/ruby-1.8.2-r1.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.2-r1.ebuild,v 1.17 2005/07/03 09:50:38 kloeri Exp $
-
-ONIGURUMA="onigd2_4_0"
-
-inherit flag-o-matic alternatives eutils gnuconfig
-
-DESCRIPTION="An object-oriented scripting language"
-HOMEPAGE="http://www.ruby-lang.org/"
-SRC_URI="mirror://ruby/${PV%.*}/${P/_pre/-preview}.tar.gz
- cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
-
-LICENSE="Ruby"
-SLOT="1.8"
-# please keep sorted
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc-macos ppc64 s390 sparc x86"
-IUSE="socks5 tcltk cjk doc threads"
-
-RDEPEND="virtual/libc
- >=sys-libs/gdbm-1.8.0
- >=sys-libs/readline-4.1
- >=sys-libs/ncurses-5.2
- socks5? ( >=net-proxy/dante-1.1.13 )
- tcltk? ( dev-lang/tk )
- >=dev-ruby/ruby-config-0.3
- !=dev-lang/ruby-cvs-1.8*"
-DEPEND="sys-devel/autoconf
- sys-apps/findutils
- ${RDEPEND}"
-PROVIDE="virtual/ruby"
-
-S=${WORKDIR}/${P%_*}
-
-src_unpack() {
- unpack ${A}
-
- if use cjk ; then
- einfo "Applying ${ONIGURUMA}"
- pushd ${WORKDIR}/oniguruma
- epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
- econf --with-rubydir=${S} || die "econf failed"
- make ${SLOT/./}
- popd
- fi
-
- # Enable build on alpha EV67 (but run gnuconfig_update everywhere)
- gnuconfig_update || die "gnuconfig_update failed"
-
- cd ${S}
- epatch ${FILESDIR}/ruby-rdoc-gentoo.diff
- epatch ${FILESDIR}/ruby-1.8.2-soap.diff
- epatch ${FILESDIR}/ruby-1.8.2-unittest.diff
-
- # Fix a hardcoded lib path in configure script
- sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
- configure.in || die "sed failed"
-}
-
-src_compile() {
- filter-flags -fomit-frame-pointer
-
- # Socks support via dante
- if use socks5; then
- # Socks support can't be disabled as long as SOCKS_SERVER is
- # set and socks library is present, so need to unset
- # SOCKS_SERVER in that case.
- unset SOCKS_SERVER
- fi
-
- # Increase GC_MALLOC_LIMIT if set (default is 8000000)
- if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
- CFLAGS="${CFLAGS} -DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
- export CFLAGS
- fi
-
- # On ia64 we need to build without optimization #48824
- if use ia64; then
- replace-flags '-O*' -O0
- fi
-
- econf --program-suffix=${SLOT/./} --enable-shared \
- $(use_enable socks5 socks) \
- $(use_enable doc install-doc) \
- $(use_enable threads pthread) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- LD_LIBRARY_PATH=${D}/usr/$(get_libdir)
- RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
- for d in $(find ${S}/ext -type d) ; do
- RUBYLIB="${RUBYLIB}:$d"
- done
- export LD_LIBRARY_PATH RUBYLIB
-
- make DESTDIR=${D} install || die "make install failed"
-
- if use ppc-macos ; then
- dosym /usr/lib/libruby${SLOT/./}.${PV%_*}.dylib /usr/lib/libruby.${PV%.*}.dylib
- dosym /usr/lib/libruby${SLOT/./}.${PV%_*}.dylib /usr/lib/libruby.${PV%_*}.dylib
- else
- dosym /usr/$(get_libdir)/libruby${SLOT/./}.so.${PV%_*} /usr/$(get_libdir)/libruby.so.${PV%.*}
- dosym /usr/$(get_libdir)/libruby${SLOT/./}.so.${PV%_*} /usr/$(get_libdir)/libruby.so.${PV%_*}
- fi
-
- dodoc COPYING* ChangeLog MANIFEST README* ToDo
-}
-
-pkg_postinst() {
- if ! use ppc-macos ; then
- ewarn
- ewarn "Warning: Vim won't work if you've just updated ruby from"
- ewarn "1.6.x to 1.8.x due to the library version change."
- ewarn "In that case, you will need to remerge vim."
- ewarn
-
- if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
- ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
- fi
- einfo
- einfo "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
- einfo
- fi
-}
-
-pkg_postrm() {
- if ! use ppc-macos ; then
- if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
- ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
- fi
- fi
-}
diff --git a/dev-lang/ruby/ruby-1.8.2.ebuild b/dev-lang/ruby/ruby-1.8.2.ebuild
deleted file mode 100644
index e60af0972a75..000000000000
--- a/dev-lang/ruby/ruby-1.8.2.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.2.ebuild,v 1.10 2005/10/08 15:02:57 grobian Exp $
-
-ONIGURUMA="onigd2_4_0"
-
-inherit flag-o-matic alternatives eutils gnuconfig
-
-DESCRIPTION="An object-oriented scripting language"
-HOMEPAGE="http://www.ruby-lang.org/"
-SRC_URI="mirror://ruby/${PV%.*}/${P/_pre/-preview}.tar.gz
- cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
-
-LICENSE="Ruby"
-SLOT="1.8"
-# please keep sorted
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 s390 sparc x86"
-IUSE="socks5 tcltk cjk doc threads"
-
-RDEPEND="virtual/libc
- >=sys-libs/gdbm-1.8.0
- >=sys-libs/readline-4.1
- >=sys-libs/ncurses-5.2
- socks5? ( >=net-proxy/dante-1.1.13 )
- tcltk? ( dev-lang/tk )
- >=dev-ruby/ruby-config-0.3
- !=dev-lang/ruby-cvs-1.8*"
-DEPEND="sys-devel/autoconf
- sys-apps/findutils
- ${RDEPEND}"
-PROVIDE="virtual/ruby"
-
-S=${WORKDIR}/${P%_*}
-
-src_unpack() {
- unpack ${A}
-
- if use cjk ; then
- einfo "Applying ${ONIGURUMA}"
- pushd ${WORKDIR}/oniguruma
- epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
- econf --with-rubydir=${S} || die "econf failed"
- make ${SLOT/./}
- popd
- fi
-
- # Enable build on alpha EV67 (but run gnuconfig_update everywhere)
- gnuconfig_update || die "gnuconfig_update failed"
-
- cd ${S}
- epatch ${FILESDIR}/ruby-rdoc-gentoo.diff
-}
-
-src_compile() {
- filter-flags -fomit-frame-pointer
-
- # Socks support via dante
- if use socks5; then
- # Socks support can't be disabled as long as SOCKS_SERVER is
- # set and socks library is present, so need to unset
- # SOCKS_SERVER in that case.
- unset SOCKS_SERVER
- fi
-
- # Increase GC_MALLOC_LIMIT if set (default is 8000000)
- if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
- CFLAGS="${CFLAGS} -DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
- export CFLAGS
- fi
-
- # On ia64 we need to build without optimization #48824
- if use ia64; then
- replace-flags '-O*' -O0
- fi
-
- econf --program-suffix=${SLOT/./} --enable-shared \
- $(use_enable socks5 socks) \
- $(use_enable doc install-doc) \
- $(use_enable threads pthread) \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- LD_LIBRARY_PATH=${D}/usr/lib
- RUBYLIB="${S}:${D}/usr/lib/ruby/${SLOT}"
- for d in $(find ${S}/ext -type d) ; do
- RUBYLIB="${RUBYLIB}:$d"
- done
- export LD_LIBRARY_PATH RUBYLIB
-
- make DESTDIR=${D} install || die "make install failed"
-
- if use ppc-macos ; then
- dosym /usr/lib/libruby${SLOT/./}.${PV%_*}.dylib /usr/lib/libruby.${PV%.*}.dylib
- dosym /usr/lib/libruby${SLOT/./}.${PV%_*}.dylib /usr/lib/libruby.${PV%_*}.dylib
- else
- dosym /usr/lib/libruby${SLOT/./}.so.${PV%_*} /usr/lib/libruby.so.${PV%.*}
- dosym /usr/lib/libruby${SLOT/./}.so.${PV%_*} /usr/lib/libruby.so.${PV%_*}
- fi
-
- dodoc COPYING* ChangeLog MANIFEST README* ToDo
-}
-
-pkg_postinst() {
- if ! use ppc-macos ; then
- ewarn
- ewarn "Warning: Vim won't work if you've just updated ruby from"
- ewarn "1.6.x to 1.8.x due to the library version change."
- ewarn "In that case, you will need to remerge vim."
- ewarn
-
- if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
- ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
- fi
- einfo
- einfo "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
- einfo
- fi
-}
-
-pkg_postrm() {
- if ! use ppc-macos ; then
- if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
- ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
- fi
- fi
-}