summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-07-02 15:14:41 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-07-02 15:14:41 +0000
commit367c7586af0eefd6a0f1a23efd7a5430f59ee69f (patch)
treeba06ec267546674192d4a32b0b6728f34ec536e9 /dev-lang/php
parentStable on amd64 wrt bug #372601 (diff)
downloadgentoo-2-367c7586af0eefd6a0f1a23efd7a5430f59ee69f.tar.gz
gentoo-2-367c7586af0eefd6a0f1a23efd7a5430f59ee69f.tar.bz2
gentoo-2-367c7586af0eefd6a0f1a23efd7a5430f59ee69f.zip
Removed call to silly phpconfutils_init. Added addpredict to src_configure (also silly)
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/ChangeLog8
-rw-r--r--dev-lang/php/files/eblits/pkg_setup-v3.eblit9
-rw-r--r--dev-lang/php/files/eblits/src_configure-v3.eblit6
-rw-r--r--dev-lang/php/php-5.4.0_alpha1.ebuild4
4 files changed, 21 insertions, 6 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index 38a8bbc83fa5..4cced3f55048 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.494 2011/07/01 11:45:01 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.495 2011/07/02 15:14:41 olemarkus Exp $
+
+ 02 Jul 2011; Ole Markus With <olemarkus@gentoo.org>
+ +files/eblits/pkg_setup-v3.eblit, files/eblits/src_configure-v3.eblit,
+ php-5.4.0_alpha1.ebuild:
+ Removed call to silly phpconfutils_init. Added addpredict to src_configure
+ (also silly)
*php-5.3.7_rc2 (01 Jul 2011)
diff --git a/dev-lang/php/files/eblits/pkg_setup-v3.eblit b/dev-lang/php/files/eblits/pkg_setup-v3.eblit
new file mode 100644
index 000000000000..ca8190642111
--- /dev/null
+++ b/dev-lang/php/files/eblits/pkg_setup-v3.eblit
@@ -0,0 +1,9 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/pkg_setup-v3.eblit,v 1.1 2011/07/02 15:14:41 olemarkus Exp $
+
+eblit-php-pkg_setup() {
+ depend.apache_pkg_setup
+}
+
+
diff --git a/dev-lang/php/files/eblits/src_configure-v3.eblit b/dev-lang/php/files/eblits/src_configure-v3.eblit
index 401a24a60bbd..7765c58a3982 100644
--- a/dev-lang/php/files/eblits/src_configure-v3.eblit
+++ b/dev-lang/php/files/eblits/src_configure-v3.eblit
@@ -1,8 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v3.eblit,v 1.2 2011/06/30 07:30:11 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v3.eblit,v 1.3 2011/07/02 15:14:41 olemarkus Exp $
eblit-php-src_configure() {
+ addpredict /usr/share/snmp/mibs/.index
+
PHP_DESTDIR="/usr/$(get_libdir)/php${SLOT}"
# This is a global variable and should be in caps. It isn't because the
@@ -17,8 +19,6 @@ eblit-php-src_configure() {
--without-pear
$(use_enable threads maintainer-zts)"
- phpconfutils_init
-
# extension USE flag shared
phpconfutils_extension_enable "bcmath" "bcmath" 1
phpconfutils_extension_with "bz2" "bzip2" 1
diff --git a/dev-lang/php/php-5.4.0_alpha1.ebuild b/dev-lang/php/php-5.4.0_alpha1.ebuild
index 0f7e318ff440..7330bbc36c55 100644
--- a/dev-lang/php/php-5.4.0_alpha1.ebuild
+++ b/dev-lang/php/php-5.4.0_alpha1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.4.0_alpha1.ebuild,v 1.2 2011/06/30 07:30:11 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.4.0_alpha1.ebuild,v 1.3 2011/07/02 15:14:41 olemarkus Exp $
EAPI=4
@@ -318,7 +318,7 @@ eblit-pkg() {
eblit-core $1 $2 1
}
-eblit-pkg pkg_setup v2
+eblit-pkg pkg_setup v3
src_prepare() { eblit-run src_prepare v4 ; }
src_configure() { eblit-run src_configure v3 ; }