summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-20 07:15:12 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-20 07:15:12 +0000
commit0b171b72e08f5ef07827515ee3e68d0df02b431f (patch)
treee51e9baa3f749be1c2ed58cff56481bd034f737c /dev-lang/opendylan-bin/opendylan-bin-2011.1.ebuild
parentAdding Opendylan license for dev-lang/opendylan{,-bin} (diff)
downloadgentoo-2-0b171b72e08f5ef07827515ee3e68d0df02b431f.tar.gz
gentoo-2-0b171b72e08f5ef07827515ee3e68d0df02b431f.tar.bz2
gentoo-2-0b171b72e08f5ef07827515ee3e68d0df02b431f.zip
Initial import, ebuilds by me
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/opendylan-bin/opendylan-bin-2011.1.ebuild')
-rw-r--r--dev-lang/opendylan-bin/opendylan-bin-2011.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lang/opendylan-bin/opendylan-bin-2011.1.ebuild b/dev-lang/opendylan-bin/opendylan-bin-2011.1.ebuild
new file mode 100644
index 000000000000..f4e33283eed3
--- /dev/null
+++ b/dev-lang/opendylan-bin/opendylan-bin-2011.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan-bin/opendylan-bin-2011.1.ebuild,v 1.1 2012/08/20 07:15:12 patrick Exp $
+EAPI=4
+
+DESCRIPTION="OpenDylan language runtime environment (prebuilt)"
+
+MY_PN="opendylan"
+MY_P="${MY_PN}-${PV}"
+HOMEPAGE="http://opendylan.org"
+SRC_URI="amd64? ( http://opendylan.org/downloads/${MY_PN}/${PV}/${MY_P}-x86_64-linux.tar.bz2 )
+ x86? ( http://opendylan.org/downloads/${MY_PN}/${PV}/${MY_P}-x86-linux.tar.bz2 )"
+LICENSE="Opendylan"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+
+DEPEND="dev-libs/boehm-gc"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ # this is a precompiled tarball
+ mkdir -p "${D}/opt/${MY_P}"
+ cp -ar "${S}/*" "${D}/opt/${MY_P}"
+ mkdir -p "${D}/etc/env.d/opendylan"
+ echo "export PATH=/opt/opendylan-2011.1/bin:\$PATH" >> "${D}/etc/env.d/opendylan/99-opendylan" || die "Failed to add env settings"
+}