summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-03 11:55:57 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-03 11:55:57 +0000
commitcb3a40d3a455444a93c5c742425143a42faffc9e (patch)
tree91b8f045bf9f2353ee8e9a87b48771db791b0db3 /dev-lang/ocaml
parentKeyword ~alpha wrt #272046, thanks to Tobias Klausmann for testing. (diff)
downloadgentoo-2-cb3a40d3a455444a93c5c742425143a42faffc9e.tar.gz
gentoo-2-cb3a40d3a455444a93c5c742425143a42faffc9e.tar.bz2
gentoo-2-cb3a40d3a455444a93c5c742425143a42faffc9e.zip
remove old
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog5
-rw-r--r--dev-lang/ocaml/ocaml-3.08.4.ebuild95
2 files changed, 4 insertions, 96 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 7e715a029a4f..68b2098e9c6c 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ocaml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.163 2009/06/03 11:52:59 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.164 2009/06/03 11:55:57 aballier Exp $
+
+ 03 Jun 2009; Alexis Ballier <aballier@gentoo.org> -ocaml-3.08.4.ebuild:
+ remove old
*ocaml-3.11.1_rc1 (03 Jun 2009)
diff --git a/dev-lang/ocaml/ocaml-3.08.4.ebuild b/dev-lang/ocaml/ocaml-3.08.4.ebuild
deleted file mode 100644
index ef1273adfb9b..000000000000
--- a/dev-lang/ocaml/ocaml-3.08.4.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.4.ebuild,v 1.20 2009/01/20 08:43:57 aballier Exp $
-
-inherit flag-o-matic eutils multilib
-
-DESCRIPTION="Fast modern type-inferring functional programming language descended from the ML family"
-HOMEPAGE="http://www.ocaml.org/"
-
-SRC_URI="http://caml.inria.fr/distrib/ocaml-3.08/${P}.tar.bz2"
-
-LICENSE="QPL-1.0 LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~ppc ~ppc64 -s390 sparc ~x86"
-IUSE="tk latex"
-
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- ewarn
- ewarn "Building ocaml with unsafe CFLAGS can have unexpected results"
- ewarn "Please retry building with safer CFLAGS before reporting bugs"
- ewarn "Likewise, building with a hardened gcc is not possible."
- ewarn
-}
-
-src_compile() {
- filter-flags "-fstack-protector"
- replace-flags "-O?" -O2
-
- local myconf
- use tk || myconf="-no-tk"
-
- # Fix for bug #23767.
- if [ "${ARCH}" = "sparc" ]; then
- myconf="${myconf} -host sparc-unknown-linux-gnu"
- fi
-
- # Fix for bug #46703
- export LC_ALL=C
-
- ./configure -prefix /usr \
- -bindir /usr/bin \
- -libdir /usr/$(get_libdir)/ocaml \
- -mandir /usr/share/man \
- --with-pthread ${myconf} || die
-
- sed -i -e "s/\(BYTECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
- sed -i -e "s/\(NATIVECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
-
- make world || die
- # Native code generation unsupported on some archs
- if ! use ppc64 ; then
- make opt || die
- make opt.opt || die
- fi
-}
-
-src_install() {
- make BINDIR="${D}/usr/bin" \
- LIBDIR="${D}/usr/$(get_libdir)/ocaml" \
- MANDIR="${D}/usr/share/man" \
- install || die
-
- # compiler libs
- dodir /usr/lib/ocaml/compiler-libs
- insinto /usr/lib/ocaml/compiler-libs
- doins {utils,typing,parsing}/*.{mli,cmi,cmo,cmx,o}
-
- # headers
- dodir /usr/include
- dosym /usr/include/caml /usr/lib/ocaml/caml
-
- # silly, silly makefiles
- dosed "s:${D}::g" /usr/$(get_libdir)/ocaml/ld.conf
-
- # documentation
- dodoc Changes INSTALL README Upgrading
-}
-
-pkg_postinst() {
- if use latex; then
- echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
- fi
-
- echo
- elog "OCaml is not binary compatible from version to version,"
- elog "so you (may) need to rebuild all packages depending on it that"
- elog "are actually installed on your system."
- elog "To do so, you can run: "
- elog "sh '${FILESDIR}/ocaml-rebuild.sh' [-h | emerge options]"
- elog "Which will call emerge on all old packages with the given options"
- echo
-}