summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-11-07 09:59:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-11-07 09:59:10 +0000
commit7c47867fd99371f88f24b40df88c36cfaa7a65ba (patch)
treea0dc22fd8276af93635bc0cea76c53b74825be20 /dev-lang/ocaml
parentMake repoman happy. (diff)
downloadgentoo-2-7c47867fd99371f88f24b40df88c36cfaa7a65ba.tar.gz
gentoo-2-7c47867fd99371f88f24b40df88c36cfaa7a65ba.tar.bz2
gentoo-2-7c47867fd99371f88f24b40df88c36cfaa7a65ba.zip
merge similar patches and make it honour better ldflags
(Portage version: 2.2_rc13/cvs/Linux 2.6.27.4 x86_64)
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog7
-rw-r--r--dev-lang/ocaml/files/ocaml-3.11.0_beta1-call-ld-with-proper-ldflags.patch27
-rw-r--r--dev-lang/ocaml/files/ocaml-3.11.0_beta1-configure.patch21
-rw-r--r--dev-lang/ocaml/ocaml-3.11.0_beta1.ebuild7
4 files changed, 27 insertions, 35 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index ecdfa8fd2b14..e94fe1852c66 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.150 2008/10/15 16:08:56 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.151 2008/11/07 09:59:10 aballier Exp $
+
+ 07 Nov 2008; Alexis Ballier <aballier@gentoo.org>
+ -files/ocaml-3.11.0_beta1-call-ld-with-proper-ldflags.patch,
+ files/ocaml-3.11.0_beta1-configure.patch, ocaml-3.11.0_beta1.ebuild:
+ merge similar patches and make it honour better ldflags
*ocaml-3.11.0_beta1 (15 Oct 2008)
diff --git a/dev-lang/ocaml/files/ocaml-3.11.0_beta1-call-ld-with-proper-ldflags.patch b/dev-lang/ocaml/files/ocaml-3.11.0_beta1-call-ld-with-proper-ldflags.patch
deleted file mode 100644
index 53e2febe6681..000000000000
--- a/dev-lang/ocaml/files/ocaml-3.11.0_beta1-call-ld-with-proper-ldflags.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-As we now support LDFLAGS in NATIVECCLINKOPTS
-it can happen that -Wl,--foo,--bar option is in that variable
-As ocaml happens to call ld with NATIVECCLINKOPTS
-we have to "translate" it so that ld doesn't bail out with unrecognized option
-Initial patch from Julien Cristau : http://caml.inria.fr/mantis/view.php?id=4142
-Modified a bit to catch comma separated options
-Index: ocaml-3.11.0+beta1/configure
-===================================================================
---- ocaml-3.11.0+beta1.orig/configure
-+++ ocaml-3.11.0+beta1/configure
-@@ -1503,6 +1503,7 @@ fi
- bytecccompopts="$CFLAGS $bytecccompopts"
- bytecclinkopts="$LDFLAGS $bytecclinkopts"
- natdynlinkopts="$LDFLAGS $natdynlinkopts"
-+nativeccrawlinkopts="$RAW_LDFLAGS $nativecclinkopts"
- nativecclinkopts="$LDFLAGS $nativecclinkopts"
- nativecccompopts="$CFLAGS $nativecccompopts"
- nativeccprofopts="$nativecccompopts"
-@@ -1553,7 +1554,7 @@ echo "DEBUGGER=$debugger" >> Makefile
- echo "CC_PROFILE=$cc_profile" >> Makefile
- echo "SYSTHREAD_SUPPORT=$systhread_support" >> Makefile
- echo "PARTIALLD=$partialld" >> Makefile
--echo "PACKLD=\$(PARTIALLD) \$(NATIVECCLINKOPTS) -o " >> Makefile
-+echo "PACKLD=\$(PARTIALLD) $nativeccrawlinkopts -o " >> Makefile
- echo "DLLCCCOMPOPTS=$dllccompopts" >> Makefile
- echo "IFLEXDIR=$iflexdir" >> Makefile
- echo "O=o" >> Makefile
diff --git a/dev-lang/ocaml/files/ocaml-3.11.0_beta1-configure.patch b/dev-lang/ocaml/files/ocaml-3.11.0_beta1-configure.patch
index 31f8620b251e..411904c37a60 100644
--- a/dev-lang/ocaml/files/ocaml-3.11.0_beta1-configure.patch
+++ b/dev-lang/ocaml/files/ocaml-3.11.0_beta1-configure.patch
@@ -2,15 +2,34 @@ Index: ocaml-3.11.0+beta1/configure
===================================================================
--- ocaml-3.11.0+beta1.orig/configure
+++ ocaml-3.11.0+beta1/configure
-@@ -1494,6 +1494,11 @@ fi
+@@ -245,7 +245,7 @@ esac
+ # Configure the bytecode compiler
+
+ bytecc="$cc"
+-mkexe="\$(BYTECC)"
++mkexe="\$(BYTECC) \$(BYTECCLINKOPTS)"
+ bytecccompopts=""
+ bytecclinkopts=""
+ dllccompopts=""
+@@ -1500,6 +1500,12 @@ fi
# Final twiddling of compiler options to work around known bugs
+bytecccompopts="$CFLAGS $bytecccompopts"
+bytecclinkopts="$LDFLAGS $bytecclinkopts"
+natdynlinkopts="$LDFLAGS $natdynlinkopts"
++nativeccrawlinkopts="$RAW_LDFLAGS $nativecclinkopts"
+nativecclinkopts="$LDFLAGS $nativecclinkopts"
+nativecccompopts="$CFLAGS $nativecccompopts"
nativeccprofopts="$nativecccompopts"
case "$buggycc" in
gcc.2.96)
+@@ -1548,7 +1554,7 @@ echo "DEBUGGER=$debugger" >> Makefile
+ echo "CC_PROFILE=$cc_profile" >> Makefile
+ echo "SYSTHREAD_SUPPORT=$systhread_support" >> Makefile
+ echo "PARTIALLD=$partialld" >> Makefile
+-echo "PACKLD=\$(PARTIALLD) \$(NATIVECCLINKOPTS) -o " >> Makefile
++echo "PACKLD=\$(PARTIALLD) $nativeccrawlinkopts -o " >> Makefile
+ echo "DLLCCCOMPOPTS=$dllccompopts" >> Makefile
+ echo "IFLEXDIR=$iflexdir" >> Makefile
+ echo "O=o" >> Makefile
diff --git a/dev-lang/ocaml/ocaml-3.11.0_beta1.ebuild b/dev-lang/ocaml/ocaml-3.11.0_beta1.ebuild
index 03d73bb5e68e..063188478699 100644
--- a/dev-lang/ocaml/ocaml-3.11.0_beta1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.11.0_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.0_beta1.ebuild,v 1.1 2008/10/15 16:08:56 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.0_beta1.ebuild,v 1.2 2008/11/07 09:59:10 aballier Exp $
inherit flag-o-matic eutils multilib versionator toolchain-funcs
@@ -51,11 +51,6 @@ src_unpack() {
# ocaml has automagics on libX11 and gdbm
# http://caml.inria.fr/mantis/view.php?id=4278
epatch "${FILESDIR}/${PN}-3.10.0-automagic.patch"
-
- # Call ld with proper flags, different from gcc ones
- # This happens when calling ocamlc -pack
- # See comment in the patch
- epatch "${FILESDIR}/${PN}-3.11.0_beta1-call-ld-with-proper-ldflags.patch"
}
src_compile() {