summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-19 14:47:29 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-19 14:47:29 +0000
commit7adc587618773aa7be42ecfc957c2e62aaa91b45 (patch)
tree69300315ad84b6aed453eb1aeacffe49650a5c05 /dev-lang/ocaml
parent3.3.0 final (Manifest recommit) (diff)
downloadgentoo-2-7adc587618773aa7be42ecfc957c2e62aaa91b45.tar.gz
gentoo-2-7adc587618773aa7be42ecfc957c2e62aaa91b45.tar.bz2
gentoo-2-7adc587618773aa7be42ecfc957c2e62aaa91b45.zip
Version bump.
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog7
-rw-r--r--dev-lang/ocaml/Manifest2
-rw-r--r--dev-lang/ocaml/files/digest-ocaml-3.08.11
-rw-r--r--dev-lang/ocaml/ocaml-3.08.1.ebuild81
4 files changed, 90 insertions, 1 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 59f292e281a6..a65c475c0777 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.45 2004/08/18 19:39:28 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.46 2004/08/19 14:47:29 mattam Exp $
+
+*ocaml-3.08.1 (19 Aug 2004)
+
+ 19 Aug 2004; Matthieu Sozeau <mattam@gentoo.org> +ocaml-3.08.1.ebuild:
+ Version bump.
18 Aug 2004; Matthieu Sozeau <mattam@gentoo.org> ocaml-3.07-r1.ebuild,
ocaml-3.08.ebuild:
diff --git a/dev-lang/ocaml/Manifest b/dev-lang/ocaml/Manifest
index a4569d129eaf..d1dabfca3fbc 100644
--- a/dev-lang/ocaml/Manifest
+++ b/dev-lang/ocaml/Manifest
@@ -1,10 +1,12 @@
MD5 b7ca52388a8e7a6b9d68670176d389cf ChangeLog 7535
MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
MD5 a345c82ec2955b8bd3d3bbe3fadabe62 ocaml-3.06-r2.ebuild 1660
+MD5 e47d2ae7a48b2def2070a3cb4299da0b ocaml-3.08.1.ebuild 2126
MD5 4428b19ad5871c85adbaa17ae3b5faaa ocaml-3.07-r1.ebuild 2878
MD5 e18dd8c94164ddcb782c026b121c2c3f ocaml-3.08.ebuild 2177
MD5 d996b9a852fbfcb0c2d9bddb4896add2 files/ocaml-rebuild.sh 1228
MD5 77519cb4017543f060a963387b593299 files/digest-ocaml-3.08 65
+MD5 3854a7d6aaedc7d5fde7239776cec5cf files/digest-ocaml-3.08.1 66
MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r2 63
MD5 c42de320103c2d3eb1aa4002e2e0716b files/digest-ocaml-3.07-r1 130
MD5 91579cecf8659312c2324d8d40709433 files/ocaml-3.06-sparc-configure.patch 1660
diff --git a/dev-lang/ocaml/files/digest-ocaml-3.08.1 b/dev-lang/ocaml/files/digest-ocaml-3.08.1
new file mode 100644
index 000000000000..a1b51298cc9d
--- /dev/null
+++ b/dev-lang/ocaml/files/digest-ocaml-3.08.1
@@ -0,0 +1 @@
+MD5 dbe9defdf7491854e8ec852bee367307 ocaml-3.08.1.tar.bz2 2050084
diff --git a/dev-lang/ocaml/ocaml-3.08.1.ebuild b/dev-lang/ocaml/ocaml-3.08.1.ebuild
new file mode 100644
index 000000000000..2f638dcf598f
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.08.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.1.ebuild,v 1.1 2004/08/19 14:47:29 mattam Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
+HOMEPAGE="http://www.ocaml.org/"
+
+SRC_URI="http://caml.inria.fr/distrib/ocaml-3.08/${P}.tar.bz2"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~ia64 ~amd64 ~hppa ~macos"
+IUSE="tcltk latex"
+
+DEPEND="virtual/libc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
+
+pkg_setup() {
+ ewarn
+ ewarn "Building ocaml with unsafe CFLAGS can have unexpected results"
+ ewarn "Please retry building with safer CFLAGS before reporting bugs"
+ ewarn
+}
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ local myconf
+ use tcltk || myconf="-no-tk"
+
+ # Fix for bug #23767.
+ if [ "${ARCH}" = "sparc" ]; then
+ myconf="${myconf} -host sparc-unknown-linux-gnu"
+ fi
+
+ # Fix for bug #46703
+ export LC_ALL=C
+
+ ./configure -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/lib/ocaml \
+ -mandir /usr/share/man \
+ --with-pthread ${myconf} || die
+
+ sed -i -e "s/\(BYTECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
+ sed -i -e "s/\(NATIVECCCOMPOPTS=.*\)/\1 ${CFLAGS}/" config/Makefile
+
+ make world || die
+ make opt || die
+ make opt.opt || die
+}
+
+src_install() {
+ make BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/lib/ocaml \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ # silly, silly makefiles
+ dosed "s:${D}::g" /usr/lib/ocaml/ld.conf
+
+ # documentation
+ dodoc Changes INSTALL LICENSE README Upgrading
+}
+
+pkg_postinst() {
+ if use latex; then
+ echo "TEXINPUTS=/usr/lib/ocaml/ocamldoc:" > /etc/env.d/99ocamldoc
+ fi
+
+ echo
+ einfo "OCaml is not binary compatible from version to version,"
+ einfo "so you (may) need to rebuild all packages depending on it that"
+ einfo "are actually installed on your system."
+ einfo "To do so, you can run: "
+ einfo "sh ${FILESDIR}/ocaml-rebuild.sh [-h | emerge options]"
+ einfo "Which will call emerge on all old packages with the given options"
+ echo
+}