summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-21 20:28:27 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-21 20:28:27 +0000
commit4b8e0fb982addf1e3b806f8908c39f8874274ab1 (patch)
tree7c32a1746c26ac83b086aa51eac77b83bb0a5ef7 /dev-lang/mono-basic
parentVersion bump, thanks to Timo Gurr <psy@monsterserver.de> in bug #182779 (diff)
downloadgentoo-2-4b8e0fb982addf1e3b806f8908c39f8874274ab1.tar.gz
gentoo-2-4b8e0fb982addf1e3b806f8908c39f8874274ab1.tar.bz2
gentoo-2-4b8e0fb982addf1e3b806f8908c39f8874274ab1.zip
dev-lang/mono-basic: version bump (1.2.4), ebuild code cleanup, fixed mono dependency (bug #182805)
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-lang/mono-basic')
-rw-r--r--dev-lang/mono-basic/ChangeLog10
-rw-r--r--dev-lang/mono-basic/files/digest-mono-basic-1.2.43
-rw-r--r--dev-lang/mono-basic/mono-basic-1.2.3.ebuild12
-rw-r--r--dev-lang/mono-basic/mono-basic-1.2.4.ebuild34
4 files changed, 52 insertions, 7 deletions
diff --git a/dev-lang/mono-basic/ChangeLog b/dev-lang/mono-basic/ChangeLog
index 31fc042a983a..6119e9fe9c7e 100644
--- a/dev-lang/mono-basic/ChangeLog
+++ b/dev-lang/mono-basic/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/mono-basic
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono-basic/ChangeLog,v 1.2 2007/04/07 22:50:55 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono-basic/ChangeLog,v 1.3 2007/06/21 20:28:27 jurek Exp $
+
+*mono-basic-1.2.4 (21 Jun 2007)
+
+ 21 Jun 2007; Jurek Bartuszek <jurek@gentoo.org> mono-basic-1.2.3.ebuild,
+ +mono-basic-1.2.4.ebuild:
+ - Version bump (1.2.4)
+ - Ebuild coding style cleanup
+ - Fixed mono dependency (fixing bug #182805)
07 Apr 2007; Saleem Abdulrasool <compnerd@gentoo.org>
mono-basic-1.2.3.ebuild:
diff --git a/dev-lang/mono-basic/files/digest-mono-basic-1.2.4 b/dev-lang/mono-basic/files/digest-mono-basic-1.2.4
new file mode 100644
index 000000000000..0ed0bd052465
--- /dev/null
+++ b/dev-lang/mono-basic/files/digest-mono-basic-1.2.4
@@ -0,0 +1,3 @@
+MD5 9d159451f6636d9003f7ac4f92c07ecc mono-basic-1.2.4.tar.bz2 955950
+RMD160 d00f7ae3d2e6bfa1ade9d188d6eea8f0edd6a124 mono-basic-1.2.4.tar.bz2 955950
+SHA256 8709e7ae4b9eebc727844b04f36c4509a98c245e70787fe2ff63825a8d75e48f mono-basic-1.2.4.tar.bz2 955950
diff --git a/dev-lang/mono-basic/mono-basic-1.2.3.ebuild b/dev-lang/mono-basic/mono-basic-1.2.3.ebuild
index eeed861ffc71..50a030e419d0 100644
--- a/dev-lang/mono-basic/mono-basic-1.2.3.ebuild
+++ b/dev-lang/mono-basic/mono-basic-1.2.3.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono-basic/mono-basic-1.2.3.ebuild,v 1.2 2007/04/07 22:50:55 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono-basic/mono-basic-1.2.3.ebuild,v 1.3 2007/06/21 20:28:27 jurek Exp $
inherit mono multilib
DESCRIPTION="Visual Basic .NET Runtime and Class Libraries"
HOMEPAGE="http://www.go-mono.com"
-SRC_URI="http://go-mono.com/sources/${PN}/${PN}-${PV}.tar.gz"
+SRC_URI="http://go-mono.com/sources/${PN}/${P}.tar.gz"
LICENSE="|| ( GPL-2 LGPL-2 X11 )"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-RDEPEND=">=dev-lang/mono-1.2.3"
+RDEPEND="=dev-lang/mono-${PV}*"
DEPEND="${RDEPEND}"
src_unpack() {
@@ -25,10 +25,10 @@ src_unpack() {
}
src_compile() {
- ./configure --prefix=/usr || die "configure failed"
- make || die "make failed"
+ econf || die "configure failed"
+ emake || die "make failed"
}
src_install() {
- make DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" install || die "install failed"
}
diff --git a/dev-lang/mono-basic/mono-basic-1.2.4.ebuild b/dev-lang/mono-basic/mono-basic-1.2.4.ebuild
new file mode 100644
index 000000000000..843a15f9dde8
--- /dev/null
+++ b/dev-lang/mono-basic/mono-basic-1.2.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono-basic/mono-basic-1.2.4.ebuild,v 1.1 2007/06/21 20:28:27 jurek Exp $
+
+inherit mono multilib
+
+DESCRIPTION="Visual Basic .NET Runtime and Class Libraries"
+HOMEPAGE="http://www.go-mono.com"
+SRC_URI="http://go-mono.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 LGPL-2 X11 )"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/mono-${PV}*"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i -e "s|\(mono_libdir=\${exec_prefix}\)/lib|\1/$(get_libdir)|" \
+ configure || die "sed failed"
+}
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}