summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-05-23 15:45:28 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-05-23 15:45:28 +0000
commitb02f8e0ff3b88b2139667d37ebd063efa372d3c6 (patch)
tree7e083c044a9b954c3bc7309065e5800c09c96019 /dev-lang/mlton
parentRemove old. (diff)
downloadgentoo-2-b02f8e0ff3b88b2139667d37ebd063efa372d3c6.tar.gz
gentoo-2-b02f8e0ff3b88b2139667d37ebd063efa372d3c6.tar.bz2
gentoo-2-b02f8e0ff3b88b2139667d37ebd063efa372d3c6.zip
Remove old.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-lang/mlton')
-rw-r--r--dev-lang/mlton/ChangeLog8
-rw-r--r--dev-lang/mlton/files/mlton-20100608-gmp-const.patch31
-rw-r--r--dev-lang/mlton/mlton-20100608.ebuild66
3 files changed, 6 insertions, 99 deletions
diff --git a/dev-lang/mlton/ChangeLog b/dev-lang/mlton/ChangeLog
index 01f1df5c5936..050bf32a449b 100644
--- a/dev-lang/mlton/ChangeLog
+++ b/dev-lang/mlton/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/mlton
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mlton/ChangeLog,v 1.15 2014/01/15 08:13:28 gienah Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mlton/ChangeLog,v 1.16 2015/05/23 15:45:27 mrueg Exp $
+
+ 23 May 2015; Manuel Rüger <mrueg@gentoo.org>
+ -files/mlton-20100608-gmp-const.patch, -mlton-20100608.ebuild:
+ Remove old.
*mlton-20130715 (15 Jan 2014)
diff --git a/dev-lang/mlton/files/mlton-20100608-gmp-const.patch b/dev-lang/mlton/files/mlton-20100608-gmp-const.patch
deleted file mode 100644
index df95704e8dcf..000000000000
--- a/dev-lang/mlton/files/mlton-20100608-gmp-const.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- mlton-20100608-orig/runtime/gc/int-inf.c 2010-06-11 23:35:14.000000000 +1000
-+++ mlton-20100608/runtime/gc/int-inf.c 2013-04-25 16:45:45.528297232 +1000
-@@ -177,8 +177,8 @@
-
- static inline objptr binary (objptr lhs, objptr rhs, size_t bytes,
- void(*binop)(__mpz_struct *resmpz,
-- __gmp_const __mpz_struct *lhsspace,
-- __gmp_const __mpz_struct *rhsspace)) {
-+ const __mpz_struct *lhsspace,
-+ const __mpz_struct *rhsspace)) {
- __mpz_struct lhsmpz, rhsmpz, resmpz;
- mp_limb_t lhsspace[LIMBS_PER_OBJPTR + 1], rhsspace[LIMBS_PER_OBJPTR + 1];
-
-@@ -254,7 +254,7 @@
-
- static objptr unary (objptr arg, size_t bytes,
- void(*unop)(__mpz_struct *resmpz,
-- __gmp_const __mpz_struct *argspace)) {
-+ const __mpz_struct *argspace)) {
- __mpz_struct argmpz, resmpz;
- mp_limb_t argspace[LIMBS_PER_OBJPTR + 1];
-
-@@ -280,7 +280,7 @@
-
- static objptr shary (objptr arg, Word32_t shift, size_t bytes,
- void(*shop)(__mpz_struct *resmpz,
-- __gmp_const __mpz_struct *argspace,
-+ const __mpz_struct *argspace,
- unsigned long shift))
- {
- __mpz_struct argmpz, resmpz;
diff --git a/dev-lang/mlton/mlton-20100608.ebuild b/dev-lang/mlton/mlton-20100608.ebuild
deleted file mode 100644
index 5f52dbb16670..000000000000
--- a/dev-lang/mlton/mlton-20100608.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mlton/mlton-20100608.ebuild,v 1.3 2013/04/25 07:27:21 gienah Exp $
-
-inherit base eutils
-
-DESCRIPTION="Standard ML optimizing compiler and libraries"
-BASE_URI="mirror://sourceforge/${PN}"
-SRC_URI="!binary? ( ${BASE_URI}/${P}.src.tgz )
- binary? ( amd64? ( ${BASE_URI}/${P}-1.amd64-linux.static.tgz )
- x86? ( ${BASE_URI}/${P}-1.x86-linux.static.tgz ) )"
-
-HOMEPAGE="http://www.mlton.org"
-
-LICENSE="HPND MIT"
-SLOT="0"
-# there is support for ppc64 and ia64, but no
-# binaries are provided and there is no native
-# code generation for these platforms
-KEYWORDS="-* ~amd64 ~x86"
-IUSE="binary doc"
-
-DEPEND="dev-libs/gmp
- doc? ( virtual/latex-base )"
-RDEPEND="dev-libs/gmp"
-
-QA_PRESTRIPPED="binary? (
- usr/bin/mlnlffigen
- usr/bin/mllex
- usr/bin/mlprof
- usr/bin/mlyacc
- usr/lib/mlton/mlton-compile
-)"
-
-# Fix Bug 452558 - dev-lang/mlton-20100608 fails to build, unknown type name '__gmp_const'
-# Fixed by upstream: https://github.com/MLton/mlton/commit/a658a1f4a76a01f568116598800f49b80cf8ee1a
-PATCHES=("${FILESDIR}/${P}-gmp-const.patch")
-
-src_compile() {
- if use !binary; then
- has_version dev-lang/mlton || die "emerge with binary use flag first"
-
- # Fix location in which to install man pages
- sed -i 's@^MAN_PREFIX_EXTRA :=.*@MAN_PREFIX_EXTRA := /share@' \
- Makefile || die 'sed Makefile failed'
-
- # Does not support parallel make
- emake -j1 all-no-docs || die
- if use doc; then
- export VARTEXFONTS="${T}/fonts"
- emake docs || die "failed to create documentation"
- fi
- fi
-}
-
-src_install() {
- if use binary; then
- # Fix location in which to install man pages
- mv "${WORKDIR}/usr/man" "${WORKDIR}/usr/share" || die "mv man failed"
-
- mv "${WORKDIR}/usr" "${D}" || die "mv failed"
- else
- emake DESTDIR="${D}" install-no-docs || die
- if use doc; then emake DESTDIR="${D}" TDOC="${D}"/usr/share/doc/${P} install-docs || die; fi
- fi
-}