summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2015-02-22 16:37:48 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2015-02-22 16:37:48 +0000
commit68cb3ead33392c81b29ae751d560767626adaad5 (patch)
tree6ac1afb7af9e5bdc4043101e18c0218481452854 /dev-lang/jimtcl
parentVersion bump. Install with -j1 so we can workaround build system issues (diff)
downloadgentoo-2-68cb3ead33392c81b29ae751d560767626adaad5.tar.gz
gentoo-2-68cb3ead33392c81b29ae751d560767626adaad5.tar.bz2
gentoo-2-68cb3ead33392c81b29ae751d560767626adaad5.zip
version bump
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x09BF4F54C2BA7F3C!)
Diffstat (limited to 'dev-lang/jimtcl')
-rw-r--r--dev-lang/jimtcl/ChangeLog9
-rw-r--r--dev-lang/jimtcl/jimtcl-0.76.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/dev-lang/jimtcl/ChangeLog b/dev-lang/jimtcl/ChangeLog
index 304d686aa57c..21bfa4c45bd6 100644
--- a/dev-lang/jimtcl/ChangeLog
+++ b/dev-lang/jimtcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/jimtcl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/ChangeLog,v 1.15 2014/08/14 01:45:51 vapier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/ChangeLog,v 1.16 2015/02/22 16:37:48 hwoarang Exp $
+
+*jimtcl-0.76 (22 Feb 2015)
+
+ 22 Feb 2015; Markos Chandras <hwoarang@gentoo.org> +jimtcl-0.76.ebuild:
+ version bump
*jimtcl-0.75-r1 (14 Aug 2014)
diff --git a/dev-lang/jimtcl/jimtcl-0.76.ebuild b/dev-lang/jimtcl/jimtcl-0.76.ebuild
new file mode 100644
index 000000000000..e7426c37fd8f
--- /dev/null
+++ b/dev-lang/jimtcl/jimtcl-0.76.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jimtcl/jimtcl-0.76.ebuild,v 1.1 2015/02/22 16:37:48 hwoarang Exp $
+
+EAPI="5"
+
+inherit multiprocessing eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="http://repo.or.cz/r/jimtcl.git"
+ inherit git-2
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/msteveb/jimtcl/zipball/${PV} -> ${P}.zip"
+ KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~s390 ~sh ~x86"
+fi
+
+DESCRIPTION="Small footprint implementation of Tcl programming language"
+HOMEPAGE="http://jim.tcl.tk/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-text/asciidoc )
+ app-arch/unzip"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git-2_src_unpack
+ else
+ default
+ cd "${WORKDIR}"/msteveb-jimtcl-*
+ S=${PWD}
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.75-bootstrap.patch
+}
+
+src_configure() {
+ multijob_init
+ CCACHE=None multijob_child_init econf --with-jim-shared
+ if use static-libs ; then
+ # The build does not support doing both simultaneously.
+ mkdir static-libs
+ cd static-libs
+ CCACHE=None ECONF_SOURCE=${S} multijob_child_init econf
+ fi
+ multijob_finish
+}
+
+src_compile() {
+ # Must build static-libs first.
+ use static-libs && emake -C static-libs libjim.a
+ emake all
+ use doc && emake docs
+}
+
+src_install() {
+ dobin jimsh
+ use static-libs && dolib.a static-libs/libjim.a
+ ln -sf libjim.so.* libjim.so
+ dolib.so libjim.so*
+ insinto /usr/include
+ doins jim.h jimautoconf.h jim-subcmd.h jim-signal.h \
+ jim-win32compat.h jim-eventloop.h jim-config.h
+ dodoc AUTHORS README TODO
+ use doc && dohtml Tcl.html
+}