summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-10-25 03:58:50 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-10-25 03:58:50 +0000
commit3686782168d6b516d18f4db295d7e4f0ebef70ec (patch)
treea84ea0c533bf428a7a882467aa3eab93859da43e /dev-lang/ispc
parentversion bump (diff)
downloadgentoo-2-3686782168d6b516d18f4db295d7e4f0ebef70ec.tar.gz
gentoo-2-3686782168d6b516d18f4db295d7e4f0ebef70ec.tar.bz2
gentoo-2-3686782168d6b516d18f4db295d7e4f0ebef70ec.zip
version bump
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/ChangeLog7
-rw-r--r--dev-lang/ispc/ispc-1.8.0.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-lang/ispc/ChangeLog b/dev-lang/ispc/ChangeLog
index 94d8de6ad59b..f7858305c3bf 100644
--- a/dev-lang/ispc/ChangeLog
+++ b/dev-lang/ispc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ispc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.17 2014/06/26 05:53:00 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.18 2014/10/25 03:58:50 ottxor Exp $
+
+*ispc-1.8.0 (25 Oct 2014)
+
+ 25 Oct 2014; Christoph Junghans <ottxor@gentoo.org> +ispc-1.8.0.ebuild:
+ version bump
26 Jun 2014; Christoph Junghans <ottxor@gentoo.org>
+files/ispc-1.7.0-llvm-version.patch, ispc-1.7.0.ebuild:
diff --git a/dev-lang/ispc/ispc-1.8.0.ebuild b/dev-lang/ispc/ispc-1.8.0.ebuild
new file mode 100644
index 000000000000..3c09749922da
--- /dev/null
+++ b/dev-lang/ispc/ispc-1.8.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.8.0.ebuild,v 1.1 2014/10/25 03:58:50 ottxor Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit toolchain-funcs python-any-r1
+
+DESCRIPTION="Intel SPMD Program Compiler"
+HOMEPAGE="http://ispc.github.com/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/ispc/ispc.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD BSD-2 UoI-NCSA"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ >=sys-devel/clang-3.0
+ >=sys-devel/llvm-3.0
+ "
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ sys-devel/bison
+ sys-devel/flex
+ "
+
+src_compile() {
+ sed -i '/^\t@/s/@//' Makefile || die
+ emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
+}
+
+src_install() {
+ dobin ispc
+ dodoc README.rst
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ docompress -x "/usr/share/doc/${PF}/examples"
+ doins -r examples/*
+ fi
+}