summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-08-21 12:39:53 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-08-21 12:39:53 +0000
commitfc7ce2637453e67eb38909e459c3b45aafd067b7 (patch)
tree9fc8a28fa548337fbe981a205cbe9f5c805e3305 /dev-lang/icc
parentVersion bump with a few fixes. Add short/long description for the package. (diff)
downloadgentoo-2-fc7ce2637453e67eb38909e459c3b45aafd067b7.tar.gz
gentoo-2-fc7ce2637453e67eb38909e459c3b45aafd067b7.tar.bz2
gentoo-2-fc7ce2637453e67eb38909e459c3b45aafd067b7.zip
Reinstate env.d file
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/icc')
-rw-r--r--dev-lang/icc/ChangeLog7
-rw-r--r--dev-lang/icc/icc-11.1.046-r1.ebuild89
2 files changed, 95 insertions, 1 deletions
diff --git a/dev-lang/icc/ChangeLog b/dev-lang/icc/ChangeLog
index 5c3298f91a5a..44a29019d8a7 100644
--- a/dev-lang/icc/ChangeLog
+++ b/dev-lang/icc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/icc
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.67 2009/08/19 07:53:54 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.68 2009/08/21 12:39:53 weaver Exp $
+
+*icc-11.1.046-r1 (21 Aug 2009)
+
+ 21 Aug 2009; Andrey Kislyuk <weaver@gentoo.org> +icc-11.1.046-r1.ebuild:
+ Reinstate env.d file
*icc-11.1.046 (19 Aug 2009)
diff --git a/dev-lang/icc/icc-11.1.046-r1.ebuild b/dev-lang/icc/icc-11.1.046-r1.ebuild
new file mode 100644
index 000000000000..35724cc12ad2
--- /dev/null
+++ b/dev-lang/icc/icc-11.1.046-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-11.1.046-r1.ebuild,v 1.1 2009/08/21 12:39:53 weaver Exp $
+
+EAPI="2"
+
+PID=1536
+PB=cproc
+DESCRIPTION="Intel C/C++ optimized compiler for Linux"
+HOMEPAGE="http://www.intel.com/software/products/compilers/clin/"
+
+###
+# everything below common to ifc and icc
+# no eclass: very likely to change for next versions
+###
+PACKAGEID="l_${PB}_p_${PV}"
+RELEASE="${PV:0:4}"
+BUILD="${PV:5:8}"
+SRC_URI="http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}.tgz"
+#SRC_URI="amd64? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}_intel64.tgz )
+# ia64? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}_ia64.tgz )
+# x86? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKAGEID}_ia32.tgz )"
+
+LICENSE="Intel-SDP"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="mirror strip binchecks"
+
+INSTALL_DIR="opt/intel/Compiler/${RELEASE}/${BUILD}"
+# these don't work, not sure why
+#QA_TEXTRELS="${INSTALL_DIR}"
+#QA_WX_LOAD="${INSTALL_DIR}"
+#QA_PRESTRIPPED="${INSTALL_DIR}"
+
+DEPEND="app-arch/rpm"
+RDEPEND="virtual/libstdc++
+ amd64? ( app-emulation/emul-linux-x86-compat )"
+
+S="${WORKDIR}/${PACKAGEID}"
+
+src_prepare() {
+ use amd64 || rm -f rpm/*x86_64.rpm
+ # debugger installed with dev-lang/idb
+ rm -f rpm/intel*idb*.rpm
+ # performance primitives installed with sci-libs/ipp
+ rm -f rpm/intel*ipp*.rpm
+ # math library installed with sci-libs/mkl
+ rm -f rpm/intel*mkl*.rpm
+}
+
+src_install() {
+ mkdir "${WORKDIR}/rpmdb"
+ # rpm open_wr's / but doesn't seem to do anything with it
+ addpredict /
+ rpm --install --nodeps --dbpath "${WORKDIR}/rpmdb" --prefix "${D}/${INSTALL_DIR}" rpm/*.rpm || die
+
+ find "${D}/${INSTALL_DIR}" -name '*.csh' | xargs sed -i "s|${D}|${ROOT}|" || die
+ find "${D}/${INSTALL_DIR}" -name '*.sh' | xargs sed -i "s|${D}|${ROOT}|" || die
+
+ ENV_FILE=05${PN}
+ MYARCH=""
+ if use amd64; then MYARCH=intel64; fi
+ if use ia64; then MYARCH=ia64; fi
+ if use x86; then MYARCH=ia32; fi
+
+ env - bash --noprofile --norc -c "source '${D}/${INSTALL_DIR}/bin/iccvars.sh' ${MYARCH}; env|egrep -v '(PWD|SHLVL|_)='" > ${ENV_FILE}
+ doenvd ${ENV_FILE} || die
+
+ # PROFILE_FILE=${PN}.sh
+ # echo "source ${ROOT}${INSTALL_DIR}/bin/iccvars.sh ${MYARCH}" >> ${PROFILE_FILE}
+ # exeinto /etc/profile.d; doexe ${PROFILE_FILE} || die
+
+ mkdir -p "${D}/opt/intel/licenses"
+}
+
+pkg_postinst() {
+ elog "${PN} requires a license file in order to run."
+ elog "To receive a restrictive non-commercial license, please register at:"
+ elog "http://www.intel.com/cd/software/products/asmo-na/eng/download/download/219771.htm"
+ elog "Read the website for more information on this license."
+ elog "Install the license file into ${ROOT}opt/intel/licenses"
+ elog
+ elog "The following packages provide components bundled with icc:"
+ elog "\t dev-lang/idb"
+ elog "\t sci-libs/ipp"
+ elog "\t sci-libs/mkl"
+}