summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-13 21:25:25 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-13 21:25:25 +0000
commitd8c8da97e448eef2e42b545d1404aea30406437a (patch)
tree3765dfa6ca358b6df2d743af2f52d7ec4478bfdc /dev-lang/icc
parentHandle to proaudio herd like dssi, use emake instead of make, fix typo in doc... (diff)
downloadgentoo-2-d8c8da97e448eef2e42b545d1404aea30406437a.tar.gz
gentoo-2-d8c8da97e448eef2e42b545d1404aea30406437a.tar.bz2
gentoo-2-d8c8da97e448eef2e42b545d1404aea30406437a.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang/icc')
-rw-r--r--dev-lang/icc/ChangeLog7
-rw-r--r--dev-lang/icc/icc-10.1.013.ebuild106
2 files changed, 112 insertions, 1 deletions
diff --git a/dev-lang/icc/ChangeLog b/dev-lang/icc/ChangeLog
index e5dd353e2883..27f55630f88c 100644
--- a/dev-lang/icc/ChangeLog
+++ b/dev-lang/icc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/icc
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.59 2008/02/26 10:33:35 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/ChangeLog,v 1.60 2008/03/13 21:25:25 bicatali Exp $
+
+*icc-10.1.013 (13 Mar 2008)
+
+ 13 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org> +icc-10.1.013.ebuild:
+ Version bump
26 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org> -icc-10.1.008.ebuild:
Removing incompatible version with gcc (see bug #201596)
diff --git a/dev-lang/icc/icc-10.1.013.ebuild b/dev-lang/icc/icc-10.1.013.ebuild
new file mode 100644
index 000000000000..fae954416bf6
--- /dev/null
+++ b/dev-lang/icc/icc-10.1.013.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/icc/icc-10.1.013.ebuild,v 1.1 2008/03/13 21:25:25 bicatali Exp $
+
+inherit rpm eutils check-reqs
+
+PID=964
+PB=cc
+PEXEC="icc icpc"
+DESCRIPTION="Intel C/C++ optimized compiler for Linux"
+HOMEPAGE="http://www.intel.com/software/products/compilers/clin/"
+
+###
+# everything below common to ifc and icc
+# no eclass: very likely to change for next versions
+###
+PACKID="l_${PB}_p_${PV}"
+KEYWORDS="~amd64 ~ia64 ~x86"
+SRC_COM="http://registrationcenter-download.intel.com/irc_nas/${PID}/${PACKID}"
+SRC_URI="amd64? ( ${SRC_COM}_intel64.tar.gz )
+ ia64? ( ${SRC_COM}_ia64.tar.gz )
+ x86? ( ${SRC_COM}_ia32.tar.gz )"
+
+LICENSE="Intel-SDP"
+SLOT="0"
+
+RESTRICT="test strip mirror"
+IUSE=""
+DEPEND=""
+RDEPEND="virtual/libstdc++
+ amd64? ( app-emulation/emul-linux-x86-compat )"
+
+pkg_setup() {
+ # Check if we have enough RAM and free diskspace
+ CHECKREQS_MEMORY="512"
+ local disk_req="300"
+ use amd64 && disk_req="400"
+ use ia64 && disk_req="350"
+ CHECKREQS_DISK_BUILD=${disk_req}
+ check_reqs
+}
+
+src_unpack() {
+ unpack ${A}
+ mv "${WORKDIR}"/l_* "${S}"
+ cd "${S}"
+
+ local ext=
+ use amd64 && ext=e
+ INSTALL_DIR=/opt/intel/${PB}${ext}/${PV}
+
+ # debugger installed with dev-lang/idb
+ rm -f data/intel*idb*.rpm
+
+ for x in data/intel*.rpm; do
+ einfo "Extracting $(basename ${x})..."
+ rpm_unpack "${S}/${x}" || die "rpm_unpack ${x} failed"
+ done
+
+ einfo "Fixing paths and tagging"
+ cd "${S}"/${INSTALL_DIR}/bin
+ sed -e "s|<INSTALLDIR>|${INSTALL_DIR}|g" \
+ -e 's|export -n IA32ROOT;||g' \
+ -i ${PEXEC} *sh \
+ || die "sed fixing shells and paths failed"
+
+ cd "${S}"/${INSTALL_DIR}/doc
+ sed -e "s|\<installpackageid\>|${PACKID}|g" \
+ -e "s|\<INSTALLTIMECOMBOPACKAGEID\>|${PACKID}|g" \
+ -i *support \
+ || die "sed support file failed"
+ chmod 644 *support
+}
+
+src_install() {
+ einfo "Copying files"
+ dodir ${INSTALL_DIR}
+ cp -pPR \
+ "${S}"/${INSTALL_DIR}/* \
+ "${D}"/${INSTALL_DIR}/ \
+ || die "Copying ${PN} failed"
+
+ local env_file=05${PN}
+ cat > ${env_file} <<-EOF
+ PATH=${INSTALL_DIR}/bin
+ ROOTPATH=${INSTALL_DIR}/bin
+ LDPATH=${INSTALL_DIR}/lib
+ MANPATH=${INSTALL_DIR}/man
+ EOF
+ doenvd ${env_file} || die "doenvd ${env_file} failed"
+}
+
+pkg_postinst () {
+ # remove left over from unpacking
+ rm -f "${ROOT}"/opt/intel/{intel_sdp_products.db,.*.log} \
+ || die "remove logs failed"
+
+ elog "Make sure you have recieved the a license for ${PN},"
+ elog "you cannot run ${PN} without a license file."
+ elog "To receive a non-commercial license, you need to register."
+ elog "Read the website for more information on this license:"
+ elog "${HOMEPAGE}"
+ elog "Then put the license file into ${ROOT}/opt/intel/licenses."
+ elog "\nTo use ${PN} issue first \n\tsource /etc/profile"
+ elog "Debugger is installed with dev-lang/idb"
+}