summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2005-08-02 02:21:35 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2005-08-02 02:21:35 +0000
commitfa797bc3984acb12b1de3f24a93357e8612f5a27 (patch)
treef5bc5354dae446b44b91304be1f54673fb64da85 /dev-lang/gwydion-dylan
parentNew revisions for remove '--includedir' to make sure the headers are in the r... (diff)
downloadgentoo-2-fa797bc3984acb12b1de3f24a93357e8612f5a27.tar.gz
gentoo-2-fa797bc3984acb12b1de3f24a93357e8612f5a27.tar.bz2
gentoo-2-fa797bc3984acb12b1de3f24a93357e8612f5a27.zip
Added the Gwydion-Dylan Compiler
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-lang/gwydion-dylan')
-rw-r--r--dev-lang/gwydion-dylan/ChangeLog11
-rw-r--r--dev-lang/gwydion-dylan/Manifest5
-rw-r--r--dev-lang/gwydion-dylan/files/20gwydion-dylan1
-rw-r--r--dev-lang/gwydion-dylan/files/50gwydion-dylan-gentoo.el6
-rw-r--r--dev-lang/gwydion-dylan/files/digest-gwydion-dylan-2.4.01
-rw-r--r--dev-lang/gwydion-dylan/gwydion-dylan-2.4.0.ebuild54
-rw-r--r--dev-lang/gwydion-dylan/metadata.xml19
7 files changed, 97 insertions, 0 deletions
diff --git a/dev-lang/gwydion-dylan/ChangeLog b/dev-lang/gwydion-dylan/ChangeLog
new file mode 100644
index 000000000000..49d875900f98
--- /dev/null
+++ b/dev-lang/gwydion-dylan/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-lang/gwydion-dylan
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gwydion-dylan/ChangeLog,v 1.1 2005/08/02 02:21:34 araujo Exp $
+
+*gwydion-dylan-2.4.0 (02 Aug 2005)
+
+ 02 Aug 2005; Luis F. Araujo <araujo@gentoo.org> +files/20gwydion-dylan,
+ +files/50gwydion-dylan-gentoo.el, +metadata.xml,
+ +gwydion-dylan-2.4.0.ebuild:
+ Added The Gwydion-Dylan Compiler for the Dylan Programming Language
+
diff --git a/dev-lang/gwydion-dylan/Manifest b/dev-lang/gwydion-dylan/Manifest
new file mode 100644
index 000000000000..1707fb33e8f4
--- /dev/null
+++ b/dev-lang/gwydion-dylan/Manifest
@@ -0,0 +1,5 @@
+MD5 1c0eb2cccd167bddbaab0772f46a92e3 gwydion-dylan-2.4.0.ebuild 1161
+MD5 c034ae089c5a4cfad038e5385b8c3916 metadata.xml 829
+MD5 b7d9302bac13e909d3ba5136c99c4d4b files/50gwydion-dylan-gentoo.el 209
+MD5 ce4153e4868f9a78d5954ef9acab89f5 files/20gwydion-dylan 16
+MD5 b56cf86c697276c98bcb6dc6b75efa5c files/digest-gwydion-dylan-2.4.0 72
diff --git a/dev-lang/gwydion-dylan/files/20gwydion-dylan b/dev-lang/gwydion-dylan/files/20gwydion-dylan
new file mode 100644
index 000000000000..7fff98f7bc69
--- /dev/null
+++ b/dev-lang/gwydion-dylan/files/20gwydion-dylan
@@ -0,0 +1 @@
+DYLANDIR="/usr"
diff --git a/dev-lang/gwydion-dylan/files/50gwydion-dylan-gentoo.el b/dev-lang/gwydion-dylan/files/50gwydion-dylan-gentoo.el
new file mode 100644
index 000000000000..b275ec9c829a
--- /dev/null
+++ b/dev-lang/gwydion-dylan/files/50gwydion-dylan-gentoo.el
@@ -0,0 +1,6 @@
+;;; gwydion-dylan site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'dylan-mode "dylan-mode" "Dylan-mode" t)
+(setq auto-mode-alist (cons '("\\.dylan\\'" . dylan-mode) auto-mode-alist))
diff --git a/dev-lang/gwydion-dylan/files/digest-gwydion-dylan-2.4.0 b/dev-lang/gwydion-dylan/files/digest-gwydion-dylan-2.4.0
new file mode 100644
index 000000000000..d23214062da9
--- /dev/null
+++ b/dev-lang/gwydion-dylan/files/digest-gwydion-dylan-2.4.0
@@ -0,0 +1 @@
+MD5 7ed180bf4ef11e8e8da3bd78b45477a8 gwydion-dylan-2.4.0.tar.gz 3623651
diff --git a/dev-lang/gwydion-dylan/gwydion-dylan-2.4.0.ebuild b/dev-lang/gwydion-dylan/gwydion-dylan-2.4.0.ebuild
new file mode 100644
index 000000000000..10bf62ea0137
--- /dev/null
+++ b/dev-lang/gwydion-dylan/gwydion-dylan-2.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gwydion-dylan/gwydion-dylan-2.4.0.ebuild,v 1.1 2005/08/02 02:21:34 araujo Exp $
+
+inherit elisp-common
+
+DESCRIPTION="The Dylan Programming Language Compiler"
+HOMEPAGE="http://www.gwydiondylan.org/"
+SRC_URI="http://www.gwydiondylan.org/downloads/src/tar/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gtk emacs"
+
+DEPEND="( || ( dev-lang/gwydion-dylan-bin
+ dev-lang/gwydion-dylan ) )
+ >=dev-libs/boehm-gc-6.4
+ gtk? ( =x11-libs/gtk+-1.2* )"
+RDEPEND=""
+
+SITEFILE=50gwydion-dylan-gentoo.el
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ $(use_with gtk) \
+ || die "./configure failed"
+ emake -j1 || die "emake failed"
+ if use emacs; then
+ elisp-compile ${S}/tools/elisp/*.el
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install \
+ || die "make failed"
+ if use emacs; then
+ elisp-install ${PN} ${S}/tools/elisp/*.el ${S}/tools/elisp/*.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ fi
+ insinto /etc/env.d
+ doins ${FILESDIR}/20gwydion-dylan
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-lang/gwydion-dylan/metadata.xml b/dev-lang/gwydion-dylan/metadata.xml
new file mode 100644
index 000000000000..542447934457
--- /dev/null
+++ b/dev-lang/gwydion-dylan/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>araujo@gentoo.org</email>
+<name>Luis F. Araujo</name>
+</maintainer>
+<longdescription lang="en">
+Dylan is an advanced, object-oriented, dynamic language which supports the rapid
+development of programs. When needed, the programmer can later optimize [his or
+her] programs for more efficient execution by supplying type information to the
+compiler. Nearly all entities in Dylan (including functions, classes, and basic
+data types such as integers) are first class objects. Additionally Dylan
+supports multiple inheritance, polymorphism, multiple dispatch, keyword
+arguments, object introspection, and many other advanced features.
+</longdescription>
+</pkgmetadata>
+