summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-07-27 15:33:17 +0000
committerJeroen Roovers <jer@gentoo.org>2010-07-27 15:33:17 +0000
commit1af1b916dffd3098a454d590dbfd8e74d47db0e4 (patch)
treed5c11663a187135e55fb8ecf8148314e8b5476c2 /dev-lang/gnu-smalltalk
parentUpdate to version that properly identifies itself as 0.23.1 (diff)
downloadgentoo-2-1af1b916dffd3098a454d590dbfd8e74d47db0e4.tar.gz
gentoo-2-1af1b916dffd3098a454d590dbfd8e74d47db0e4.tar.bz2
gentoo-2-1af1b916dffd3098a454d590dbfd8e74d47db0e4.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-lang/gnu-smalltalk')
-rw-r--r--dev-lang/gnu-smalltalk/ChangeLog7
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.1.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-lang/gnu-smalltalk/ChangeLog b/dev-lang/gnu-smalltalk/ChangeLog
index d04b79849225..3c3eba6d5a6a 100644
--- a/dev-lang/gnu-smalltalk/ChangeLog
+++ b/dev-lang/gnu-smalltalk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/gnu-smalltalk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.42 2010/05/06 16:11:07 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.43 2010/07/27 15:33:17 jer Exp $
+
+*gnu-smalltalk-3.2.1 (27 Jul 2010)
+
+ 27 Jul 2010; Jeroen Roovers <jer@gentoo.org> +gnu-smalltalk-3.2.1.ebuild:
+ Version bump.
06 May 2010; Víctor Ostorga <vostorga@gentoo.org>
gnu-smalltalk-3.2.ebuild:
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.1.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.1.ebuild
new file mode 100644
index 000000000000..a49d03726e44
--- /dev/null
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.1.ebuild,v 1.1 2010/07/27 15:33:17 jer Exp $
+
+EAPI="0"
+
+inherit elisp-common flag-o-matic eutils
+
+DESCRIPTION="GNU Smalltalk"
+HOMEPAGE="http://smalltalk.gnu.org"
+SRC_URI="http://ftp.gnu.org/gnu/smalltalk/smalltalk-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tk readline emacs gtk gmp"
+
+DEPEND="sys-libs/gdbm
+ sys-apps/debianutils
+ dev-libs/libsigsegv
+ virtual/libffi
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )
+ tk? ( dev-lang/tk )
+ gtk? ( =x11-libs/gtk+-2* )
+ gmp? ( dev-libs/gmp )"
+RDEPEND=""
+
+S="${WORKDIR}/smalltalk-${PV}"
+
+SITEFILE=50gnu-smalltalk-gentoo.el
+
+src_compile() {
+ replace-flags '-O3' '-O2'
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --with-system-libsigsegv \
+ --with-system-libffi \
+ --with-system-libltdl \
+ $(use_with emacs emacs) \
+ $(use_with readline readline) \
+ $(use_with gmp gmp) \
+ $(use_with tk tcl /usr/$(get_libdir)) \
+ $(use_with tk tk /usr/$(get_libdir)) \
+ $(use_enable gtk gtk)
+ emake || die "emake failed"
+ use emacs && elisp-compile *.el
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS COPYING* ChangeLog NEWS README THANKS TODO
+ if use emacs; then
+ elisp-install "${PN}" *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ fperms 0444 /usr/share/smalltalk/packages.xml
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}