summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-11 15:50:22 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-11 15:50:22 +0000
commit47be736f2475c2030ade6496917889bb3c5b35a9 (patch)
treeced3be95a7c8128668e03a7c44f71636c90962cc /dev-lang/ezm3/ezm3-1.2.ebuild
parentChange for Gnome dependencies. (Manifest recommit) (diff)
downloadgentoo-2-47be736f2475c2030ade6496917889bb3c5b35a9.tar.gz
gentoo-2-47be736f2475c2030ade6496917889bb3c5b35a9.tar.bz2
gentoo-2-47be736f2475c2030ade6496917889bb3c5b35a9.zip
ezm3!
Diffstat (limited to 'dev-lang/ezm3/ezm3-1.2.ebuild')
-rw-r--r--dev-lang/ezm3/ezm3-1.2.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/dev-lang/ezm3/ezm3-1.2.ebuild b/dev-lang/ezm3/ezm3-1.2.ebuild
new file mode 100644
index 000000000000..29cb693e3024
--- /dev/null
+++ b/dev-lang/ezm3/ezm3-1.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ezm3/ezm3-1.2.ebuild,v 1.1 2004/07/11 15:50:22 vapier Exp $
+
+inherit eutils
+
+MY_P="${P/-/-snap-}"
+EZM3="ezm3-1.1"
+EZM3_TARGET="LINUXLIBC6"
+
+DESCRIPTION="stripped down m3 compiler for building cvsup"
+HOMEPAGE="http://www.polstra.com/projects/freeware/ezm3/"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/development/CVSup/ezm3/${P}-src.tar.bz2
+ x86? ( ftp://ftp.freebsd.org/pub/FreeBSD/development/CVSup/ezm3/${P}-LINUXLIBC6-boot.tar.bz2 )
+ mirror://gentoo/${P}-PPC_LINUX.patch.bz2"
+# ppc? ( mirror://gentoo/${P}-PPC_LINUX-boot.tar.bz2 )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="-* x86 ppc"
+IUSE="X opengl static"
+
+DEPEND="virtual/libc
+ dev-util/yacc
+ >=sys-apps/sed-4
+ !virtual/m3"
+RDEPEND="virtual/libc"
+PROVIDE="virtual/m3"
+
+seduse() {
+ useq !${1} && echo "${2}" || echo ":"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${P}-PPC_LINUX.patch
+}
+
+src_compile() {
+ # when you do make, ezm3 builds & installs at the same time so we control
+ # where it is going to install the compiler and stuff
+ # (to not violate sandbox)
+ sed -i \
+ -e "s:/usr/local:/usr:" \
+ m3config/src/${EZM3_TARGET} \
+ || die "sed ${EZM3_TARGET} failed"
+ echo "M3CC_MAKE = [\"make\", \"BISON=yacc\"]" >> m3config/src/${EZM3_TARGET}
+
+ # now we disable X and OpenGL if the user doesnt have them in their USE var
+ sed -i \
+ -e "s:/usr/local:/usr:" \
+ -e "s:touch:ranlib:" \
+ -e "s:`seduse X 'import_X11():import_X11() is\nend\nproc dont_import_X11()'`:" \
+ -e "s:`seduse opengl 'import_OpenGL():import_OpenGL() is\nend\nproc dont_import_OpenGL()'`:" \
+ m3config/src/COMMON \
+ || die "sed COMMON failed"
+
+ # finally we compile the m3 compiler
+ # we clear the CFLAGS because:
+ # (1) higher optimizations cause issues
+ # (2) build system uses gcc-3.2.3 ... dont want to trigger CFLAG mismatches
+ # (3) it doesnt really matter ... we are just building cvsup ;)
+ # Remove P because it's used internally ;x
+ env -u P -u CFLAGS emake -j1 exportall || die "ezm3 compile failed"
+}
+
+src_install() {
+ cd binaries/${EZM3_TARGET}
+ cp -a usr ${D}/ || die
+ rm -rf ${D}/usr/man
+}