summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-03-09 23:43:05 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-03-09 23:43:05 +0000
commite2b346db749799c8c49b7fcf09ab912fa7bfc77d (patch)
tree120c69defaf4df7cd9bf60b350e6b72442d93f5e /dev-java
parentversion bump (diff)
downloadgentoo-2-e2b346db749799c8c49b7fcf09ab912fa7bfc77d.tar.gz
gentoo-2-e2b346db749799c8c49b7fcf09ab912fa7bfc77d.tar.bz2
gentoo-2-e2b346db749799c8c49b7fcf09ab912fa7bfc77d.zip
Clean room implementation to replace the broken version in
java-overlay. (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 9C6D7DE4)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jcip-annotations/ChangeLog9
-rw-r--r--dev-java/jcip-annotations/jcip-annotations-1.0.1.ebuild31
-rw-r--r--dev-java/jcip-annotations/metadata.xml6
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-java/jcip-annotations/ChangeLog b/dev-java/jcip-annotations/ChangeLog
new file mode 100644
index 000000000000..c7dbced9a5b5
--- /dev/null
+++ b/dev-java/jcip-annotations/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-java/jcip-annotations
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jcip-annotations/ChangeLog,v 1.1 2015/03/09 23:43:05 chewi Exp $
+
+*jcip-annotations-1.0.1 (09 Mar 2015)
+
+ 09 Mar 2015; James Le Cuirot <chewi@gentoo.org>
+ +jcip-annotations-1.0.1.ebuild, +metadata.xml:
+ Clean room implementation to replace the broken version in java-overlay.
diff --git a/dev-java/jcip-annotations/jcip-annotations-1.0.1.ebuild b/dev-java/jcip-annotations/jcip-annotations-1.0.1.ebuild
new file mode 100644
index 000000000000..3dc21abc24ea
--- /dev/null
+++ b/dev-java/jcip-annotations/jcip-annotations-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jcip-annotations/jcip-annotations-1.0.1.ebuild,v 1.1 2015/03/09 23:43:05 chewi Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit versionator java-pkg-2 java-pkg-simple
+
+MY_P="${PN}-$(replace_version_separator $(get_last_version_component_index) -)"
+
+DESCRIPTION="Clean room implementation of the JCIP Annotations"
+HOMEPAGE="https://github.com/stephenc/jcip-annotations"
+SRC_URI="https://github.com/stephenc//${PN}/archive/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND=">=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}-${MY_P}/src"
+JAVA_SRC_DIR="main/java"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc ../README.md
+}
diff --git a/dev-java/jcip-annotations/metadata.xml b/dev-java/jcip-annotations/metadata.xml
new file mode 100644
index 000000000000..9af6f5aab01f
--- /dev/null
+++ b/dev-java/jcip-annotations/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>The JCIP Annotations are really useful, however they are released under the Creative Commons Attribution License, which is not recommended for licensing software and may therefore cause issues for some people.</longdescription>
+</pkgmetadata>