summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-31 20:20:39 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-10-31 20:20:39 +0000
commit3cf95e9d0c708c521f32051534f484086b3be01f (patch)
tree3285c471be21f7b0b50de482c15af385b737c419 /dev-java
parentFixes #6091. (diff)
downloadgentoo-2-3cf95e9d0c708c521f32051534f484086b3be01f.tar.gz
gentoo-2-3cf95e9d0c708c521f32051534f484086b3be01f.tar.bz2
gentoo-2-3cf95e9d0c708c521f32051534f484086b3be01f.zip
Fixes #8529.
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/dom4j/ChangeLog9
-rw-r--r--dev-java/dom4j/dom4j-1.3.ebuild50
-rw-r--r--dev-java/dom4j/files/digest-dom4j-1.31
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-java/dom4j/ChangeLog b/dev-java/dom4j/ChangeLog
new file mode 100644
index 000000000000..11cbd33d2e42
--- /dev/null
+++ b/dev-java/dom4j/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-java/dom4j
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/dom4j/ChangeLog,v 1.1 2002/10/31 20:20:39 karltk Exp $
+
+*dom4j-1.3 (31 Oct 2002)
+
+ 31 Oct 2002; Karl Trygve Kalleberg <karltk@gentoo.org> dom4j-1.3.ebuild files/digest-dom4j :
+ Initial import. Ebuild submitted by Adrian Almenar
+ <aalmenar@conectium.com>.
diff --git a/dev-java/dom4j/dom4j-1.3.ebuild b/dev-java/dom4j/dom4j-1.3.ebuild
new file mode 100644
index 000000000000..5b54ca4d50fa
--- /dev/null
+++ b/dev-java/dom4j/dom4j-1.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-java/dom4j/dom4j-1.3.ebuild,v 1.1 2002/10/31 20:20:39 karltk Exp $
+
+S=${WORKDIR}/dom4j-${PV}
+DESCRIPTION="dom4j is an easy to use, open source library for working with XML, XPath and XSLT on the Java platform using the Java Collections Framework and with full support for DOM, SAX and JAXP."
+SRC_URI="mirror://sourceforge/dom4j/${P}.tar.gz"
+HOMEPAGE="http://dom4j.sourceforge.net"
+DEPEND=">=virtual/jdk-1.3"
+REDEPND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+IUSE=""
+
+src_compile() {
+ cd ${WORKDIR}/dom4j-patched-${PV}
+ sh build.sh || die "Compilation Failed"
+}
+
+src_install () {
+ cd ${WORKDIR}/dom4j-patched-${PV}
+ # If you need another jar change the name
+ # of the file in dojar to the one you need
+ dojar build/dom4j.jar
+ dohtml -r build/doc/*
+}
+
+pkg_postinst() {
+ einfo "dom4j creates 3 jar files:"
+ einfo "------------------------------------------------------------------"
+ einfo "dom4j-full.jar: this contains all the dom4j code, the XPath engine
+ and the interfaces for SAX and DOM. If in doubt use this JAR."
+
+ einfo "dom4j.jar this contains all the dom4j code and the XPath engine but
+ without the SAX or DOM interfaces. Usually the SAX and DOM
+ interfaces come bundled with a JAXP parser so if you are using
+ JAXP and crimson.jar or xerces.jar then dom4j.jar is the
+ recommended JAR to use."
+
+ einfo "dom4j-core.jar this contains all the dom4j code without the XPath
+ engine and the SAX and DOM interfaces. This JAR is intended
+ for developers who wish to keep the dom4j.jar and the jaxen.jar
+ JARs seperate."
+ einfo ">>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>"
+ einfo "We are actually copying dom4j.jar. If you need another jar please
+ feel free to modify the ebuild to fit your needs"
+ einfo ">>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>"
+
+}
diff --git a/dev-java/dom4j/files/digest-dom4j-1.3 b/dev-java/dom4j/files/digest-dom4j-1.3
new file mode 100644
index 000000000000..5bce8298167c
--- /dev/null
+++ b/dev-java/dom4j/files/digest-dom4j-1.3
@@ -0,0 +1 @@
+MD5 2d05858028d16af14a073f2f191f1ff7 dom4j-1.3.tar.gz 11577482