summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-05-03 20:45:45 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-05-03 20:45:45 +0000
commit02b6cd11e903d1a70ad0b3eb6c9da737f2217f05 (patch)
treed678b6bcaed45f8694a5693f83fbdcc648cf47d1 /dev-java
parentVersion bump to 1.0.11. (diff)
downloadgentoo-2-02b6cd11e903d1a70ad0b3eb6c9da737f2217f05.tar.gz
gentoo-2-02b6cd11e903d1a70ad0b3eb6c9da737f2217f05.tar.bz2
gentoo-2-02b6cd11e903d1a70ad0b3eb6c9da737f2217f05.zip
Version bump to 2.1.0.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/joni/ChangeLog10
-rw-r--r--dev-java/joni/joni-2.1.0.ebuild38
2 files changed, 45 insertions, 3 deletions
diff --git a/dev-java/joni/ChangeLog b/dev-java/joni/ChangeLog
index 50aa244188a7..22282226a3e7 100644
--- a/dev-java/joni/ChangeLog
+++ b/dev-java/joni/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/joni
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/joni/ChangeLog,v 1.11 2010/10/17 12:30:57 caster Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/joni/ChangeLog,v 1.12 2014/05/03 20:45:45 tomwij Exp $
+
+*joni-2.1.0 (03 May 2014)
+
+ 03 May 2014; Tom Wijsman <TomWij@gentoo.org> +joni-2.1.0.ebuild:
+ Version bump to 2.1.0.
17 Oct 2010; Vlastimil Babka <caster@gentoo.org> -joni-1.1.3.ebuild:
Remove old.
@@ -39,4 +44,3 @@
22 May 2009; Vlastimil Babka <caster@gentoo.org> +joni-1.1.3.ebuild,
+metadata.xml:
New package, jruby dependency. Ebuild provided by chewi in java-overlay.
-
diff --git a/dev-java/joni/joni-2.1.0.ebuild b/dev-java/joni/joni-2.1.0.ebuild
new file mode 100644
index 000000000000..2354a7abf0e4
--- /dev/null
+++ b/dev-java/joni/joni-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/joni/joni-2.1.0.ebuild,v 1.1 2014/05/03 20:45:45 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source"
+
+inherit base java-pkg-2 java-ant-2
+
+DESCRIPTION="Java port of the Oniguruma regular expression engine"
+HOMEPAGE="http://jruby.codehaus.org/"
+SRC_URI="https://github.com/jruby/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+CDEPEND="dev-java/asm:3
+ dev-java/jcodings:1"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5"
+
+S="${WORKDIR}/${PN}-${PN}-${PV}"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_BUILD_TARGET="build"
+EANT_GENTOO_CLASSPATH="asm-3 jcodings-1"
+
+src_install() {
+ java-pkg_dojar target/${PN}.jar
+
+ use source && java-pkg_dosrc src/*
+}