summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-07-17 01:40:23 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-07-17 01:40:23 +0000
commit71db2d1a7810b9a3a23364d42405c7bc63a0d24f (patch)
tree3d3316f1e32a5b9aee32d31069f5a3e5daf1fa7c /dev-java/swt
parent2.1.1_pre3-r1 revbump. This fixes bugs #37124 and #140694. (diff)
downloadgentoo-2-71db2d1a7810b9a3a23364d42405c7bc63a0d24f.tar.gz
gentoo-2-71db2d1a7810b9a3a23364d42405c7bc63a0d24f.tar.bz2
gentoo-2-71db2d1a7810b9a3a23364d42405c7bc63a0d24f.zip
version bump from upstream, dropping mozilla support for seamonkey
(Portage version: 2.1.1_pre3)
Diffstat (limited to 'dev-java/swt')
-rw-r--r--dev-java/swt/ChangeLog10
-rw-r--r--dev-java/swt/files/SWTMessages.properties1
-rw-r--r--dev-java/swt/files/digest-swt-3.29
-rw-r--r--dev-java/swt/files/swt-3.2-cairo-signedness.patch11
-rw-r--r--dev-java/swt/files/swt-3.2-gcc-4.x-warning-fix.patch65
-rw-r--r--dev-java/swt/swt-3.2.ebuild167
6 files changed, 262 insertions, 1 deletions
diff --git a/dev-java/swt/ChangeLog b/dev-java/swt/ChangeLog
index fe4780317763..9e0eb89ae6ba 100644
--- a/dev-java/swt/ChangeLog
+++ b/dev-java/swt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-java/swt
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.34 2006/05/07 07:07:09 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.35 2006/07/17 01:40:23 compnerd Exp $
+
+*swt-3.2 (17 Jul 2006)
+
+ 17 Jul 2006; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/swt-3.2-cairo-signedness.patch,
+ +files/swt-3.2-gcc-4.x-warning-fix.patch, files/SWTMessages.properties,
+ +swt-3.2.ebuild:
+ Version bump from upstream, dropping mozilla support in favor of seamonkey
*swt-3.2_rc2 (07 May 2006)
diff --git a/dev-java/swt/files/SWTMessages.properties b/dev-java/swt/files/SWTMessages.properties
index d3f061bf0ba2..e7fdf88e62db 100644
--- a/dev-java/swt/files/SWTMessages.properties
+++ b/dev-java/swt/files/SWTMessages.properties
@@ -66,6 +66,7 @@ SWT_Minimize=Minimize
SWT_Maximize=Maximize
SWT_Restore=Restore
SWT_ShowList=Show List
+SWT_FileDownload=File Download
SWT_Download_File=Download: {0}
SWT_Download_Location=Saving {0} from {1}
SWT_Download_Started=Downloading...
diff --git a/dev-java/swt/files/digest-swt-3.2 b/dev-java/swt/files/digest-swt-3.2
new file mode 100644
index 000000000000..f8f121537b2f
--- /dev/null
+++ b/dev-java/swt/files/digest-swt-3.2
@@ -0,0 +1,9 @@
+MD5 7128a79bbc837626d07f2c7264e784aa swt-3.2-gtk-linux-ppc.zip 2913359
+RMD160 558cddfbd3fb32091908c23a26db4f153bf36510 swt-3.2-gtk-linux-ppc.zip 2913359
+SHA256 13cda631e4ec522c9d10aa2edb5a38f104e40ad1f67f94513f932a9193167062 swt-3.2-gtk-linux-ppc.zip 2913359
+MD5 2cba80d9bd247fd6985509d96c1540cd swt-3.2-gtk-linux-x86.zip 2935209
+RMD160 d9560445852020e7d755594c60ba01c7904b9924 swt-3.2-gtk-linux-x86.zip 2935209
+SHA256 05701ceb02a4099e035571abb0d005947758de48c47b49cd38a5b3fd5670a13c swt-3.2-gtk-linux-x86.zip 2935209
+MD5 e373d904a4f67322b0c1419c22285a5b swt-3.2-gtk-linux-x86_64.zip 2841135
+RMD160 8764b1357a23a530c9e523b6f1364a7b7abfea01 swt-3.2-gtk-linux-x86_64.zip 2841135
+SHA256 fb00c97c488353a10d7842a50b9184851e90870c3ec1b0ee3bfa838e6ac9a665 swt-3.2-gtk-linux-x86_64.zip 2841135
diff --git a/dev-java/swt/files/swt-3.2-cairo-signedness.patch b/dev-java/swt/files/swt-3.2-cairo-signedness.patch
new file mode 100644
index 000000000000..a05a18768a41
--- /dev/null
+++ b/dev-java/swt/files/swt-3.2-cairo-signedness.patch
@@ -0,0 +1,11 @@
+--- cairo.c.orig 2006-07-16 19:16:27.000000000 -0500
++++ cairo.c 2006-07-16 19:18:15.000000000 -0500
+@@ -533,7 +533,7 @@
+ {
+ jint rc = 0;
+ Cairo_NATIVE_ENTER(env, that, cairo_1image_1surface_1create_1for_1data_FUNC);
+- rc = (jint)cairo_image_surface_create_for_data((char *)arg0, arg1, arg2, arg3, arg4);
++ rc = (jint)cairo_image_surface_create_for_data((unsigned char *)arg0, arg1, arg2, arg3, arg4);
+ Cairo_NATIVE_EXIT(env, that, cairo_1image_1surface_1create_1for_1data_FUNC);
+ return rc;
+ }
diff --git a/dev-java/swt/files/swt-3.2-gcc-4.x-warning-fix.patch b/dev-java/swt/files/swt-3.2-gcc-4.x-warning-fix.patch
new file mode 100644
index 000000000000..afa12e7f95fe
--- /dev/null
+++ b/dev-java/swt/files/swt-3.2-gcc-4.x-warning-fix.patch
@@ -0,0 +1,65 @@
+--- src/os.c 2006-07-16 17:14:17.000000000 -0500
++++ src/os.c 2006-07-16 17:16:04.000000000 -0500
+@@ -2618,7 +2618,7 @@
+ OS_NATIVE_ENTER(env, that, _1g_1object_1get_FUNC);
+ if (arg1) if ((lparg1 = (*env)->GetByteArrayElements(env, arg1, NULL)) == NULL) goto fail;
+ if (arg2) if ((lparg2 = (*env)->GetIntArrayElements(env, arg2, NULL)) == NULL) goto fail;
+- g_object_get((GObject *)arg0, (const gchar *)lparg1, lparg2, arg3);
++ g_object_get((GObject *)arg0, (const gchar *)lparg1, lparg2, arg3, (char *)NULL);
+ fail:
+ if (arg2 && lparg2) (*env)->ReleaseIntArrayElements(env, arg2, lparg2, 0);
+ if (arg1 && lparg1) (*env)->ReleaseByteArrayElements(env, arg1, lparg1, JNI_ABORT);
+@@ -2669,7 +2669,7 @@
+ jbyte *lparg1=NULL;
+ OS_NATIVE_ENTER(env, that, _1g_1object_1set__I_3BFI_FUNC);
+ if (arg1) if ((lparg1 = (*env)->GetByteArrayElements(env, arg1, NULL)) == NULL) goto fail;
+- g_object_set((gpointer)arg0, (const gchar *)lparg1, arg2, arg3);
++ g_object_set((gpointer)arg0, (const gchar *)lparg1, arg2, arg3, (char *)NULL);
+ fail:
+ if (arg1 && lparg1) (*env)->ReleaseByteArrayElements(env, arg1, lparg1, JNI_ABORT);
+ OS_NATIVE_EXIT(env, that, _1g_1object_1set__I_3BFI_FUNC);
+@@ -2683,7 +2683,7 @@
+ jbyte *lparg1=NULL;
+ OS_NATIVE_ENTER(env, that, _1g_1object_1set__I_3BII_FUNC);
+ if (arg1) if ((lparg1 = (*env)->GetByteArrayElements(env, arg1, NULL)) == NULL) goto fail;
+- g_object_set((gpointer)arg0, (const gchar *)lparg1, arg2, arg3);
++ g_object_set((gpointer)arg0, (const gchar *)lparg1, arg2, arg3, (char *)NULL);
+ fail:
+ if (arg1 && lparg1) (*env)->ReleaseByteArrayElements(env, arg1, lparg1, JNI_ABORT);
+ OS_NATIVE_EXIT(env, that, _1g_1object_1set__I_3BII_FUNC);
+@@ -2697,7 +2697,7 @@
+ jbyte *lparg1=NULL;
+ OS_NATIVE_ENTER(env, that, _1g_1object_1set__I_3BJI_FUNC);
+ if (arg1) if ((lparg1 = (*env)->GetByteArrayElements(env, arg1, NULL)) == NULL) goto fail;
+- g_object_set((gpointer)arg0, (const gchar *)lparg1, arg2, arg3);
++ g_object_set((gpointer)arg0, (const gchar *)lparg1, arg2, arg3, (char *)NULL);
+ fail:
+ if (arg1 && lparg1) (*env)->ReleaseByteArrayElements(env, arg1, lparg1, JNI_ABORT);
+ OS_NATIVE_EXIT(env, that, _1g_1object_1set__I_3BJI_FUNC);
+@@ -2711,7 +2711,7 @@
+ jbyte *lparg1=NULL;
+ OS_NATIVE_ENTER(env, that, _1g_1object_1set__I_3BZI_FUNC);
+ if (arg1) if ((lparg1 = (*env)->GetByteArrayElements(env, arg1, NULL)) == NULL) goto fail;
+- g_object_set((gpointer)arg0, (const gchar *)lparg1, arg2, arg3);
++ g_object_set((gpointer)arg0, (const gchar *)lparg1, arg2, arg3, (char *)NULL);
+ fail:
+ if (arg1 && lparg1) (*env)->ReleaseByteArrayElements(env, arg1, lparg1, JNI_ABORT);
+ OS_NATIVE_EXIT(env, that, _1g_1object_1set__I_3BZI_FUNC);
+@@ -12197,7 +12197,7 @@
+ OS_NATIVE_ENTER(env, that, _1gtk_1widget_1style_1get__I_3B_3II_FUNC);
+ if (arg1) if ((lparg1 = (*env)->GetByteArrayElements(env, arg1, NULL)) == NULL) goto fail;
+ if (arg2) if ((lparg2 = (*env)->GetIntArrayElements(env, arg2, NULL)) == NULL) goto fail;
+- gtk_widget_style_get((GtkWidget *)arg0, (const gchar *)lparg1, lparg2, arg3);
++ gtk_widget_style_get((GtkWidget *)arg0, (const gchar *)lparg1, lparg2, arg3, (char *)NULL);
+ fail:
+ if (arg2 && lparg2) (*env)->ReleaseIntArrayElements(env, arg2, lparg2, 0);
+ if (arg1 && lparg1) (*env)->ReleaseByteArrayElements(env, arg1, lparg1, 0);
+@@ -12214,7 +12214,7 @@
+ OS_NATIVE_ENTER(env, that, _1gtk_1widget_1style_1get__I_3B_3JI_FUNC);
+ if (arg1) if ((lparg1 = (*env)->GetByteArrayElements(env, arg1, NULL)) == NULL) goto fail;
+ if (arg2) if ((lparg2 = (*env)->GetLongArrayElements(env, arg2, NULL)) == NULL) goto fail;
+- gtk_widget_style_get((GtkWidget *)arg0, (const gchar *)lparg1, lparg2, arg3);
++ gtk_widget_style_get((GtkWidget *)arg0, (const gchar *)lparg1, lparg2, arg3, (char *)NULL);
+ fail:
+ if (arg2 && lparg2) (*env)->ReleaseLongArrayElements(env, arg2, lparg2, 0);
+ if (arg1 && lparg1) (*env)->ReleaseByteArrayElements(env, arg1, lparg1, 0);
diff --git a/dev-java/swt/swt-3.2.ebuild b/dev-java/swt/swt-3.2.ebuild
new file mode 100644
index 000000000000..ac4b481ca279
--- /dev/null
+++ b/dev-java/swt/swt-3.2.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.2.ebuild,v 1.1 2006/07/17 01:40:23 compnerd Exp $
+
+inherit eutils java-pkg
+
+MY_DMF="R-3.2-200606291905"
+MY_VERSION="3.2"
+
+DESCRIPTION="GTK based SWT Library"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="x86? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-gtk-linux-x86.zip )
+ amd64? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-gtk-linux-x86_64.zip )
+ ppc? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-gtk-linux-ppc.zip )"
+
+SLOT="3"
+LICENSE="CPL-1.0 LGPL-2.1 MPL-1.1"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="accessibility cairo gnome mozilla opengl"
+COMMON=">=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6.8
+ accessibility? ( >=dev-libs/atk-1.10.2 )
+ || (
+ (
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ virtual/x11
+ )
+ cairo? ( >=x11-libs/cairo-1.0.2 )
+ gnome? (
+ =gnome-base/libgnome-2*
+ =gnome-base/gnome-vfs-2*
+ =gnome-base/libgnomeui-2*
+ )
+ mozilla? (
+ >=www-client/seamonkey-1.0.2
+ >=dev-libs/nspr-4.6.2
+ )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON}
+ >=dev-util/pkgconfig-0.9
+ dev-java/ant-core
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unzip -jq "${DISTDIR}/${A}" "*src.zip" || die "unable to extract distfile"
+
+ # Unpack the sources
+ einfo "Unpacking src.zip to ${S}"
+ unzip -q src.zip || die "Unable to extract sources"
+
+ # Cleanup the redirtied directory structure
+ rm -rf about_files/
+ rm -f .classpath .project
+
+ # Replace the build.xml to allow compilation without Eclipse tasks
+ cp ${FILESDIR}/build.xml ${S}/build.xml || die "Unable to update build.xml"
+ mkdir ${S}/src && mv ${S}/org ${S}/src || die "Unable to restructure SWT sources"
+
+ # Patch for GCC 4.x warnings
+ epatch ${FILESDIR}/${PN}-3.2-gcc-4.x-warning-fix.patch
+ epatch ${FILESDIR}/${PN}-3.2-cairo-signedness.patch
+}
+
+src_compile() {
+ JAVA_HOME=$(java-config -O)
+
+ # Identify the AWT path
+ # The IBM VMs and the GNU GCC implementations do not store the AWT libraries
+ # in the same location as the rest of the binary VMs.
+ if [[ ! -z "$(java-config --java-version | grep 'IBM')" ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/jre/bin
+ elif [[ ! -z "$(java-config --java-version | grep 'GNU libgcj')" ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/$(get_libdir)
+ else
+ if [[ ${ARCH} == 'x86' ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/jre/lib/i386
+ elif [[ ${ARCH} == 'ppc' ]] ; then
+ export AWT_LIB_PATH=$JAVA_HOME/jre/lib/ppc
+ else
+ export AWT_LIB_PATH=$JAVA_HOME/jre/lib/amd64
+ fi
+ fi
+
+ # Fix the GTK+ Library path
+ export GTKLIBS="$(pkg-config --libs-only-L gtk+-2.0 gthread-2.0) -lgtk-x11-2.0 -lgthread-2.0 -L/usr/$(get_libdir)/X11 -lXtst"
+
+ # Fix the pointer size for AMD64
+ [[ ${ARCH} == 'amd64' ]] && export SWT_PTR_CFLAGS=-DSWT_PTR_SIZE_64
+
+ einfo "Building AWT library"
+ emake -f make_linux.mak make_awt || die "Failed to build AWT support"
+
+ einfo "Building SWT library"
+ emake -f make_linux.mak make_swt || die "Failed to build SWT support"
+
+ if use accessibility ; then
+ einfo "Building JAVA-AT-SPI bridge"
+ emake -f make_linux.mak make_atk || die "Failed to build ATK support"
+ fi
+
+ if use gnome ; then
+ einfo "Building GNOME VFS support"
+ emake -f make_linux.mak make_gnome || die "Failed to build GNOME VFS support"
+ fi
+
+ if use mozilla ; then
+ export GECKO_INCLUDES="-I/usr/$(get_libdir)/seamonkey/include/xpcom \
+ -I/usr/include/nspr \
+ -I/usr/$(get_libdir)/seamonkey/include/embed_base \
+ -I/usr/$(get_libdir)/seamonkey/include/string"
+
+ einfo "Building the Mozilla component"
+ emake -f make_linux.mak make_mozilla || die "Failed to build Mozilla support"
+ fi
+
+ if use cairo ; then
+ einfo "Building CAIRO support"
+ emake -f make_linux.mak make_cairo || die "Unable to build CAIRO support"
+ fi
+
+ if use opengl ; then
+ einfo "Building OpenGL component"
+ emake -f make_linux.mak make_glx || die "Unable to build OpenGL component"
+ fi
+
+ einfo "Building JNI libraries"
+ ant compile || die "Failed to compile JNI interfaces"
+
+ einfo "Creating missing files"
+ cp ${FILESDIR}/SWTMessages.properties ${S}/build/org/eclipse/swt/internal/
+ echo -n "version 3.232" >> ${S}/build/version.txt
+
+ einfo "Packing JNI libraries"
+ ant jar || die "Failed to create JNI jar"
+}
+
+src_install() {
+ java-pkg_dojar swt.jar
+
+ java-pkg_sointo /usr/$(get_libdir)
+ java-pkg_doso *.so
+
+ dohtml about.html
+}
+
+pkg_postinst() {
+ if use cairo; then
+ ewarn
+ ewarn "CAIRO Support is experimental! We are not responsible if"
+ ewarn "enabling support for CAIRO corrupts your Gentoo install,"
+ ewarn "if it blows up your computer, or if it becomes sentient"
+ ewarn "and chases you down the street yelling random binary!"
+ ewarn
+ ebeep 5
+ fi
+}